summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-12 15:28:09 +0100
committerRemi Collet <remi@remirepo.net>2018-12-12 15:28:09 +0100
commit3a4db4cf331a91ffc04876c0395ebf8c0ddfc88a (patch)
treeefedf0a1d4668e65506e8e64a083fb2105abbaea
parent89e824ba11496370a34c83e2fa6cf7a8bd9f27f5 (diff)
ignore failing test with 7.3, reported as https://github.com/hnw/php-timecop/issues/42
-rw-r--r--php-pecl-timecop.spec23
1 files changed, 19 insertions, 4 deletions
diff --git a/php-pecl-timecop.spec b/php-pecl-timecop.spec
index 83d1d0b..10ac6b0 100644
--- a/php-pecl-timecop.spec
+++ b/php-pecl-timecop.spec
@@ -23,7 +23,7 @@
Summary: Time travel and freezing extension
Name: %{?sub_prefix}php-pecl-timecop
Version: 1.2.10
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -164,7 +164,6 @@ done
%check
-cd NTS
if [ -f %{php_extdir}/calendar.so ]; then
MOD="-d extension=calendar.so"
fi
@@ -175,22 +174,34 @@ fi
--modules | grep %{pecl_name}
%if %{with_tests}
+%if "%{php_version}" > "7.3"
+rm ?TS/tests/date_007.phpt
+rm ?TS/tests/date_008.phpt
+rm ?TS/tests/date_override_007.phpt
+rm ?TS/tests/date_override_008.phpt
+rm ?TS/tests/immutable_007.phpt
+rm ?TS/tests/immutable_008.phpt
+rm ?TS/tests/immutable_override_007.phpt
+rm ?TS/tests/immutable_override_008.phpt
+%endif
+
+cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n $MOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff || : ignore
+%{__php} -n run-tests.php --show-diff
%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
%if %{with_tests}
+cd ../ZTS
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n $MOD -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
@@ -236,6 +247,10 @@ fi
%changelog
+* Wed Dec 12 2018 Remi Collet <remi@remirepo.net> - 1.2.10-4
+- ignore failing test with 7.3, reported as
+ https://github.com/hnw/php-timecop/issues/42
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 1.2.10-3
- rebuild for 7.3.0beta2 new ABI