summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-03-28 07:41:35 +0100
committerRemi Collet <remi@php.net>2025-03-28 07:41:35 +0100
commitc35947d37ad8e902283266a0af69d0fa41a73f95 (patch)
treedf5942da134292863b3a0d0b809b9241a6129b15
parent1c9285a9fe7d039472840053ac1a16b7e571a4a0 (diff)
update to 3.0.6
re-license spec file to CECILL-2.1 open https://github.com/RubixML/Tensor/issues/49 PHP 7.4 build failure
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-tensor.spec51
3 files changed, 21 insertions, 36 deletions
diff --git a/PHPINFO b/PHPINFO
index 6fcf33c..bf5e0cd 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -6,5 +6,5 @@ A library and extension that provides objects for scientific computing in PHP.
tensor => enabled
Author => The Rubix ML Community
Version => 3.0.5
-Build Date => Mar 19 2024 00:00:00
-Powered by Zephir => Version 0.17.0-$Id$
+Build Date => Mar 28 2025 00:00:00
+Powered by Zephir => Version 0.18.0-$Id$
diff --git a/REFLECTION b/REFLECTION
index a4f30b6..4e2426a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #89 tensor version 3.0.5 ] {
+Extension [ <persistent> extension #112 tensor version 3.0.5 ] {
- Dependencies {
}
diff --git a/php-pecl-tensor.spec b/php-pecl-tensor.spec
index 75358f4..c97ccc3 100644
--- a/php-pecl-tensor.spec
+++ b/php-pecl-tensor.spec
@@ -1,8 +1,8 @@
# remirepo spec file for php-pecl-tensor
#
-# Copyright (c) 2020-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2020-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -13,7 +13,7 @@
# After 20-json
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.0.5
+%global upstream_version 3.0.6
#global upstream_prever alpha2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../ext/configure
@@ -21,7 +21,7 @@
Summary: Objects for scientific computing in PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{sources}.tgz
@@ -31,8 +31,7 @@ Patch1: tensor-libs.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.4
-BuildRequires: %{?scl_prefix}php-devel < 8.3
+BuildRequires: (%{?scl_prefix}php-devel >= 7.4 with %{?scl_prefix}php-devel < 8.4)
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
BuildRequires: openblas-devel
@@ -62,7 +61,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
@@ -98,6 +97,7 @@ export CFLAGS="%{optflags} -Wno-incompatible-pointer-types"
cd %{sources}/ext
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
%configure \
@@ -105,7 +105,7 @@ cd ../NTS
--with-libdir=%{_lib} \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
@@ -114,14 +114,14 @@ cd ../ZTS
--with-libdir=%{_lib} \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
%install
%{?dtsenable}
-make -C %{sources}/NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C %{sources}/NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -130,7 +130,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C %{sources}/ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C %{sources}/ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -141,26 +141,6 @@ do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -178,7 +158,7 @@ fi
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -192,6 +172,11 @@ fi
%changelog
+* Fri Mar 28 2025 Remi Collet <remi@remirepo.net> - 3.0.6-1
+- update to 3.0.6
+- re-license spec file to CECILL-2.1
+- open https://github.com/RubixML/Tensor/issues/49 PHP 7.4 build failure
+
* Tue Mar 19 2024 Remi Collet <remi@remirepo.net> - 3.0.5-1
- update to 3.0.5