summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-01 06:47:18 +0100
committerRemi Collet <remi@remirepo.net>2021-03-01 06:47:18 +0100
commitb2ab23773ac62a8677266021125f3339024806a8 (patch)
tree4b590d02546fbae98548240ddfd37dc6519fae69
parentb7081a59cdea218945e5232e1810a99721cbec08 (diff)
update to 2.2.0
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION309
-rw-r--r--php-pecl-tensor.spec6
3 files changed, 310 insertions, 9 deletions
diff --git a/PHPINFO b/PHPINFO
index 6a1b006..cc056b3 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,6 +5,6 @@ tensor
Tensor is a library and extension that provides objects for scientific computing in PHP.
tensor => enabled
Author => Andrew DalPino
-Version => 2.1.4
-Build Date => Feb 21 2021 00:00:00
+Version => 2.2.0
+Build Date => Mar 1 2021 00:00:00
Powered by Zephir => Version 0.12.20-$Id$
diff --git a/REFLECTION b/REFLECTION
index b4d468c..127cd1a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,9 +1,9 @@
-Extension [ <persistent> extension #105 tensor version 2.1.4 ] {
+Extension [ <persistent> extension #104 tensor version 2.2.0 ] {
- Dependencies {
}
- - Classes [16] {
+ - Classes [21] {
Interface [ <internal:tensor> interface Tensor\Arithmetic ] {
- Constants [0] {
@@ -352,6 +352,47 @@ Extension [ <persistent> extension #105 tensor version 2.1.4 ] {
}
}
+ Interface [ <internal:tensor> interface Tensor\Exceptions\TensorException extends Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [8] {
+ Method [ <internal:Core, inherits Throwable> abstract public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Throwable> abstract public method __toString ] {
+ }
+ }
+ }
+
Interface [ <internal:tensor> interface Tensor\Tensor extends Tensor\ArrayLike, Countable, Traversable, IteratorAggregate, ArrayAccess, Tensor\Arithmetic, Tensor\Comparable, Tensor\Functional, Tensor\Trigonometric, Tensor\Statistical ] {
- Constants [4] {
@@ -670,6 +711,63 @@ Extension [ <persistent> extension #105 tensor version 2.1.4 ] {
}
}
+ Class [ <internal:tensor> class Tensor\Exceptions\InvalidArgumentException extends InvalidArgumentException implements Throwable, Tensor\Exceptions\TensorException ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:tensor> <iterateable> class Tensor\Vector implements Tensor\Tensor, Tensor\Statistical, Tensor\Trigonometric, Tensor\Functional, Tensor\Comparable, Tensor\Arithmetic, ArrayAccess, IteratorAggregate, Traversable, Countable, Tensor\ArrayLike ] {
- Constants [4] {
@@ -2603,7 +2701,7 @@ Extension [ <persistent> extension #105 tensor version 2.1.4 ] {
- Parameters [2] {
Parameter #0 [ <required> Tensor\Matrix $a ]
- Parameter #1 [ <required> bool $normalize ]
+ Parameter #1 [ <optional> bool $symmetric ]
}
- Return [ Tensor\Decompositions\Eigen ]
}
@@ -2627,7 +2725,7 @@ Extension [ <persistent> extension #105 tensor version 2.1.4 ] {
- Parameters [0] {
}
- - Return [ Tensor\Matrix ]
+ - Return [ array ]
}
Method [ <internal:tensor> public method eigenvectors ] {
@@ -2696,6 +2794,191 @@ Extension [ <persistent> extension #105 tensor version 2.1.4 ] {
}
}
+ Class [ <internal:tensor> class Tensor\Decompositions\Svd ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:tensor> static public method decompose ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Tensor\Matrix $a ]
+ }
+ - Return [ Tensor\Decompositions\Svd ]
+ }
+ }
+
+ - Properties [3] {
+ Property [ <default> protected $u ]
+ Property [ <default> protected $singularValues ]
+ Property [ <default> protected $vT ]
+ }
+
+ - Methods [6] {
+ Method [ <internal:tensor, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Tensor\Matrix $u ]
+ Parameter #1 [ <required> array $singularValues ]
+ Parameter #2 [ <required> Tensor\Matrix $vT ]
+ }
+ }
+
+ Method [ <internal:tensor> public method u ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Tensor\Matrix ]
+ }
+
+ Method [ <internal:tensor> public method singularValues ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:tensor> public method s ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Tensor\Matrix ]
+ }
+
+ Method [ <internal:tensor> public method v ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Tensor\Matrix ]
+ }
+
+ Method [ <internal:tensor> public method vT ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Tensor\Matrix ]
+ }
+ }
+ }
+
+ Class [ <internal:tensor> class Tensor\Exceptions\DimensionalityMismatch extends Tensor\Exceptions\InvalidArgumentException implements Tensor\Exceptions\TensorException, Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:tensor> class Tensor\Exceptions\RuntimeException extends RuntimeException implements Throwable, Tensor\Exceptions\TensorException ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:tensor> <iterateable> class Tensor\Matrix implements Tensor\Tensor, Tensor\Statistical, Tensor\Trigonometric, Tensor\Functional, Tensor\Comparable, Tensor\Arithmetic, ArrayAccess, IteratorAggregate, Traversable, Countable, Tensor\ArrayLike ] {
- Constants [4] {
@@ -2848,7 +3131,7 @@ Extension [ <persistent> extension #105 tensor version 2.1.4 ] {
Property [ <default> protected $n ]
}
- - Methods [148] {
+ - Methods [150] {
Method [ <internal:tensor, ctor> public method __construct ] {
- Parameters [2] {
@@ -3010,6 +3293,13 @@ Extension [ <persistent> extension #105 tensor version 2.1.4 ] {
- Return [ Tensor\Matrix ]
}
+ Method [ <internal:tensor> public method pseudoinverse ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Tensor\Matrix ]
+ }
+
Method [ <internal:tensor> public method det ] {
}
@@ -3104,11 +3394,18 @@ Extension [ <persistent> extension #105 tensor version 2.1.4 ] {
Method [ <internal:tensor> public method eig ] {
- Parameters [1] {
- Parameter #0 [ <optional> bool $normalize ]
+ Parameter #0 [ <optional> bool $symmetric ]
}
- Return [ Tensor\Decompositions\Eigen ]
}
+ Method [ <internal:tensor> public method svd ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Tensor\Decompositions\Svd ]
+ }
+
Method [ <internal:tensor> public method solve ] {
- Parameters [1] {
diff --git a/php-pecl-tensor.spec b/php-pecl-tensor.spec
index 06fd253..3229f90 100644
--- a/php-pecl-tensor.spec
+++ b/php-pecl-tensor.spec
@@ -16,7 +16,7 @@
# After 20-json
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 2.1.4
+%global upstream_version 2.2.0
#global upstream_prever alpha2
Summary: Objects for scientific computing in PHP
@@ -82,6 +82,7 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
cd NTS
+sed -e 's/\r//' -i ext/config.m4
%patch0 -p1 -b .headers
%patch1 -p1 -b .libs
@@ -203,6 +204,9 @@ fi
%changelog
+* Mon Mar 1 2021 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+
* Sun Feb 21 2021 Remi Collet <remi@remirepo.net> - 2.1.4-1
- update to 2.1.4