summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-05-25 08:48:14 +0200
committerRemi Collet <remi@remirepo.net>2021-05-25 08:48:14 +0200
commit0373bcdec3b3fc1c4859dcade848c3047df4eda3 (patch)
tree4feb9e7fe49032cd20f79ced30edec021463f443
parent4f8358907bf59c669496a0db96019bfc7c7ab444 (diff)
update to 2.2.3
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-tensor.spec5
-rw-r--r--tensor-headers.patch4
-rw-r--r--tensor-libs.patch4
5 files changed, 12 insertions, 9 deletions
diff --git a/PHPINFO b/PHPINFO
index 6008ee3..ee6e28c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
tensor
-Tensor is a library and extension that provides objects for scientific computing in PHP.
+A library and extension that provides objects for scientific computing in PHP.
tensor => enabled
Author => Andrew DalPino
-Version => 2.2.0
-Build Date => Mar 8 2021 00:00:00
+Version => 2.2.3
+Build Date => May 25 2021 00:00:00
Powered by Zephir => Version 0.12.21-$Id$
diff --git a/REFLECTION b/REFLECTION
index d4cac8c..f900ae0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #103 tensor version 2.2.0 ] {
+Extension [ <persistent> extension #102 tensor version 2.2.3 ] {
- Dependencies {
}
diff --git a/php-pecl-tensor.spec b/php-pecl-tensor.spec
index e1faa26..e1718df 100644
--- a/php-pecl-tensor.spec
+++ b/php-pecl-tensor.spec
@@ -16,7 +16,7 @@
# After 20-json
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 2.2.1
+%global upstream_version 2.2.3
#global upstream_prever alpha2
Summary: Objects for scientific computing in PHP
@@ -204,6 +204,9 @@ fi
%changelog
+* Tue May 25 2021 Remi Collet <remi@remirepo.net> - 2.2.3-1
+- update to 2.2.3
+
* Mon Mar 8 2021 Remi Collet <remi@remirepo.net> - 2.2.1-1
- update to 2.2.1
diff --git a/tensor-headers.patch b/tensor-headers.patch
index e2fed73..c65444b 100644
--- a/tensor-headers.patch
+++ b/tensor-headers.patch
@@ -35,5 +35,5 @@ index ae03d9c..2b130c0 100644
+ PHP_ADD_INCLUDE($OPENBLAS_DIR)
+ fi
- if ! test "x-lopenblas -llapacke -lgfortran -lpthread" = "x"; then
- PHP_EVAL_LIBLINE(-lopenblas -llapacke -lgfortran -lpthread, TENSOR_SHARED_LIBADD)
+ if ! test "x-lopenblas -llapacke -lgfortran" = "x"; then
+ PHP_EVAL_LIBLINE(-lopenblas -llapacke -lgfortran, TENSOR_SHARED_LIBADD)
diff --git a/tensor-libs.patch b/tensor-libs.patch
index 42fe7b3..319fb0f 100644
--- a/tensor-libs.patch
+++ b/tensor-libs.patch
@@ -6,8 +6,8 @@ index 2b130c0..90b7e1c 100644
PHP_ADD_INCLUDE($OPENBLAS_DIR)
fi
-- if ! test "x-lopenblas -llapacke -lgfortran -lpthread" = "x"; then
-- PHP_EVAL_LIBLINE(-lopenblas -llapacke -lgfortran -lpthread, TENSOR_SHARED_LIBADD)
+- if ! test "x-lopenblas -llapacke -lgfortran" = "x"; then
+- PHP_EVAL_LIBLINE(-lopenblas -llapacke -lgfortran, TENSOR_SHARED_LIBADD)
- fi
+ PHP_EVAL_LIBLINE(-lopenblas, TENSOR_SHARED_LIBADD)