summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-10 15:08:37 +0100
committerRemi Collet <remi@php.net>2022-11-10 15:08:37 +0100
commitd073a413b8cadd5438e62073f202fb81c8fafeaf (patch)
tree32ed0d9b7d48749203dde8715b68fde5354666cf
parentbe3f1bafb88de5a066ea87a61f28805cf9e86929 (diff)
update to 1.3.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION74
-rw-r--r--php-pecl-teds.spec5
3 files changed, 46 insertions, 35 deletions
diff --git a/PHPINFO b/PHPINFO
index 622fbb3..c6f1065 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 1.2.8
+teds version => 1.3.0
diff --git a/REFLECTION b/REFLECTION
index 17d9fed..c95e7e8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,10 +1,10 @@
-Extension [ <persistent> extension #100 teds version 1.2.8 ] {
+Extension [ <persistent> extension #101 teds version 1.3.0 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
- Parameters [2] {
- Parameter #0 [ <required> iterable $iterable ]
+ Parameter #0 [ <required> Traversable|array $iterable ]
Parameter #1 [ <optional> ?callable $callback = null ]
}
- Return [ bool ]
@@ -12,7 +12,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Function [ <internal:teds> function Teds\all ] {
- Parameters [2] {
- Parameter #0 [ <required> iterable $iterable ]
+ Parameter #0 [ <required> Traversable|array $iterable ]
Parameter #1 [ <optional> ?callable $callback = null ]
}
- Return [ bool ]
@@ -20,7 +20,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Function [ <internal:teds> function Teds\none ] {
- Parameters [2] {
- Parameter #0 [ <required> iterable $iterable ]
+ Parameter #0 [ <required> Traversable|array $iterable ]
Parameter #1 [ <optional> ?callable $callback = null ]
}
- Return [ bool ]
@@ -28,7 +28,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Function [ <internal:teds> function Teds\includes_value ] {
- Parameters [2] {
- Parameter #0 [ <required> iterable $iterable ]
+ Parameter #0 [ <required> Traversable|array $iterable ]
Parameter #1 [ <required> mixed $value ]
}
- Return [ bool ]
@@ -36,7 +36,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Function [ <internal:teds> function Teds\fold ] {
- Parameters [3] {
- Parameter #0 [ <required> iterable $iterable ]
+ Parameter #0 [ <required> Traversable|array $iterable ]
Parameter #1 [ <required> callable $callback ]
Parameter #2 [ <required> mixed $initial ]
}
@@ -45,7 +45,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Function [ <internal:teds> function Teds\find ] {
- Parameters [3] {
- Parameter #0 [ <required> iterable $iterable ]
+ Parameter #0 [ <required> Traversable|array $iterable ]
Parameter #1 [ <required> callable $callback ]
Parameter #2 [ <optional> mixed $default = null ]
}
@@ -54,7 +54,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Function [ <internal:teds> function Teds\unique_values ] {
- Parameters [1] {
- Parameter #0 [ <required> iterable $iterable ]
+ Parameter #0 [ <required> Traversable|array $iterable ]
}
- Return [ array ]
}
@@ -87,6 +87,14 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
}
- Return [ int ]
}
+ Function [ <internal:teds> function Teds\strict_equals ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $v1 ]
+ Parameter #1 [ <required> mixed $v2 ]
+ }
+ - Return [ bool ]
+ }
Function [ <internal:teds> function Teds\binary_search ] {
- Parameters [4] {
@@ -628,7 +636,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -997,7 +1005,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <required> iterable $iterator ]
+ Parameter #0 [ <required> Traversable|array $iterator ]
}
}
@@ -1162,7 +1170,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -1392,7 +1400,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds> static public method fromPairs ] {
- Parameters [1] {
- Parameter #0 [ <required> iterable $pairs ]
+ Parameter #0 [ <required> Traversable|array $pairs ]
}
- Return [ Teds\ImmutableIterable ]
}
@@ -1413,7 +1421,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <required> iterable $iterator ]
+ Parameter #0 [ <required> Traversable|array $iterator ]
}
}
@@ -1578,7 +1586,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -1824,7 +1832,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -1988,7 +1996,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -2241,7 +2249,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -2411,7 +2419,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -2547,7 +2555,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds> static public method fromPairs ] {
- Parameters [1] {
- Parameter #0 [ <required> iterable $pairs ]
+ Parameter #0 [ <required> Traversable|array $pairs ]
}
- Return [ Teds\MutableIterable ]
}
@@ -2568,7 +2576,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -2789,7 +2797,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -3005,7 +3013,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds> static public method fromPairs ] {
- Parameters [1] {
- Parameter #0 [ <required> iterable $pairs ]
+ Parameter #0 [ <required> Traversable|array $pairs ]
}
- Return [ Teds\StrictTreeMap ]
}
@@ -3026,7 +3034,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -3285,7 +3293,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -3460,7 +3468,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $values = [] ]
+ Parameter #0 [ <optional> Traversable|array $values = [] ]
}
}
@@ -3606,7 +3614,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $values = [] ]
+ Parameter #0 [ <optional> Traversable|array $values = [] ]
}
}
@@ -3739,7 +3747,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds> static public method fromPairs ] {
- Parameters [1] {
- Parameter #0 [ <required> iterable $pairs ]
+ Parameter #0 [ <required> Traversable|array $pairs ]
}
- Return [ Teds\StrictSortedVectorMap ]
}
@@ -3760,7 +3768,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -4005,7 +4013,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -4153,7 +4161,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds> static public method fromPairs ] {
- Parameters [1] {
- Parameter #0 [ <required> iterable $pairs ]
+ Parameter #0 [ <required> Traversable|array $pairs ]
}
- Return [ Teds\StrictHashMap ]
}
@@ -4174,7 +4182,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -4349,7 +4357,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
@@ -4468,7 +4476,7 @@ Extension [ <persistent> extension #100 teds version 1.2.8 ] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> iterable $iterator = [] ]
+ Parameter #0 [ <optional> Traversable|array $iterator = [] ]
}
}
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index e4cb2a0..20d7dfc 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.2.8
+%global upstream_version 1.3.0
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -186,6 +186,9 @@ fi
%changelog
+* Thu Nov 10 2022 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+
* Thu Oct 27 2022 Remi Collet <remi@remirepo.net> - 1.2.8-1
- update to 1.2.8 (no change)