summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-08-25 10:23:13 +0200
committerRemi Collet <remi@remirepo.net>2021-08-25 10:23:13 +0200
commitbcbfb1b51bce1df98fc79d86377d9663e926caf3 (patch)
tree0a1f2068488042cbe7e8a6c7b29000577b7896b9
initial package
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--PHPINFO5
-rw-r--r--REFLECTION669
-rw-r--r--php-pecl-teds.spec199
5 files changed, 886 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..3ea0a39
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,5 @@
+
+teds
+
+teds support => enabled
+teds version => 0.1.0a1
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..924bd2c
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,669 @@
+Extension [ <persistent> extension #81 teds version 0.1.0a1 ] {
+
+ - Functions {
+ Function [ <internal:teds> function Teds\any ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> iterable $iterable ]
+ Parameter #1 [ <optional> ?callable $callback = null ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:teds> function Teds\all ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> iterable $iterable ]
+ Parameter #1 [ <optional> ?callable $callback = null ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:teds> function Teds\none ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> iterable $iterable ]
+ Parameter #1 [ <optional> ?callable $callback = null ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:teds> function Teds\includes_value ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> iterable $iterable ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:teds> function Teds\fold ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> iterable $iterable ]
+ Parameter #1 [ <required> callable $callback ]
+ Parameter #2 [ <required> mixed $initial ]
+ }
+ - Return [ mixed ]
+ }
+ Function [ <internal:teds> function Teds\find ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> iterable $iterable ]
+ Parameter #1 [ <required> callable $callback ]
+ Parameter #2 [ <optional> mixed $default = null ]
+ }
+ - Return [ mixed ]
+ }
+ }
+
+ - Classes [4] {
+ Class [ <internal:teds> <iterateable> final class Teds\Deque implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\Deque ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [21] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method capacity ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method clear ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method pushBack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method pushFront ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method popBack ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method popFront ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method valueAt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method setValueAt ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method indexOf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ int|false ]
+ }
+
+ Method [ <internal:teds> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
+ Class [ <internal:teds> <iterateable> final class Teds\ImmutableKeyValueSequence implements IteratorAggregate, Traversable, Countable, JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:teds> static public method fromPairs ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> iterable $pairs ]
+ }
+ - Return [ Teds\ImmutableKeyValueSequence ]
+ }
+
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\ImmutableKeyValueSequence ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [11] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> iterable $iterator ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method toPairs ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method keys ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method keyAt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method valueAt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
+ Class [ <internal:teds> <iterateable> final class Teds\ImmutableSequence implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\ImmutableSequence ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [14] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> iterable $iterator ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method valueAt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method indexOf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ int|false ]
+ }
+
+ Method [ <internal:teds> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
+ Class [ <internal:teds> <iterateable> final class Teds\Vector implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\Vector ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [21] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method capacity ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method clear ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method setSize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $size ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method push ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method pop ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method valueAt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method setValueAt ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $offset ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method indexOf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ int|false ]
+ }
+
+ Method [ <internal:teds> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method shrinkToFit ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
new file mode 100644
index 0000000..77fa16d
--- /dev/null
+++ b/php-pecl-teds.spec
@@ -0,0 +1,199 @@
+# remirepo spec file for php-pecl-teds
+#
+# Copyright (c) 2021 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
+%if 0%{?scl:1}
+%scl_package php-pecl-teds
+%endif
+
+%bcond_without tests
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name teds
+%global ini_name 40-%{pecl_name}.ini
+
+%global upstream_version 0.1.0
+%global upstream_prever a1
+
+Summary: Tentative Extra Data Structures
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+
+License: BSD
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+
+%description
+teds (Tentative Extra Data Structures) is a collection of data structures
+and iterable functionality.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/COPYING/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+
+# Check version as upstream often forget to update this
+extver=$(sed -n '/define PHP_TEDS_VERSION/{s/.* "//;s/".*$//;p}' php_teds.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
+ : Error: Upstream version is ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+peclconf() {
+%configure \
+ --enable-teds \
+ --with-php-config=$1
+}
+
+cd NTS
+%{_bindir}/phpize
+peclconf %{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+peclconf %{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# Install the ZTS stuff
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+%{_bindir}/php --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%endif
+
+%if %{with tests}
+cd NTS
+: Run upstream test suite
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+%{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
+%endif
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/COPYING}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%{php_ztsextdir}/%{pecl_name}.so
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%changelog
+* Wed Aug 25 2021 Remi Collet <remi@remirepo.net> - 0.1.0~a1-1
+- initial package