summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-24 07:11:50 +0100
committerRemi Collet <remi@php.net>2022-01-24 07:11:50 +0100
commit7db5f347837ec10a88789e85ac474c8c918932f1 (patch)
treee22f6542d762edd57bf04fae2ed18ac2d121ed49
parent1e6b489e0295e05d5eb104b9718486c5f6c3758e (diff)
update to 0.8.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION379
-rw-r--r--php-pecl-teds.spec5
3 files changed, 378 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index cbd559e..56952c8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 0.6.0
+teds version => 0.8.0
diff --git a/REFLECTION b/REFLECTION
index e0aeeba..d6d35bd 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 teds version 0.6.0 ] {
+Extension [ <persistent> extension #99 teds version 0.8.0 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -51,6 +51,13 @@ Extension [ <persistent> extension #99 teds version 0.6.0 ] {
}
- Return [ mixed ]
}
+ Function [ <internal:teds> function Teds\unique_values ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> iterable $iterable ]
+ }
+ - Return [ array ]
+ }
Function [ <internal:teds> function Teds\array_value_first ] {
- Parameters [1] {
@@ -80,9 +87,19 @@ Extension [ <persistent> extension #99 teds version 0.6.0 ] {
}
- Return [ int ]
}
+ Function [ <internal:teds> function Teds\binary_search ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> array $array ]
+ Parameter #1 [ <required> mixed $target ]
+ Parameter #2 [ <optional> ?callable $comparer = null ]
+ Parameter #3 [ <optional> bool $useKey = false ]
+ }
+ - Return [ array ]
+ }
}
- - Classes [11] {
+ - Classes [13] {
Class [ <internal:teds> <iterateable> final class Teds\Deque implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
- Constants [0] {
@@ -1141,7 +1158,7 @@ Extension [ <persistent> extension #99 teds version 0.6.0 ] {
}
}
- Class [ <internal:teds> <iterateable> class Teds\StableMinHeap extends SplMinHeap implements Iterator, Traversable, Countable ] {
+ Class [ <internal:teds> <iterateable> class Teds\StableMinHeap extends SplHeap implements Countable, Traversable, Iterator ] {
- Constants [0] {
}
@@ -1156,7 +1173,7 @@ Extension [ <persistent> extension #99 teds version 0.6.0 ] {
}
- Methods [14] {
- Method [ <internal:teds, overwrites SplMinHeap, prototype SplHeap> public method compare ] {
+ Method [ <internal:teds, overwrites SplHeap, prototype SplHeap> public method compare ] {
- Parameters [2] {
Parameter #0 [ <required> mixed $value1 ]
@@ -1246,7 +1263,7 @@ Extension [ <persistent> extension #99 teds version 0.6.0 ] {
}
}
- Class [ <internal:teds> <iterateable> class Teds\StableMaxHeap extends SplMinHeap implements Iterator, Traversable, Countable ] {
+ Class [ <internal:teds> <iterateable> class Teds\StableMaxHeap extends SplHeap implements Countable, Traversable, Iterator ] {
- Constants [0] {
}
@@ -1261,7 +1278,7 @@ Extension [ <persistent> extension #99 teds version 0.6.0 ] {
}
- Methods [14] {
- Method [ <internal:teds, overwrites SplMinHeap, prototype SplHeap> public method compare ] {
+ Method [ <internal:teds, overwrites SplHeap, prototype SplHeap> public method compare ] {
- Parameters [2] {
Parameter #0 [ <required> mixed $value1 ]
@@ -1351,6 +1368,356 @@ Extension [ <persistent> extension #99 teds version 0.6.0 ] {
}
}
+ Class [ <internal:teds> <iterateable> final class Teds\StableSortedListMap implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:teds> static public method fromPairs ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> iterable $pairs ]
+ }
+ - Return [ Teds\StableSortedListMap ]
+ }
+
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\StableSortedListMap ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [24] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method clear ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method toPairs ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method keys ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method bottom ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method bottomKey ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method top ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method topKey ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method pop ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method shift ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $key ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method get ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $key ]
+ Parameter #1 [ <optional> mixed $default = null ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method containsValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
+ Class [ <internal:teds> <iterateable> final class Teds\StableSortedListSet implements IteratorAggregate, Traversable, Countable, JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\StableSortedListSet ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [16] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method clear ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method bottom ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method top ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method pop ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method shift ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method contains ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method remove ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
Class [ <internal:teds> <iterateable> final class Teds\StrictMap implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
- Constants [0] {
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index 686955b..3d849a6 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,7 +19,7 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.6.0
+%global upstream_version 0.8.0
#global upstream_prever a1
Summary: Tentative Extra Data Structures
@@ -194,6 +194,9 @@ fi
%changelog
+* Mon Jan 24 2022 Remi Collet <remi@remirepo.net> - 0.8.0-1
+- update to 0.8.0
+
* Tue Jan 18 2022 Remi Collet <remi@remirepo.net> - 0.6.0-1
- update to 0.6.0