summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-11 08:14:38 +0200
committerRemi Collet <remi@remirepo.net>2021-09-11 08:14:38 +0200
commit51ae2f86d26b4951929e35535265bc892ad59e25 (patch)
tree2e97578e73c5aaa9cc682ec195a95342805761a0
parentf143a9c7927bc5c37a36f5f0ed169c3590ae0ad6 (diff)
update to 0.1.1 (stable)
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION245
-rw-r--r--php-pecl-teds.spec9
3 files changed, 249 insertions, 7 deletions
diff --git a/PHPINFO b/PHPINFO
index 3ea0a39..abf08d7 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
teds
teds support => enabled
-teds version => 0.1.0a1
+teds version => 0.1.1
diff --git a/REFLECTION b/REFLECTION
index 924bd2c..7f19be4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #81 teds version 0.1.0a1 ] {
+Extension [ <persistent> extension #82 teds version 0.1.1 ] {
- Functions {
Function [ <internal:teds> function Teds\any ] {
@@ -53,7 +53,7 @@ Extension [ <persistent> extension #81 teds version 0.1.0a1 ] {
}
}
- - Classes [4] {
+ - Classes [5] {
Class [ <internal:teds> <iterateable> final class Teds\Deque implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
- Constants [0] {
@@ -267,7 +267,7 @@ Extension [ <persistent> extension #81 teds version 0.1.0a1 ] {
- Properties [0] {
}
- - Methods [11] {
+ - Methods [15] {
Method [ <internal:teds, ctor> public method __construct ] {
- Parameters [1] {
@@ -341,6 +341,38 @@ Extension [ <persistent> extension #81 teds version 0.1.0a1 ] {
- Return [ mixed ]
}
+ Method [ <internal:teds> public method indexOfKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ int|false ]
+ }
+
+ Method [ <internal:teds> public method indexOfValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ int|false ]
+ }
+
+ Method [ <internal:teds> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method containsValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
- Parameters [0] {
@@ -481,6 +513,213 @@ Extension [ <persistent> extension #81 teds version 0.1.0a1 ] {
}
}
+ Class [ <internal:teds> <iterateable> final class Teds\KeyValueVector implements IteratorAggregate, Traversable, Countable, JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:teds> static public method fromPairs ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> iterable $pairs ]
+ }
+ - Return [ Teds\KeyValueVector ]
+ }
+
+ Method [ <internal:teds> static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $array ]
+ }
+ - Return [ Teds\KeyValueVector ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [23] {
+ Method [ <internal:teds, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> iterable $iterator = [] ]
+ }
+ }
+
+ Method [ <internal:teds, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ InternalIterator ]
+ }
+
+ Method [ <internal:teds, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method capacity ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:teds> public method clear ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method setSize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $size ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method toPairs ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method push ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> mixed $key ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method pop ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method keys ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method values ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:teds> public method keyAt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method valueAt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $offset ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:teds> public method setKeyAt ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> mixed $key ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method setValueAt ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $offset ]
+ Parameter #1 [ <required> mixed $value ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds> public method indexOfKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ int|false ]
+ }
+
+ Method [ <internal:teds> public method indexOfValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ int|false ]
+ }
+
+ Method [ <internal:teds> public method containsKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $key ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method containsValue ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> mixed $value ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:teds> public method shrinkToFit ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:teds, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
Class [ <internal:teds> <iterateable> final class Teds\Vector implements IteratorAggregate, Traversable, Countable, JsonSerializable, ArrayAccess ] {
- Constants [0] {
diff --git a/php-pecl-teds.spec b/php-pecl-teds.spec
index bee04cc..a49384f 100644
--- a/php-pecl-teds.spec
+++ b/php-pecl-teds.spec
@@ -19,13 +19,13 @@
%global pecl_name teds
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.1.0
-%global upstream_prever a1
+%global upstream_version 0.1.1
+#global upstream_prever a1
Summary: Tentative Extra Data Structures
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
@@ -195,6 +195,9 @@ fi
%changelog
+* Sat Sep 11 2021 Remi Collet <remi@remirepo.net> - 0.1.1-1
+- update to 0.1.1 (stable)
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 0.1.0~a1-2
- rebuild for 8.1.0RC1