summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-13 08:20:04 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-13 08:20:04 +0100
commit6270b101f56f32ec863bc847c14e575d800b90d6 (patch)
tree40f83a4b54c0a21c5b1e7277d67a88ee4985712a
parentcfdc0f431df55869bb95ad2077c27eabe19e2a53 (diff)
php-pecl-taint: 2.0.1 (php 7, beta)
-rw-r--r--REFLECTION39
-rw-r--r--php-pecl-taint.spec13
2 files changed, 47 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..0ba7ef0
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,39 @@
+Extension [ <persistent> extension #55 taint version 2.0.1 ] {
+
+ - Dependencies {
+ Dependency [ xdebug (Conflicts) ]
+ }
+
+ - INI {
+ Entry [ taint.enable <SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ taint.error_level <ALL> ]
+ Current = '512'
+ }
+ }
+
+ - Functions {
+ Function [ <internal:taint> function taint ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> &$string ]
+ Parameter #1 [ <optional> &$... ]
+ }
+ }
+ Function [ <internal:taint> function untaint ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> &$string ]
+ Parameter #1 [ <optional> &$... ]
+ }
+ }
+ Function [ <internal:taint> function is_tainted ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $string ]
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-taint.spec b/php-pecl-taint.spec
index 8699e5e..364b56e 100644
--- a/php-pecl-taint.spec
+++ b/php-pecl-taint.spec
@@ -10,18 +10,18 @@
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__php: %global __php %{_bindir}/php}
-%global gh_commit e7cc225bf212a72db3be492d53aa89ddbb18bfa1
+%global gh_commit 24b5e87988ce0b01098ee0b617a13f32264ee0be
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laruence
%global gh_project taint
#global gh_date 20150910
%global pecl_name taint
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
Summary: XSS code sniffer
Name: %{?scl_prefix}php-pecl-taint
-Version: 2.0.0
+Version: 2.0.1
%if 0%{?gh_date:1}
Release: 0.7.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -213,5 +213,8 @@ rm -rf %{buildroot}
%changelog
-* Tue Oct 27 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
-- new package, version 1.0.0 (beta, php 7) \ No newline at end of file
+* Sun Dec 13 2015 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- Update to 2.0.1 (php 7, beta)
+
+* Tue Oct 27 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- new package, version 2.0.0 (beta, php 7)