summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-01 11:12:57 +0200
committerRemi Collet <remi@remirepo.net>2017-08-01 11:12:57 +0200
commit536fc3235b79820b6599a3cedd21e8a6cc2d3eed (patch)
treef551d7b5578bab0fc88fd34fb2d9b9844ba517c7
parent37b3a5a5a175182f3307cfbe936c9dda121355aa (diff)
v2.0.3
-rw-r--r--LICENSE68
-rw-r--r--REFLECTION2
-rw-r--r--e41d11bb55aa16da57e152fecfce30a50b454c0d.patch22
-rw-r--r--php-pecl-taint.spec13
4 files changed, 7 insertions, 98 deletions
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 51877e0..0000000
--- a/LICENSE
+++ /dev/null
@@ -1,68 +0,0 @@
---------------------------------------------------------------------
- The PHP License, version 3.01
-Copyright (c) 1999 - 2011 The PHP Group. All rights reserved.
---------------------------------------------------------------------
-
-Redistribution and use in source and binary forms, with or without
-modification, is permitted provided that the following conditions
-are met:
-
- 1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
-
- 2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in
- the documentation and/or other materials provided with the
- distribution.
-
- 3. The name "PHP" must not be used to endorse or promote products
- derived from this software without prior written permission. For
- written permission, please contact group@php.net.
-
- 4. Products derived from this software may not be called "PHP", nor
- may "PHP" appear in their name, without prior written permission
- from group@php.net. You may indicate that your software works in
- conjunction with PHP by saying "Foo for PHP" instead of calling
- it "PHP Foo" or "phpfoo"
-
- 5. The PHP Group may publish revised and/or new versions of the
- license from time to time. Each version will be given a
- distinguishing version number.
- Once covered code has been published under a particular version
- of the license, you may always continue to use it under the terms
- of that version. You may also choose to use such covered code
- under the terms of any subsequent version of the license
- published by the PHP Group. No one other than the PHP Group has
- the right to modify the terms applicable to covered code created
- under this License.
-
- 6. Redistributions of any form whatsoever must retain the following
- acknowledgment:
- "This product includes PHP software, freely available from
- <http://www.php.net/software/>".
-
-THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
-ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
-THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
-PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
-DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
-INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
-OF THE POSSIBILITY OF SUCH DAMAGE.
-
---------------------------------------------------------------------
-
-This software consists of voluntary contributions made by many
-individuals on behalf of the PHP Group.
-
-The PHP Group can be contacted via Email at group@php.net.
-
-For more information on the PHP Group and the PHP project,
-please see <http://www.php.net>.
-
-PHP includes the Zend Engine, freely available at
-<http://www.zend.com>.
diff --git a/REFLECTION b/REFLECTION
index a9c5546..d8560b4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #114 taint version 2.0.2 ] {
+Extension [ <persistent> extension #139 taint version 2.0.3 ] {
- Dependencies {
Dependency [ xdebug (Conflicts) ]
diff --git a/e41d11bb55aa16da57e152fecfce30a50b454c0d.patch b/e41d11bb55aa16da57e152fecfce30a50b454c0d.patch
deleted file mode 100644
index 873fc8b..0000000
--- a/e41d11bb55aa16da57e152fecfce30a50b454c0d.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From e41d11bb55aa16da57e152fecfce30a50b454c0d Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 29 Jun 2017 08:23:04 +0200
-Subject: [PATCH] silent the each operator (for 7.2)
-
----
- tests/bug63123.phpt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/bug63123.phpt b/tests/bug63123.phpt
-index 705a954..ca44e28 100644
---- a/tests/bug63123.phpt
-+++ b/tests/bug63123.phpt
-@@ -10,7 +10,7 @@ taint.enable=1
- $str = 'a,' . 'b';
- taint($str);
- $a = explode(',', $str);
--while (list($key, $val) = each($a)) {
-+while (list($key, $val) = @each($a)) {
- echo $val;
- }
-
diff --git a/php-pecl-taint.spec b/php-pecl-taint.spec
index 34a252c..a07c396 100644
--- a/php-pecl-taint.spec
+++ b/php-pecl-taint.spec
@@ -22,20 +22,18 @@
Summary: XSS code sniffer
Name: %{?sub_prefix}php-pecl-taint
-Version: 2.0.2
+Version: 2.0.3
%if 0%{?gh_date:1}
Release: 0.9.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
%else
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
Group: Development/Languages
URL: https://github.com/%{gh_owner}/%{gh_project}
-Patch0: e41d11bb55aa16da57e152fecfce30a50b454c0d.patch
-
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -85,10 +83,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%setup -qc
%if 0%{?gh_date:1}
mv %{gh_project}-%{gh_commit} NTS
-mv NTS/package2.xml package.xml
+mv NTS/package.xml package.xml
%else
mv %{pecl_name}-%{version} NTS
-mv package2.xml package.xml
%endif
# Don't install/register tests
@@ -97,7 +94,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .upstream
# see https://github.com/laruence/taint/issues/55
sed -e '/PHP_VERSION_ID/s/70200/70300/' -i php_taint.h
@@ -236,6 +232,9 @@ fi
%changelog
+* Tue Aug 1 2017 Remi Collet <remi@remirepo.net> - 2.0.3-1
+- Update to 2.0.3
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.2-5
- rebuild for PHP 7.2.0beta1 new API