summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-04 07:06:17 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-04 07:06:17 +0200
commit45a00d9dd152ed7c3d3c7e9a39f5fdbc3ad0fee0 (patch)
tree99a54b8a626fe3ccd33710031eb1da11237e177f
parent06b84c0222b6d4947e25c2812b1799567ce89c7f (diff)
php-pecl-taint: 2.0.2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-taint.spec36
2 files changed, 24 insertions, 14 deletions
diff --git a/REFLECTION b/REFLECTION
index 0ba7ef0..a9c5546 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #55 taint version 2.0.1 ] {
+Extension [ <persistent> extension #114 taint version 2.0.2 ] {
- Dependencies {
Dependency [ xdebug (Conflicts) ]
diff --git a/php-pecl-taint.spec b/php-pecl-taint.spec
index 928b8ae..7f90426 100644
--- a/php-pecl-taint.spec
+++ b/php-pecl-taint.spec
@@ -6,7 +6,10 @@
#
# Please, preserve the changelog entries
#
-%{?scl: %scl_package php-pecl-taint}
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-taint
+%endif
%global gh_commit 24b5e87988ce0b01098ee0b617a13f32264ee0be
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
@@ -18,19 +21,19 @@
%global ini_name 40-%{pecl_name}.ini
Summary: XSS code sniffer
-Name: %{?scl_prefix}php-pecl-taint
-Version: 2.0.1
+Name: %{?sub_prefix}php-pecl-taint
+Version: 2.0.2
%if 0%{?gh_date:1}
Release: 0.7.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
Group: Development/Languages
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -39,9 +42,11 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
-%if "%{php_version}" > "7.0"
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -49,8 +54,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter shared private
@@ -70,8 +77,13 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
+%if 0%{?gh_date:1}
mv %{gh_project}-%{gh_commit} NTS
mv NTS/package2.xml package.xml
+%else
+mv %{pecl_name}-%{version} NTS
+mv package2.xml package.xml
+%endif
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -125,7 +137,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -196,12 +207,7 @@ fi
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -216,6 +222,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Jul 4 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
+- Update to 2.0.2 (php 7, beta)
+- sources from pecl
+
* Sun Mar 6 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-2
- adapt for F24