summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-05 15:54:44 +0100
committerRemi Collet <remi@php.net>2021-11-05 15:54:44 +0100
commit05aff441a81aca4209bf971161dd5b7eb87b215c (patch)
tree2596a17c395579642172c8e8fd5c1baa6b1e325f
parent21e3519861aa79228dc2c34140970afb73dd30dc (diff)
ignore 2 tests using deprecated calls on 8.1
-rw-r--r--php-pecl-sync.spec19
1 files changed, 15 insertions, 4 deletions
diff --git a/php-pecl-sync.spec b/php-pecl-sync.spec
index 26cebba..c11b6fe 100644
--- a/php-pecl-sync.spec
+++ b/php-pecl-sync.spec
@@ -22,7 +22,7 @@
Summary: Named and unnamed synchronization objects
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.1.2
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
Group: Development/Languages
URL: https://pecl.php.net/package/%{pecl_name}
@@ -57,6 +57,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -161,6 +164,12 @@ fi
%check
+%if "%{php_version}" > "8.1"
+# ignore deprecated calls
+rm ?TS/tests/005.phpt
+rm ?TS/tests/010.phpt
+%endif
+
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -170,9 +179,8 @@ cd NTS
: Upstream test suite for NTS extension
export TEST_PHP_EXECUTABLE=%{__php}
export TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so"
-export NO_INTERACTION=1
export REPORT_EXIT_STATUS=1
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
%if %{with_zts}
cd ../ZTS
@@ -184,7 +192,7 @@ cd ../ZTS
: Upstream test suite for ZTS extension
export TEST_PHP_EXECUTABLE=%{_bindir}/zts-php
export TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so"
-%{_bindir}/zts-php -n run-tests.php --show-diff
+%{_bindir}/zts-php -n run-tests.php -q --show-diff
%endif
@@ -203,6 +211,9 @@ export TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.
%changelog
+* Fri Sep 10 2021 Remi Collet <remi@remirepo.net> - 1.1.2-2
+- ignore 2 tests using deprecated calls on 8.1
+
* Sat Apr 10 2021 Remi Collet <remi@remirepo.net> - 1.1.2-1
- update to 1.1.2
- drop patch merged upstream