summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-29 09:20:48 +0200
committerRemi Collet <remi@php.net>2023-06-29 09:20:48 +0200
commit5420a4e02b87a62d07886a22b1558d47fcc9219c (patch)
tree876a34aa1af9c2244f187d1a4fb3b4b2f9d8e125
parent05aff441a81aca4209bf971161dd5b7eb87b215c (diff)
update to 1.1.3HEADmaster
-rw-r--r--REFLECTION38
-rw-r--r--php-pecl-sync.spec44
2 files changed, 28 insertions, 54 deletions
diff --git a/REFLECTION b/REFLECTION
index 07e9aba..bd5d212 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 sync version 1.1.2 ] {
+Extension [ <persistent> extension #123 sync version 1.1.3 ] {
- Classes [5] {
Class [ <internal:sync> class SyncMutex ] {
@@ -19,21 +19,21 @@ Extension [ <persistent> extension #119 sync version 1.1.2 ] {
Method [ <internal:sync, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $name ]
+ Parameter #0 [ <optional> $name = <default> ]
}
}
Method [ <internal:sync> public method lock ] {
- Parameters [1] {
- Parameter #0 [ <optional> $wait ]
+ Parameter #0 [ <optional> $wait = <default> ]
}
}
Method [ <internal:sync> public method unlock ] {
- Parameters [1] {
- Parameter #0 [ <optional> $all ]
+ Parameter #0 [ <optional> $all = <default> ]
}
}
}
@@ -57,23 +57,23 @@ Extension [ <persistent> extension #119 sync version 1.1.2 ] {
Method [ <internal:sync, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $name ]
- Parameter #1 [ <optional> $initialval ]
- Parameter #2 [ <optional> $autounlock ]
+ Parameter #0 [ <optional> $name = <default> ]
+ Parameter #1 [ <optional> $initialval = <default> ]
+ Parameter #2 [ <optional> $autounlock = <default> ]
}
}
Method [ <internal:sync> public method lock ] {
- Parameters [1] {
- Parameter #0 [ <optional> $wait ]
+ Parameter #0 [ <optional> $wait = <default> ]
}
}
Method [ <internal:sync> public method unlock ] {
- Parameters [1] {
- Parameter #0 [ <optional> &$prevcount ]
+ Parameter #0 [ <optional> &$prevcount = <default> ]
}
}
}
@@ -97,15 +97,15 @@ Extension [ <persistent> extension #119 sync version 1.1.2 ] {
Method [ <internal:sync, ctor> public method __construct ] {
- Parameters [2] {
- Parameter #0 [ <optional> $name ]
- Parameter #1 [ <optional> $manual ]
+ Parameter #0 [ <optional> $name = <default> ]
+ Parameter #1 [ <optional> $manual = <default> ]
}
}
Method [ <internal:sync> public method wait ] {
- Parameters [1] {
- Parameter #0 [ <optional> $wait ]
+ Parameter #0 [ <optional> $wait = <default> ]
}
}
@@ -141,22 +141,22 @@ Extension [ <persistent> extension #119 sync version 1.1.2 ] {
Method [ <internal:sync, ctor> public method __construct ] {
- Parameters [2] {
- Parameter #0 [ <optional> $name ]
- Parameter #1 [ <optional> $autounlock ]
+ Parameter #0 [ <optional> $name = <default> ]
+ Parameter #1 [ <optional> $autounlock = <default> ]
}
}
Method [ <internal:sync> public method readlock ] {
- Parameters [1] {
- Parameter #0 [ <optional> $wait ]
+ Parameter #0 [ <optional> $wait = <default> ]
}
}
Method [ <internal:sync> public method writelock ] {
- Parameters [1] {
- Parameter #0 [ <optional> $wait ]
+ Parameter #0 [ <optional> $wait = <default> ]
}
}
@@ -213,15 +213,15 @@ Extension [ <persistent> extension #119 sync version 1.1.2 ] {
- Parameters [2] {
Parameter #0 [ <required> $string ]
- Parameter #1 [ <optional> $start ]
+ Parameter #1 [ <optional> $start = <default> ]
}
}
Method [ <internal:sync> public method read ] {
- Parameters [2] {
- Parameter #0 [ <optional> $start ]
- Parameter #1 [ <optional> $length ]
+ Parameter #0 [ <optional> $start = <default> ]
+ Parameter #1 [ <optional> $length = <default> ]
}
}
}
diff --git a/php-pecl-sync.spec b/php-pecl-sync.spec
index c11b6fe..1385123 100644
--- a/php-pecl-sync.spec
+++ b/php-pecl-sync.spec
@@ -1,15 +1,12 @@
# remirepo spec file for php-pecl-sync
#
-# Copyright (c) 2014-2021 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2014-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-sync
-%endif
+%{?scl:%scl_package php-pecl-sync}
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name sync
@@ -20,9 +17,9 @@
%endif
Summary: Named and unnamed synchronization objects
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.1.2
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 1.1.3
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
Group: Development/Languages
URL: https://pecl.php.net/package/%{pecl_name}
@@ -41,26 +38,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
%description
@@ -164,12 +141,6 @@ fi
%check
-%if "%{php_version}" > "8.1"
-# ignore deprecated calls
-rm ?TS/tests/005.phpt
-rm ?TS/tests/010.phpt
-%endif
-
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -211,6 +182,9 @@ export TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.
%changelog
+* Thu Jun 29 2023 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+
* Fri Sep 10 2021 Remi Collet <remi@remirepo.net> - 1.1.2-2
- ignore 2 tests using deprecated calls on 8.1