summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole6.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-07-02 14:07:18 +0200
committerRemi Collet <remi@php.net>2024-07-02 14:07:18 +0200
commita7352a4f9b3c31706492b2e3400197ce53a0632d (patch)
treebc1e714f6ef86cde5c91d79305d394f31641f7a2 /php-pecl-swoole6.spec
parent3308ce4948b49c94ab32af062b7fb70ceb6cd806 (diff)
update to 6.0.0
rename to php-pecl-swoole6 raise dependency on PHP 8.1
Diffstat (limited to 'php-pecl-swoole6.spec')
-rw-r--r--php-pecl-swoole6.spec102
1 files changed, 42 insertions, 60 deletions
diff --git a/php-pecl-swoole6.spec b/php-pecl-swoole6.spec
index 69e0d30..02b39f7 100644
--- a/php-pecl-swoole6.spec
+++ b/php-pecl-swoole6.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for php-pecl-swoole5
+# remirepo spec file for php-pecl-swoole6
#
# Copyright (c) 2013-2024 Remi Collet
# License: CC-BY-SA-4.0
@@ -8,7 +8,7 @@
#
%if 0%{?scl:1}
-%scl_package php-pecl-swoole5
+%scl_package php-pecl-swoole6
%else
%global _root_prefix %{_prefix}
%endif
@@ -34,33 +34,24 @@
%endif
-%if 0%{?fedora} || 0%{?rhel} >= 8
-%bcond_without pgsql
+%if 0%{?fedora} || 0%{?rhel} >= 9
+%bcond_without uring
%else
-%bcond_with pgsql
+%bcond_with uring
%endif
-%if 0%{?fedora} || 0%{?rhel} >= 8
+%bcond_without pgsql
%bcond_without brotli
-%else
-%bcond_with brotli
-%endif
-
-%if 0%{?fedora} || 0%{?rhel} >= 8
%bcond_without curl
-%else
-%bcond_with curl
-%endif
-
%bcond_without nghttpd2
-%global upstream_version 5.1.3
+%global upstream_version 6.0.0
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
Summary: PHP's asynchronous concurrent distributed networking framework
-Name: %{?scl_prefix}php-pecl-%{pecl_name}5
+Name: %{?scl_prefix}php-pecl-%{pecl_name}6
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is Apache-2.0
@@ -70,13 +61,10 @@ License: Apache-2.0 AND BSD-3-Clause AND MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: 0001-missing-header.patch
-Patch1: 0002-fix-implicit-int.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel >= 8.0
+BuildRequires: %{?scl_prefix}php-devel >= 8.1
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-json
@@ -87,22 +75,26 @@ BuildRequires: pcre-devel
BuildRequires: openssl-devel >= 1.0.2
BuildRequires: zlib-devel
%if %{with curl}
-BuildRequires: libcurl-devel >= 7.56
+BuildRequires: pkgconfig(libcurl)
%endif
%if %{with cares}
-BuildRequires: c-ares-devel
+BuildRequires: pkgconfig(libcares)
%endif
%if %{with brotli}
-BuildRequires: brotli-devel
+BuildRequires: pkgconfig(libbrotlidec)
+BuildRequires: pkgconfig(libbrotlienc)
%endif
%if %{with pgsql}
-BuildRequires: libpq-devel
+BuildRequires: pkgconfig(libpq)
%endif
%if %{with nghttpd2}
-BuildRequires: libnghttp2-devel
+BuildRequires: pkgconfig(libnghttp2)
%endif
-BuildRequires: unixODBC-devel
-BuildRequires: sqlite-devel
+%if %{with uring}
+BuildRequires: pkgconfig(liburing)
+%endif
+BuildRequires: pkgconfig(odbc)
+BuildRequires: pkgconfig(sqlite3)
%if %{with oracle}
%ifarch aarch64
BuildRequires: oracle-instantclient%{oraclever}-devel
@@ -128,24 +120,29 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10 || "%{php_version}" >= "8.2"
-Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 5
+%if 0%{?fedora} >= 41 || 0%{?rhel} >= 10 || "%{php_version}" >= "8.4"
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 6
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}2 < 5
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}2 < 6
Provides: %{?scl_prefix}php-pecl-%{pecl_name}2 = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}2%{?_isa} = %{version}-%{release}
-Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}4 < 5
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}4 < 6
Provides: %{?scl_prefix}php-pecl-%{pecl_name}4 = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}4%{?_isa} = %{version}-%{release}
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}5 < 6
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}5 = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}5%{?_isa} = %{version}-%{release}
%else
# Single version can be installed
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 5
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}2 < 5
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}4 < 5
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 6
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}2 < 6
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}4 < 6
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}5 < 6
%endif
# Only one extension can be installed (same symbols)
Conflicts: %{?scl_prefix}php-pecl-openswoole
+Conflicts: %{?scl_prefix}php-pecl-openswoole22
%description
@@ -192,9 +189,6 @@ sed \
cd %{sources}
-%patch -P0 -p1
-%patch -P1 -p1
-
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
%if %{with nghttpd2}
rm -r thirdparty/nghttp2
@@ -260,13 +254,16 @@ peclbuild() {
%if %{with nghttpd2}
--with-nghttp2-dir=%{_root_prefix} \
%endif
+%if %{with uring}
+ --enable-iouring \
+%endif
%if %{with oracle}
--with-swoole-oracle=instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib \
%endif
--with-swoole-odbc=unixodbc,%{_root_prefix} \
--enable-swoole-sqlite \
--with-libdir=%{_lib} \
- --with-php-config=$1
+ --with-php-config=$*
make %{?_smp_mflags}
}
@@ -279,7 +276,7 @@ peclbuild %{__phpconfig}
%if %{with_zts}
cd ../ZTS
-peclbuild %{__ztsphpconfig}
+peclbuild %{__ztsphpconfig} --enable-swoole-thread
%endif
@@ -315,26 +312,6 @@ rm %{buildroot}%{pecl_testdir}/%{pecl_name}/tests/swoole_process/echo.py
rm %{buildroot}%{pecl_docdir}/%{pecl_name}/examples/process/echo.py
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
OPT="--no-php-ini"
[ -f %{php_extdir}/curl.so ] && OPT="$OPT -d extension=curl"
@@ -389,6 +366,11 @@ cd ../ZTS
%changelog
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 6.0.0-1
+- update to 6.0.0
+- rename to php-pecl-swoole6
+- raise dependency on PHP 8.1
+
* Thu Jun 6 2024 Remi Collet <remi@remirepo.net> - 5.1.3-1
- update to 5.1.3
- fix build warnings (errors with GCC 14) using patch from