summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole5.spec')
-rw-r--r--php-pecl-swoole5.spec74
1 files changed, 48 insertions, 26 deletions
diff --git a/php-pecl-swoole5.spec b/php-pecl-swoole5.spec
index 9296752..a11651d 100644
--- a/php-pecl-swoole5.spec
+++ b/php-pecl-swoole5.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for php-pecl-swoole4
+# remirepo spec file for php-pecl-swoole5
#
# Copyright (c) 2013-2022 Remi Collet
# License: CC-BY-SA
@@ -11,7 +11,7 @@
%undefine _strict_symbol_defs_build
%if 0%{?scl:1}
-%scl_package php-pecl-swoole4
+%scl_package php-pecl-swoole5
%endif
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -21,18 +21,31 @@
%bcond_without cares
%bcond_without nghttpd2
-%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
+
+%if 0%{?fedora} || 0%{?rhel} >= 8
+%bcond_without pgsql
+%else
+%bcond_with pgsql
+%endif
+
+%if 0%{?fedora} || 0%{?rhel} >= 8
%bcond_without brotli
%else
%bcond_with brotli
%endif
-%global upstream_version 4.8.11
+%if 0%{?fedora} || 0%{?rhel} >= 8
+%bcond_without curl
+%else
+%bcond_with curl
+%endif
+
+%global upstream_version 5.0.0
#global upstream_prever RC2
Summary: PHP's asynchronous concurrent distributed networking framework
-Name: %{?scl_prefix}php-pecl-%{pecl_name}4
+Name: %{?scl_prefix}php-pecl-%{pecl_name}5
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
@@ -47,7 +60,7 @@ Patch0: %{pecl_name}-build.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel >= 7.2
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-json
@@ -56,13 +69,18 @@ BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: pcre-devel
BuildRequires: openssl-devel >= 1.0.2
BuildRequires: zlib-devel
-BuildRequires: libcurl-devel
+%if %{with curl}
+BuildRequires: libcurl-devel >= 7.56
+%endif
%if %{with cares}
BuildRequires: c-ares-devel
%endif
%if %{with brotli}
BuildRequires: brotli-devel
%endif
+%if %{with pgsql}
+BuildRequires: libpq-devel
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -77,33 +95,25 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8 || "%{php_version}" > "7.3"
-Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 4
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 10 || "%{php_version}" >= "8.2"
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 5
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}2 < 4
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}2 < 5
Provides: %{?scl_prefix}php-pecl-%{pecl_name}2 = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}2%{?_isa} = %{version}-%{release}
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}4 < 5
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}4 = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}4%{?_isa} = %{version}-%{release}
%else
# Single version can be installed
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 4
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}2 < 4
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 5
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}2 < 5
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}4 < 5
%endif
# Only one extension can be installed (same symbols)
Conflicts: %{?scl_prefix}php-pecl-openswoole
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%description
Event-driven asynchronous and concurrent networking engine with
@@ -193,10 +203,14 @@ peclbuild() {
--enable-sockets \
--enable-trace-log \
--enable-openssl \
- --enable-http2 \
--enable-mysqlnd \
- --enable-swoole-json \
+%if %{with pgsql}
+ --enable-swoole-pgsql \
+%endif
+%if %{with curl}
--enable-swoole-curl \
+%endif
+ --enable-swoole-coro-time \
%if %{with cares}
--enable-cares \
%endif
@@ -310,6 +324,7 @@ cd ../ZTS
%files devel
%doc %{pecl_testdir}/%{pecl_name}
+%doc %{pecl_docdir}/%{pecl_name}/core-tests
%doc %{pecl_docdir}/%{pecl_name}/examples
%doc %{pecl_docdir}/%{pecl_name}/gdbinit
%doc %{pecl_docdir}/%{pecl_name}/thirdparty
@@ -322,6 +337,13 @@ cd ../ZTS
%changelog
+* Tue Aug 2 2022 Remi Collet <remi@remirepo.net> - 5.0.0-1
+- update to 5.0.0
+- rename to php-pecl-swoole5
+- raise dependency on PHP 8.0
+- add postgresql support on Fedora, EL-8 and EL-9
+- remove curl support on EL-7
+
* Tue Jul 12 2022 Remi Collet <remi@remirepo.net> - 4.8.11-1
- update to 4.8.11