summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO13
-rw-r--r--REFLECTION13
-rw-r--r--php-pecl-swoole5.spec5
3 files changed, 17 insertions, 14 deletions
diff --git a/PHPINFO b/PHPINFO
index 85d6636..1b3c8af 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 5.1.0
-Built => Sep 29 2023 00:00:00
+Version => 5.1.1
+Built => Nov 27 2023 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
@@ -14,15 +14,15 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 3.0.9 30 May 2023
+openssl => OpenSSL 3.1.1 30 May 2023
dtls => enabled
http2 => enabled
json => enabled
curl-native => enabled
pcre => enabled
-c-ares => 1.19.1
-zlib => 1.2.12
-brotli => E16777225/D16777225
+c-ares => 1.21.0
+zlib => 1.2.13
+brotli => E16781312/D16781312
mutex_timedlock => enabled
pthread_barrier => enabled
futex => enabled
@@ -30,7 +30,6 @@ mysqlnd => enabled
async_redis => enabled
coroutine_pgsql => enabled
coroutine_odbc => enabled
-coroutine_oracle => enabled
coroutine_sqlite => enabled
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 6891767..20d5230 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #102 swoole version 5.1.0 ] {
+Extension [ <persistent> extension #74 swoole version 5.1.1 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -32,12 +32,12 @@ Extension [ <persistent> extension #102 swoole version 5.1.0 ] {
}
}
- - Constants [414] {
- Constant [ string SWOOLE_VERSION ] { 5.1.0 }
- Constant [ int SWOOLE_VERSION_ID ] { 50100 }
+ - Constants [415] {
+ Constant [ string SWOOLE_VERSION ] { 5.1.1 }
+ Constant [ int SWOOLE_VERSION_ID ] { 50101 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 5 }
Constant [ int SWOOLE_MINOR_VERSION ] { 1 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 0 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 1 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -162,6 +162,7 @@ Extension [ <persistent> extension #102 swoole version 5.1.0 ] {
Constant [ int SWOOLE_ERROR_HTTP_PROXY_HANDSHAKE_FAILED ] { 7103 }
Constant [ int SWOOLE_ERROR_HTTP_PROXY_BAD_RESPONSE ] { 7104 }
Constant [ int SWOOLE_ERROR_HTTP_CONFLICT_HEADER ] { 7105 }
+ Constant [ int SWOOLE_ERROR_HTTP_CONTEXT_UNAVAILABLE ] { 7106 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_BAD_CLIENT ] { 8501 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_BAD_OPCODE ] { 8502 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_UNCONNECTED ] { 8503 }
@@ -239,6 +240,7 @@ Extension [ <persistent> extension #102 swoole version 5.1.0 ] {
Constant [ int SWOOLE_TRACE_CO_PGSQL ] { 4294967296 }
Constant [ int SWOOLE_TRACE_CO_ODBC ] { 8589934592 }
Constant [ int SWOOLE_TRACE_CO_ORACLE ] { 17179869184 }
+ Constant [ int SWOOLE_TRACE_CO_SQLITE ] { 34359738368 }
Constant [ int SWOOLE_TRACE_ALL ] { 9223372036854775807 }
Constant [ int SWOOLE_LOG_DEBUG ] { 0 }
Constant [ int SWOOLE_LOG_TRACE ] { 1 }
@@ -297,7 +299,6 @@ Extension [ <persistent> extension #102 swoole version 5.1.0 ] {
Constant [ int SWOOLE_HOOK_SOCKETS ] { 16384 }
Constant [ int SWOOLE_HOOK_PDO_PGSQL ] { 65536 }
Constant [ int SWOOLE_HOOK_PDO_ODBC ] { 131072 }
- Constant [ int SWOOLE_HOOK_PDO_ORACLE ] { 262144 }
Constant [ int SWOOLE_HOOK_PDO_SQLITE ] { 524288 }
Constant [ int SWOOLE_HOOK_ALL ] { 2147481599 }
Constant [ int SOCKET_ECANCELED ] { 125 }
diff --git a/php-pecl-swoole5.spec b/php-pecl-swoole5.spec
index f461321..9435dd9 100644
--- a/php-pecl-swoole5.spec
+++ b/php-pecl-swoole5.spec
@@ -54,7 +54,7 @@
%bcond_without nghttpd2
-%global upstream_version 5.1.0
+%global upstream_version 5.1.1
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -381,6 +381,9 @@ cd ../ZTS
%changelog
+* Mon Nov 27 2023 Remi Collet <remi@remirepo.net> - 5.1.1-1
+- update to 5.1.1
+
* Fri Sep 29 2023 Remi Collet <remi@remirepo.net> - 5.1.0-1
- update to 5.1.0
- add dependency on pdo extension