summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole5.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-02-16 07:54:46 +0100
committerRemi Collet <remi@php.net>2025-02-16 07:54:46 +0100
commit498321920ce54c8cb26135a1ed3ce8aeb070cbfd (patch)
tree2730ebd3fdfd82c08af231c5406ed039cec28c55 /php-pecl-swoole5.spec
parent4ec530a138e714876653a5828b2532d908160988 (diff)
update to 5.1.7HEADmaster
re-license spec file to CECILL-2.1 fix cpu affinity check using patch from v6 update to 5.1.7 re-license spec file to CECILL-2.1 fix cpu affinity check using patch from v6
Diffstat (limited to 'php-pecl-swoole5.spec')
-rw-r--r--php-pecl-swoole5.spec23
1 files changed, 19 insertions, 4 deletions
diff --git a/php-pecl-swoole5.spec b/php-pecl-swoole5.spec
index c583538..a903998 100644
--- a/php-pecl-swoole5.spec
+++ b/php-pecl-swoole5.spec
@@ -1,8 +1,8 @@
# remirepo spec file for php-pecl-swoole5
#
-# Copyright (c) 2013-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2013-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -39,7 +39,7 @@
%bcond_without curl
%bcond_without nghttpd2
-%global upstream_version 5.1.6
+%global upstream_version 5.1.7
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -55,6 +55,9 @@ License: Apache-2.0 AND BSD-3-Clause AND MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+# Backported from version 6
+Patch0: 0001-fix-cpu-affinity-check.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -127,6 +130,8 @@ Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}4 < 5
%endif
# Only one extension can be installed (same symbols)
Conflicts: %{?scl_prefix}php-pecl-openswoole
+Conflicts: %{?scl_prefix}php-pecl-openswoole22
+Conflicts: %{?scl_prefix}php-pecl-openswoole25
%description
@@ -180,6 +185,8 @@ rm -r thirdparty/nghttp2
cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
%endif
+%patch -P0 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -246,6 +253,9 @@ peclbuild() {
--with-libdir=%{_lib} \
--with-php-config=$1
+# See https://bugzilla.redhat.com/show_bug.cgi?id=2345743
+sed -e 's:-Wl,-rpath,/usr/usr/lib64 -L/usr/usr/lib64::' -i Makefile
+
%make_build
}
@@ -344,6 +354,11 @@ cd ../ZTS
%changelog
+* Sun Feb 16 2025 Remi Collet <remi@remirepo.net> - 5.1.7-1
+- update to 5.1.7
+- re-license spec file to CECILL-2.1
+- fix cpu affinity check using patch from v6
+
* Thu Nov 28 2024 Remi Collet <remi@remirepo.net> - 5.1.6-1
- update to 5.1.6