summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-07 08:32:32 +0100
committerRemi Collet <remi@php.net>2022-11-07 08:32:32 +0100
commitedcf0497d1422cb856bbac1c0d45d394f225e8d6 (patch)
treed8380c021239fdddcf8b15d74df50c4fd76a11cb
parente36e91a9c8a442cf1b302462085a145104142d39 (diff)
update to 5.0.1
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION76
-rw-r--r--php-pecl-swoole5.spec10
3 files changed, 64 insertions, 26 deletions
diff --git a/PHPINFO b/PHPINFO
index fd9a3b4..b9d12e3 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 5.0.0
-Built => Aug 2 2022 00:00:00
+Version => 5.0.1
+Built => Nov 7 2022 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 6cf632f..109459f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
+Extension [ <persistent> extension #88 swoole version 5.0.1 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -28,12 +28,12 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
}
}
- - Constants [400] {
- Constant [ string SWOOLE_VERSION ] { 5.0.0 }
- Constant [ int SWOOLE_VERSION_ID ] { 50000 }
+ - Constants [401] {
+ Constant [ string SWOOLE_VERSION ] { 5.0.1 }
+ Constant [ int SWOOLE_VERSION_ID ] { 50001 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 5 }
Constant [ int SWOOLE_MINOR_VERSION ] { 0 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 0 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 1 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -311,6 +311,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
Constant [ int SWOOLE_HTTP2_ERROR_CONNECT_ERROR ] { 10 }
Constant [ int SWOOLE_HTTP2_ERROR_ENHANCE_YOUR_CALM ] { 11 }
Constant [ int SWOOLE_HTTP2_ERROR_INADEQUATE_SECURITY ] { 12 }
+ Constant [ int SWOOLE_HTTP2_ERROR_HTTP_1_1_REQUIRED ] { 13 }
Constant [ int SWOOLE_MYSQLND_CR_UNKNOWN_ERROR ] { 2000 }
Constant [ int SWOOLE_MYSQLND_CR_CONNECTION_ERROR ] { 2002 }
Constant [ int SWOOLE_MYSQLND_CR_SERVER_GONE_ERROR ] { 2006 }
@@ -2757,7 +2758,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Parameters [3] {
Parameter #0 [ <optional> int $cid = 0 ]
- Parameter #1 [ <optional> int $options = DEBUG_BACKTRACE_PROVIDE_OBJECT ]
+ Parameter #1 [ <optional> int $options = 0 ]
Parameter #2 [ <optional> int $limit = 0 ]
}
- Return [ void ]
@@ -7163,7 +7164,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Parameters [4] {
Parameter #0 [ <optional> string $host = '0.0.0.0' ]
Parameter #1 [ <optional> int $port = 0 ]
- Parameter #2 [ <optional> int $mode = SWOOLE_PROCESS ]
+ Parameter #2 [ <optional> int $mode = SWOOLE_BASE ]
Parameter #3 [ <optional> int $sock_type = SWOOLE_SOCK_TCP ]
}
}
@@ -7342,7 +7343,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
Parameter #1 [ <optional> float $timeout = 0.5 ]
Parameter #2 [ <optional> int $taskWorkerIndex = -1 ]
}
- - Return [ string|false ]
+ - Return [ mixed ]
}
Method [ <internal:swoole> public method taskWaitMulti ] {
@@ -7558,7 +7559,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Static properties [0] {
}
- - Static methods [1] {
+ - Static methods [2] {
Method [ <internal:swoole> static public method pack ] {
- Parameters [1] {
@@ -7566,6 +7567,14 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
}
- Return [ string|false ]
}
+
+ Method [ <internal:swoole> static public method unpack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $data ]
+ }
+ - Return [ mixed ]
+ }
}
- Properties [5] {
@@ -8010,7 +8019,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Parameters [9] {
Parameter #0 [ <required> string $name ]
Parameter #1 [ <optional> string $value = '' ]
- Parameter #2 [ <optional> int $expire = 0 ]
+ Parameter #2 [ <optional> int $expires = 0 ]
Parameter #3 [ <optional> string $path = '/' ]
Parameter #4 [ <optional> string $domain = '' ]
Parameter #5 [ <optional> bool $secure = false ]
@@ -8026,7 +8035,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Parameters [9] {
Parameter #0 [ <required> string $name ]
Parameter #1 [ <optional> string $value = '' ]
- Parameter #2 [ <optional> int $expire = 0 ]
+ Parameter #2 [ <optional> int $expires = 0 ]
Parameter #3 [ <optional> string $path = '/' ]
Parameter #4 [ <optional> string $domain = '' ]
Parameter #5 [ <optional> bool $secure = false ]
@@ -8042,7 +8051,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Parameters [9] {
Parameter #0 [ <required> string $name ]
Parameter #1 [ <optional> string $value = '' ]
- Parameter #2 [ <optional> int $expire = 0 ]
+ Parameter #2 [ <optional> int $expires = 0 ]
Parameter #3 [ <optional> string $path = '/' ]
Parameter #4 [ <optional> string $domain = '' ]
Parameter #5 [ <optional> bool $secure = false ]
@@ -8233,7 +8242,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Parameters [4] {
Parameter #0 [ <optional> string $host = '0.0.0.0' ]
Parameter #1 [ <optional> int $port = 0 ]
- Parameter #2 [ <optional> int $mode = SWOOLE_PROCESS ]
+ Parameter #2 [ <optional> int $mode = SWOOLE_BASE ]
Parameter #3 [ <optional> int $sock_type = SWOOLE_SOCK_TCP ]
}
}
@@ -8412,7 +8421,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
Parameter #1 [ <optional> float $timeout = 0.5 ]
Parameter #2 [ <optional> int $taskWorkerIndex = -1 ]
}
- - Return [ string|false ]
+ - Return [ mixed ]
}
Method [ <internal:swoole, inherits Swoole\Server> public method taskWaitMulti ] {
@@ -8779,7 +8788,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Parameters [4] {
Parameter #0 [ <optional> string $host = '0.0.0.0' ]
Parameter #1 [ <optional> int $port = 0 ]
- Parameter #2 [ <optional> int $mode = SWOOLE_PROCESS ]
+ Parameter #2 [ <optional> int $mode = SWOOLE_BASE ]
Parameter #3 [ <optional> int $sock_type = SWOOLE_SOCK_TCP ]
}
}
@@ -8958,7 +8967,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
Parameter #1 [ <optional> float $timeout = 0.5 ]
Parameter #2 [ <optional> int $taskWorkerIndex = -1 ]
}
- - Return [ string|false ]
+ - Return [ mixed ]
}
Method [ <internal:swoole, inherits Swoole\Server> public method taskWaitMulti ] {
@@ -9327,7 +9336,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Parameters [4] {
Parameter #0 [ <optional> string $host = '0.0.0.0' ]
Parameter #1 [ <optional> int $port = 0 ]
- Parameter #2 [ <optional> int $mode = SWOOLE_PROCESS ]
+ Parameter #2 [ <optional> int $mode = SWOOLE_BASE ]
Parameter #3 [ <optional> int $sock_type = SWOOLE_SOCK_TCP ]
}
}
@@ -9506,7 +9515,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
Parameter #1 [ <optional> float $timeout = 0.5 ]
Parameter #2 [ <optional> int $taskWorkerIndex = -1 ]
}
- - Return [ string|false ]
+ - Return [ mixed ]
}
Method [ <internal:swoole, inherits Swoole\Server> public method taskWaitMulti ] {
@@ -9758,7 +9767,7 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
Property [ public $notices = NULL ]
}
- - Methods [9] {
+ - Methods [12] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [0] {
@@ -9822,6 +9831,29 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Return [ string|false ]
}
+ Method [ <internal:swoole> public method createLOB ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int|false ]
+ }
+
+ Method [ <internal:swoole> public method openLOB ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $oid ]
+ Parameter #1 [ <optional> string $mode = "rb" ]
+ }
+ }
+
+ Method [ <internal:swoole> public method unlinkLOB ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $oid ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:swoole> public method __destruct ] {
- Parameters [0] {
@@ -9870,21 +9902,21 @@ Extension [ <persistent> extension #88 swoole version 5.0.0 ] {
- Parameters [0] {
}
- - Return [ int ]
+ - Return [ int|false ]
}
Method [ <internal:swoole> public method numRows ] {
- Parameters [0] {
}
- - Return [ int ]
+ - Return [ int|false ]
}
Method [ <internal:swoole> public method fieldCount ] {
- Parameters [0] {
}
- - Return [ int ]
+ - Return [ int|false ]
}
Method [ <internal:swoole> public method fetchObject ] {
diff --git a/php-pecl-swoole5.spec b/php-pecl-swoole5.spec
index a11651d..237b8e9 100644
--- a/php-pecl-swoole5.spec
+++ b/php-pecl-swoole5.spec
@@ -40,7 +40,7 @@
%bcond_with curl
%endif
-%global upstream_version 5.0.0
+%global upstream_version 5.0.1
#global upstream_prever RC2
@@ -214,6 +214,9 @@ peclbuild() {
%if %{with cares}
--enable-cares \
%endif
+%if %{with brotli}
+ --enable-brotli \
+%endif
--with-libdir=%{_lib} \
--with-php-config=$1
@@ -325,10 +328,10 @@ cd ../ZTS
%files devel
%doc %{pecl_testdir}/%{pecl_name}
%doc %{pecl_docdir}/%{pecl_name}/core-tests
+%doc %{pecl_docdir}/%{pecl_name}/docs
%doc %{pecl_docdir}/%{pecl_name}/examples
%doc %{pecl_docdir}/%{pecl_name}/gdbinit
%doc %{pecl_docdir}/%{pecl_name}/thirdparty
-%doc %{pecl_docdir}/%{pecl_name}/travis
%{php_incldir}/ext/%{pecl_name}
%if %{with_zts}
@@ -337,6 +340,9 @@ cd ../ZTS
%changelog
+* Mon Nov 7 2022 Remi Collet <remi@remirepo.net> - 5.0.1-1
+- update to 5.0.1
+
* Tue Aug 2 2022 Remi Collet <remi@remirepo.net> - 5.0.0-1
- update to 5.0.0
- rename to php-pecl-swoole5