summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-06 13:54:50 +0100
committerRemi Collet <remi@php.net>2023-02-06 13:54:50 +0100
commit2f5e4a607f906715035f8dba823b304f530e0ba9 (patch)
treea1dc6adfcb13c99fb59053dcc329907126d539e7
parent11b0f344f4b41fd7f1aa3f671c7831a57843641e (diff)
update to 5.0.2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION310
-rw-r--r--php-pecl-swoole5.spec15
3 files changed, 61 insertions, 268 deletions
diff --git a/PHPINFO b/PHPINFO
index 4f85ba1..c4a0d99 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 5.0.1
-Built => Nov 7 2022 00:00:00
+Version => 5.0.2
+Built => Feb 6 2023 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index ff5d30f..b26acdd 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
+Extension [ <persistent> extension #107 swoole version 5.0.2 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -28,12 +28,12 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
}
}
- - Constants [401] {
- Constant [ string SWOOLE_VERSION ] { 5.0.1 }
- Constant [ int SWOOLE_VERSION_ID ] { 50001 }
+ - Constants [403] {
+ Constant [ string SWOOLE_VERSION ] { 5.0.2 }
+ Constant [ int SWOOLE_VERSION_ID ] { 50002 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 5 }
Constant [ int SWOOLE_MINOR_VERSION ] { 0 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 1 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 2 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -198,6 +198,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Constant [ int SWOOLE_ERROR_CO_NOT_EXISTS ] { 10016 }
Constant [ int SWOOLE_ERROR_CO_CANCELED ] { 10017 }
Constant [ int SWOOLE_ERROR_CO_TIMEDOUT ] { 10018 }
+ Constant [ int SWOOLE_ERROR_CO_SOCKET_CLOSE_WAIT ] { 10019 }
Constant [ int SWOOLE_TRACE_SERVER ] { 2 }
Constant [ int SWOOLE_TRACE_CLIENT ] { 4 }
Constant [ int SWOOLE_TRACE_BUFFER ] { 8 }
@@ -228,6 +229,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Constant [ int SWOOLE_TRACE_TABLE ] { 268435456 }
Constant [ int SWOOLE_TRACE_CO_CURL ] { 536870912 }
Constant [ int SWOOLE_TRACE_CARES ] { 1073741824 }
+ Constant [ int SWOOLE_TRACE_ZLIB ] { 2147483648 }
Constant [ int SWOOLE_TRACE_ALL ] { 9223372036854775807 }
Constant [ int SWOOLE_LOG_DEBUG ] { 0 }
Constant [ int SWOOLE_LOG_TRACE ] { 1 }
@@ -454,7 +456,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Function [ <internal:swoole> function swoole_async_dns_lookup_coro ] {
- Parameters [3] {
- Parameter #0 [ <required> mixed $domain_name ]
+ Parameter #0 [ <required> string $domain_name ]
Parameter #1 [ <optional> float $timeout = 60 ]
Parameter #2 [ <optional> int $type = AF_INET ]
}
@@ -756,6 +758,12 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
}
- Return [ bool ]
}
+ Function [ <internal:swoole> function swoole_event_wait ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
Function [ <internal:swoole> function swoole_event_isset ] {
- Parameters [2] {
@@ -793,12 +801,6 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
}
- Return [ bool ]
}
- Function [ <internal:swoole> function swoole_event_wait ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
Function [ <internal:swoole> function swoole_event_exit ] {
- Parameters [0] {
@@ -828,13 +830,6 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
}
- Return [ int|false ]
}
- Function [ <internal:swoole> function swoole_timer_exists ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> int $timer_id ]
- }
- - Return [ bool ]
- }
Function [ <internal:swoole> function swoole_timer_info ] {
- Parameters [1] {
@@ -842,256 +837,38 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
}
- Return [ ?array ]
}
- Function [ <internal:swoole> function swoole_timer_stats ] {
-
- - Parameters [0] {
- }
- - Return [ array ]
- }
Function [ <internal:swoole> function swoole_timer_list ] {
- Parameters [0] {
}
- - Return [ É ]
+ - Return [ Swoole\Timer\Iterator ]
}
- Function [ <internal:swoole> function swoole_timer_clear ] {
+ Function [ <internal:swoole> function swoole_timer_exists ] {
- Parameters [1] {
Parameter #0 [ <required> int $timer_id ]
}
- Return [ bool ]
}
- Function [ <internal:swoole> function swoole_timer_clear_all ] {
+ Function [ <internal:swoole> function swoole_timer_stats ] {
- Parameters [0] {
}
- - Return [ bool ]
- }
- Function [ <internal:swoole> function swoole_native_socket_create_listen ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> int $port ]
- Parameter #1 [ <optional> int $backlog = 128 ]
- }
- - Return [ Swoole\Coroutine\Socket|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_accept ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- }
- - Return [ Swoole\Coroutine\Socket|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_set_nonblock ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- }
- - Return [ bool ]
- }
- Function [ <internal:swoole> function swoole_native_socket_set_block ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- }
- - Return [ bool ]
- }
- Function [ <internal:swoole> function swoole_native_socket_listen ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <optional> int $backlog = 0 ]
- }
- - Return [ bool ]
- }
- Function [ <internal:swoole> function swoole_native_socket_close ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- }
- - Return [ void ]
- }
- Function [ <internal:swoole> function swoole_native_socket_write ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> string $data ]
- Parameter #2 [ <optional> ?int $length = null ]
- }
- - Return [ int|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_read ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> int $length ]
- Parameter #2 [ <optional> int $mode = PHP_BINARY_READ ]
- }
- - Return [ string|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_getsockname ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> &$address ]
- Parameter #2 [ <optional> &$port = null ]
- }
- - Return [ bool ]
- }
- Function [ <internal:swoole> function swoole_native_socket_getpeername ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> &$address ]
- Parameter #2 [ <optional> &$port = null ]
- }
- - Return [ bool ]
- }
- Function [ <internal:swoole> function swoole_native_socket_create ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> int $domain ]
- Parameter #1 [ <required> int $type ]
- Parameter #2 [ <required> int $protocol ]
- }
- - Return [ Swoole\Coroutine\Socket|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_connect ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> string $address ]
- Parameter #2 [ <optional> ?int $port = null ]
- }
- - Return [ bool ]
+ - Return [ array ]
}
- Function [ <internal:swoole> function swoole_native_socket_strerror ] {
+ Function [ <internal:swoole> function swoole_timer_clear ] {
- Parameters [1] {
- Parameter #0 [ <required> int $error_code ]
- }
- - Return [ string ]
- }
- Function [ <internal:swoole> function swoole_native_socket_bind ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> string $address ]
- Parameter #2 [ <optional> int $port = 0 ]
- }
- - Return [ bool ]
- }
- Function [ <internal:swoole> function swoole_native_socket_recv ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> &$data ]
- Parameter #2 [ <required> int $length ]
- Parameter #3 [ <required> int $flags ]
- }
- - Return [ int|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_send ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> string $data ]
- Parameter #2 [ <required> int $length ]
- Parameter #3 [ <required> int $flags ]
- }
- - Return [ int|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_recvfrom ] {
-
- - Parameters [6] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> &$data ]
- Parameter #2 [ <required> int $length ]
- Parameter #3 [ <required> int $flags ]
- Parameter #4 [ <required> &$address ]
- Parameter #5 [ <optional> &$port = null ]
- }
- - Return [ int|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_sendto ] {
-
- - Parameters [6] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> string $data ]
- Parameter #2 [ <required> int $length ]
- Parameter #3 [ <required> int $flags ]
- Parameter #4 [ <required> string $address ]
- Parameter #5 [ <optional> ?int $port = null ]
- }
- - Return [ int|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_get_option ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> int $level ]
- Parameter #2 [ <required> int $option ]
- }
- - Return [ array|int|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_set_option ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> int $level ]
- Parameter #2 [ <required> int $option ]
- Parameter #3 [ <required> $value ]
- }
- - Return [ bool ]
- }
- Function [ <internal:swoole> function swoole_native_socket_getopt ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> int $level ]
- Parameter #2 [ <required> int $option ]
- }
- - Return [ array|int|false ]
- }
- Function [ <internal:swoole> function swoole_native_socket_setopt ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <required> int $level ]
- Parameter #2 [ <required> int $option ]
- Parameter #3 [ <required> $value ]
+ Parameter #0 [ <required> int $timer_id ]
}
- Return [ bool ]
}
- Function [ <internal:swoole> function swoole_native_socket_shutdown ] {
+ Function [ <internal:swoole> function swoole_timer_clear_all ] {
- - Parameters [2] {
- Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
- Parameter #1 [ <optional> int $mode = 2 ]
+ - Parameters [0] {
}
- Return [ bool ]
}
- Function [ <internal:swoole> function swoole_native_socket_last_error ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> ?Swoole\Coroutine\Socket $socket = null ]
- }
- - Return [ int ]
- }
- Function [ <internal:swoole> function swoole_native_socket_clear_error ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> ?Swoole\Coroutine\Socket $socket = null ]
- }
- - Return [ void ]
- }
- Function [ <internal:swoole> function swoole_native_socket_import_stream ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $stream ]
- }
- - Return [ Swoole\Coroutine\Socket ]
- }
Function [ <internal:swoole> function swoole_native_curl_close ] {
- Parameters [1] {
@@ -1890,19 +1667,21 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Method [ <internal:swoole> public method setPriority ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> int $which ]
Parameter #1 [ <required> int $priority ]
+ Parameter #2 [ <optional> ?int $who = null ]
}
- Return [ bool ]
}
Method [ <internal:swoole> public method getPriority ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> int $which ]
+ Parameter #1 [ <optional> ?int $who = null ]
}
- - Return [ int ]
+ - Return [ int|false ]
}
Method [ <internal:swoole> public method set ] {
@@ -3457,7 +3236,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
- Parameters [0] {
}
- - Return [ int ]
+ - Return [ mixed ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
@@ -3986,7 +3765,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Property [ public $errMsg = '' ]
}
- - Methods [31] {
+ - Methods [32] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -4038,6 +3817,14 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
- Return [ bool ]
}
+ Method [ <internal:swoole> public method getBoundCid ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $event ]
+ }
+ - Return [ int ]
+ }
+
Method [ <internal:swoole> public method peek ] {
- Parameters [1] {
@@ -4067,7 +3854,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Method [ <internal:swoole> public method recvLine ] {
- Parameters [2] {
- Parameter #0 [ <optional> int $length = 65535 ]
+ Parameter #0 [ <optional> int $length = 65536 ]
Parameter #1 [ <optional> float $timeout = 0 ]
}
- Return [ string|false ]
@@ -4076,7 +3863,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Method [ <internal:swoole> public method recvWithBuffer ] {
- Parameters [2] {
- Parameter #0 [ <optional> int $length = 65535 ]
+ Parameter #0 [ <optional> int $length = 65536 ]
Parameter #1 [ <optional> float $timeout = 0 ]
}
- Return [ string|false ]
@@ -4624,7 +4411,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Property [ public $errCode = 0 ]
Property [ public $errMsg = '' ]
Property [ public $fd = -1 ]
- Property [ private $socket = NULL ]
+ Property [ public $socket = NULL ]
Property [ public $type = 1 ]
Property [ public $setting = NULL ]
Property [ public $connected = false ]
@@ -4788,7 +4575,8 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
- Static methods [0] {
}
- - Properties [18] {
+ - Properties [19] {
+ Property [ public $socket = NULL ]
Property [ public $errCode = 0 ]
Property [ public $errMsg = '' ]
Property [ public $connected = false ]
@@ -5142,12 +4930,13 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
- Static methods [0] {
}
- - Properties [9] {
+ - Properties [10] {
Property [ public $errCode = 0 ]
Property [ public $errMsg = '' ]
Property [ public $sock = -1 ]
Property [ public $type = 0 ]
Property [ public $setting = NULL ]
+ Property [ public $socket = NULL ]
Property [ public $connected = false ]
Property [ public $host = NULL ]
Property [ public $port = 0 ]
@@ -5413,7 +5202,8 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
- Static methods [0] {
}
- - Properties [9] {
+ - Properties [10] {
+ Property [ private $socket = NULL ]
Property [ public $serverInfo = NULL ]
Property [ public $sock = -1 ]
Property [ public $connected = false ]
@@ -7589,7 +7379,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Parameter #3 [ <required> mixed $data ]
Parameter #4 [ <optional> bool $json_decode = true ]
}
- - Return [ string|false ]
+ - Return [ array|string|false ]
}
Method [ <internal:swoole> public method addCommand ] {
@@ -8667,7 +8457,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Parameter #3 [ <required> mixed $data ]
Parameter #4 [ <optional> bool $json_decode = true ]
}
- - Return [ string|false ]
+ - Return [ array|string|false ]
}
Method [ <internal:swoole, inherits Swoole\Server> public method addCommand ] {
@@ -9213,7 +9003,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Parameter #3 [ <required> mixed $data ]
Parameter #4 [ <optional> bool $json_decode = true ]
}
- - Return [ string|false ]
+ - Return [ array|string|false ]
}
Method [ <internal:swoole, inherits Swoole\Server> public method addCommand ] {
@@ -9761,7 +9551,7 @@ Extension [ <persistent> extension #107 swoole version 5.0.1 ] {
Parameter #3 [ <required> mixed $data ]
Parameter #4 [ <optional> bool $json_decode = true ]
}
- - Return [ string|false ]
+ - Return [ array|string|false ]
}
Method [ <internal:swoole, inherits Swoole\Server> public method addCommand ] {
diff --git a/php-pecl-swoole5.spec b/php-pecl-swoole5.spec
index 237b8e9..156591c 100644
--- a/php-pecl-swoole5.spec
+++ b/php-pecl-swoole5.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-swoole5
#
-# Copyright (c) 2013-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2013-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -40,7 +40,7 @@
%bcond_with curl
%endif
-%global upstream_version 5.0.1
+%global upstream_version 5.0.2
#global upstream_prever RC2
@@ -48,10 +48,10 @@ Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}5
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-# Extension is ASL 2.0
-# Hiredis is BSD
+# Extension is Apache-2.0
+# Hiredis is BSD-3-Clause
# nlohmann/json is MIT
-License: ASL 2.0 and BSD and MIT
+License: Apache-2.0 AND BSD-3-Clause AND MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -340,6 +340,9 @@ cd ../ZTS
%changelog
+* Mon Feb 6 2023 Remi Collet <remi@remirepo.net> - 5.0.2-1
+- update to 5.0.2
+
* Mon Nov 7 2022 Remi Collet <remi@remirepo.net> - 5.0.1-1
- update to 5.0.1