summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec11
1 files changed, 9 insertions, 2 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index ecf0375..bc7c99f 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -36,7 +36,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.2.1
+Version: 4.2.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
@@ -168,8 +168,11 @@ mv %{pecl_name}-%{version} NTS
cd NTS
+# See https://github.com/swoole/swoole-src/issues/2038
+sed -e 's/4.2.2-alpha/%{version}/' -i include/swoole.h
+
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
+extver=$(sed -n '/#define SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' include/swoole.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
exit 1
@@ -340,6 +343,10 @@ cd ../ZTS
%changelog
+* Mon Oct 15 2018 Remi Collet <remi@remirepo.net> - 4.2.2-1
+- update to 4.2.2
+- open https://github.com/swoole/swoole-src/issues/2038 bad version
+
* Wed Sep 19 2018 Remi Collet <remi@remirepo.net> - 4.2.1-1
- update to 4.2.1