summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec17
1 files changed, 16 insertions, 1 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index e2fbabe..2fe1009 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -34,13 +34,18 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Patch0: https://github.com/swoole/swoole-src/commit/bebc3a0890156b9067b19f9c56766d132647fd58.patch
+Patch1: https://github.com/swoole/swoole-src/commit/7d4eaed41ae94237ed9e4ae72ac166b6e7617047.patch
+Patch2: https://github.com/swoole/swoole-src/commit/0a1ab3d5b1cfde8b905192bec0535bc61b92871a.patch
+Patch3: https://patch-diff.githubusercontent.com/raw/swoole/swoole-src/pull/3686.patch
+
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
%else
@@ -160,6 +165,11 @@ sed \
cd NTS
+%patch0 -p1 -b .up0
+%patch1 -p1 -b .up1
+%patch2 -p1 -b .up2
+%patch3 -p1 -b .pr3686
+
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -328,6 +338,11 @@ cd ../ZTS
%changelog
+* Sun Sep 20 2020 Remi Collet <remi@remirepo.net> - 4.5.4-2
+- add upstream patch for EL-6 and for PHP 8
+- add patch for EL-6 from
+ https://github.com/swoole/swoole-src/pull/3686
+
* Sun Sep 20 2020 Remi Collet <remi@remirepo.net> - 4.5.4-1
- update to 4.5.4
- open https://github.com/swoole/swoole-src/issues/3681 broken build on EL-6