summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec11
1 files changed, 8 insertions, 3 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 9e60ea1..665e168 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -36,13 +36,15 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
Version: 4.3.0
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: https://github.com/swoole/swoole-src/commit/5fee743356e035e47d260299b80b99d1b020908c.patch
+
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
%else
@@ -167,6 +169,8 @@ sed \
cd NTS
+%patch0 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -205,9 +209,7 @@ peclbuild() {
%configure \
--enable-swoole \
--enable-sockets \
-%if %{__isa_bits} == 64
--enable-trace-log \
-%endif
--enable-openssl \
--enable-http2 \
%if %{with_pgsql}
@@ -337,6 +339,9 @@ cd ../ZTS
%changelog
+* Mon Mar 11 2019 Remi Collet <remi@remirepo.net> - 4.3.0-2
+- test build for upstream patch
+
* Thu Mar 7 2019 Remi Collet <remi@remirepo.net> - 4.3.0-1
- update to 4.3.0
- drop dependencies on libnghttp2 and c-ares