summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole4.spec')
-rw-r--r--php-pecl-swoole4.spec23
1 files changed, 14 insertions, 9 deletions
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index f871837..73ecbe9 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,16 +27,19 @@
%global with_brotli 0
%endif
+%global upstream_version 4.4.13
+%global upstream_prever RC1
+
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.4.12
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
@@ -148,7 +151,7 @@ These are the files needed to compile programs using %{name}.
%prep
%setup -q -c
-mv %{pecl_name}-%{version} NTS
+mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
# Don't install/register tests, install examples as doc
@@ -164,8 +167,8 @@ sed \
cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole.h)
-if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
fi
cd ..
@@ -181,13 +184,12 @@ cat << 'EOF' | tee %{ini_name}
extension=%{pecl_name}.so
; Configuration
-;swoole.display_errors = On
;swoole.enable_coroutine = On
;swoole.enable_library = On
;swoole.enable_preemptive_scheduler = Off
-;swoole.fast_serialize = Off
-;swoole.unixsock_buffer_size = 8388608
+;swoole.display_errors = On
:swoole.use_shortname = On
+;swoole.unixsock_buffer_size = 8388608
EOF
@@ -332,6 +334,9 @@ cd ../ZTS
%changelog
+* Thu Dec 5 2019 Remi Collet <remi@remirepo.net> - 4.4.13~RC1-1
+- update to 4.4.13RC1
+
* Mon Nov 4 2019 Remi Collet <remi@remirepo.net> - 4.4.12-1
- update to 4.4.12