summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-30 08:25:57 +0100
committerRemi Collet <remi@remirepo.net>2020-10-30 08:25:57 +0100
commitcef0086f49f65fba7dfafb12239301103c81fb0a (patch)
treeb533b5cb158ef28eacfc835e80d4dd083b62bff4
parent6e3ef0c458738caf7419171b4bcc25823b55db49 (diff)
update to 4.5.6
raise dependency on openssl 1.0.2 (drop EL-6 support) add dependency on json extension
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION43
-rw-r--r--php-pecl-swoole4.spec15
3 files changed, 47 insertions, 17 deletions
diff --git a/PHPINFO b/PHPINFO
index 2ffef5e..1e71816 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.5.5
-Built => Oct 15 2020 00:00:00
+Version => 4.5.6
+Built => Oct 30 2020 00:00:00
coroutine => enabled
trace_log => enabled
epoll => enabled
@@ -18,7 +18,7 @@ openssl => OpenSSL 1.1.1g FIPS 21 Apr 2020
http2 => enabled
pcre => enabled
zlib => 1.2.11
-brotli => E16777223/D16777223
+brotli => E16777225/D16777225
mutex_timedlock => enabled
pthread_barrier => enabled
futex => enabled
diff --git a/REFLECTION b/REFLECTION
index 1035325..ab153b3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 swoole version 4.5.5 ] {
+Extension [ <persistent> extension #117 swoole version 4.5.6 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -21,12 +21,12 @@ Extension [ <persistent> extension #117 swoole version 4.5.5 ] {
}
}
- - Constants [353] {
- Constant [ string SWOOLE_VERSION ] { 4.5.5 }
- Constant [ int SWOOLE_VERSION_ID ] { 40505 }
+ - Constants [354] {
+ Constant [ string SWOOLE_VERSION ] { 4.5.6 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40506 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 5 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 5 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 6 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -139,16 +139,17 @@ Extension [ <persistent> extension #117 swoole version 4.5.5 ] {
Constant [ int SWOOLE_ERROR_AIO_CANCELED ] { 4002 }
Constant [ int SWOOLE_ERROR_AIO_TIMEOUT ] { 4003 }
Constant [ int SWOOLE_ERROR_CLIENT_NO_CONNECTION ] { 5001 }
- Constant [ int SWOOLE_ERROR_SOCKET_CLOSED ] { 5002 }
+ Constant [ int SWOOLE_ERROR_SOCKET_CLOSED ] { 6001 }
+ Constant [ int SWOOLE_ERROR_SOCKET_POLL_TIMEOUT ] { 6002 }
Constant [ int SWOOLE_ERROR_SOCKS5_UNSUPPORT_VERSION ] { 7001 }
Constant [ int SWOOLE_ERROR_SOCKS5_UNSUPPORT_METHOD ] { 7002 }
Constant [ int SWOOLE_ERROR_SOCKS5_AUTH_FAILED ] { 7003 }
Constant [ int SWOOLE_ERROR_SOCKS5_SERVER_ERROR ] { 7004 }
Constant [ int SWOOLE_ERROR_SOCKS5_HANDSHAKE_FAILED ] { 7005 }
- Constant [ int SWOOLE_ERROR_HTTP_PROXY_HANDSHAKE_ERROR ] { 8001 }
- Constant [ int SWOOLE_ERROR_HTTP_INVALID_PROTOCOL ] { 8002 }
- Constant [ int SWOOLE_ERROR_HTTP_PROXY_HANDSHAKE_FAILED ] { 8003 }
- Constant [ int SWOOLE_ERROR_HTTP_PROXY_BAD_RESPONSE ] { 8004 }
+ Constant [ int SWOOLE_ERROR_HTTP_PROXY_HANDSHAKE_ERROR ] { 7101 }
+ Constant [ int SWOOLE_ERROR_HTTP_INVALID_PROTOCOL ] { 7102 }
+ Constant [ int SWOOLE_ERROR_HTTP_PROXY_HANDSHAKE_FAILED ] { 7103 }
+ Constant [ int SWOOLE_ERROR_HTTP_PROXY_BAD_RESPONSE ] { 7104 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_BAD_CLIENT ] { 8501 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_BAD_OPCODE ] { 8502 }
Constant [ int SWOOLE_ERROR_WEBSOCKET_UNCONNECTED ] { 8503 }
@@ -520,6 +521,26 @@ Extension [ <persistent> extension #117 swoole version 4.5.5 ] {
- Parameters [0] {
}
}
+ Function [ <internal:swoole> function swoole_substr_unserialize ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str ]
+ Parameter #1 [ <required> $offset ]
+ Parameter #2 [ <optional> $length ]
+ Parameter #3 [ <optional> $options ]
+ }
+ }
+ Function [ <internal:swoole> function swoole_substr_json_decode ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $json ]
+ Parameter #1 [ <required> $offset ]
+ Parameter #2 [ <optional> $length ]
+ Parameter #3 [ <optional> $associative ]
+ Parameter #4 [ <optional> $depth ]
+ Parameter #5 [ <optional> $flags ]
+ }
+ }
Function [ <internal:swoole> function swoole_internal_call_user_shutdown_begin ] {
- Parameters [0] {
@@ -6778,7 +6799,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.5 ] {
}
}
- Method [ <internal:swoole> public method onAccept ] {
+ Method [ <internal:swoole> private method onAccept ] {
- Parameters [0] {
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 9cf2dbe..921ff08 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -17,7 +17,7 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name swoole
-# After 20-sockets
+# After 20-sockets, 20-json and 20-mysqlnd
%global ini_name 40-%{pecl_name}.ini
%global with_nghttpd2 1
@@ -27,7 +27,7 @@
%global with_brotli 0
%endif
-%global upstream_version 4.5.5
+%global upstream_version 4.5.6
#global upstream_prever RC2
@@ -49,10 +49,11 @@ BuildRequires: %{?dtsprefix}gcc-c++
%endif
BuildRequires: %{?scl_prefix}php-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-sockets
BuildRequires: %{?scl_prefix}php-mysqlnd
BuildRequires: pcre-devel
-BuildRequires: openssl-devel
+BuildRequires: openssl-devel >= 1.0.2
BuildRequires: zlib-devel
%if %{with_brotli}
BuildRequires: brotli-devel
@@ -60,6 +61,7 @@ BuildRequires: brotli-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-json%{?_isa}
Requires: %{?scl_prefix}php-sockets%{?_isa}
Requires: %{?scl_prefix}php-mysqlnd%{?_isa}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -206,6 +208,7 @@ peclbuild() {
--enable-openssl \
--enable-http2 \
--enable-mysqlnd \
+ --enable-swoole-json \
--with-libdir=%{_lib} \
--with-php-config=$1
@@ -281,6 +284,7 @@ fi
%check
OPT="--no-php-ini"
+[ -f %{php_extdir}/json.so ] && OPT="$OPT -d extension=json.so"
[ -f %{php_extdir}/sockets.so ] && OPT="$OPT -d extension=sockets.so"
[ -f %{php_extdir}/mysqlnd.so ] && OPT="$OPT -d extension=mysqlnd.so"
@@ -331,6 +335,11 @@ cd ../ZTS
%changelog
+* Fri Oct 30 2020 Remi Collet <remi@remirepo.net> - 4.5.6-1
+- update to 4.5.6
+- raise dependency on openssl 1.0.2 (drop EL-6 support)
+- add dependency on json extension
+
* Thu Oct 15 2020 Remi Collet <remi@remirepo.net> - 4.5.5-1
- update to 4.5.5
- drop patches merged upstream