summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-18 07:10:36 +0100
committerRemi Collet <remi@php.net>2021-11-18 07:10:36 +0100
commitc2c0ecd976765cc923ed4d42bda675355624382e (patch)
tree2a3959fd86ba0c32d822b3e4f7c4d6765a4a7f91
parent020d2c2235d3716778d7f8dc5c24d87675181f0d (diff)
update to 4.8.2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION28
-rw-r--r--php-pecl-swoole4.spec5
3 files changed, 29 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index 4c79345..cb500b2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.8.1
-Built => Oct 30 2021 00:00:00
+Version => 4.8.2
+Built => Nov 18 2021 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 8ce01c9..39adcdd 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #162 swoole version 4.8.1 ] {
+Extension [ <persistent> extension #162 swoole version 4.8.2 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -28,12 +28,12 @@ Extension [ <persistent> extension #162 swoole version 4.8.1 ] {
}
}
- - Constants [381] {
- Constant [ string SWOOLE_VERSION ] { 4.8.1 }
- Constant [ int SWOOLE_VERSION_ID ] { 40801 }
+ - Constants [390] {
+ Constant [ string SWOOLE_VERSION ] { 4.8.2 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40802 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 8 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 1 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 2 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -345,6 +345,15 @@ Extension [ <persistent> extension #162 swoole version 4.8.1 ] {
Constant [ int SWOOLE_SERVER_COMMAND_EVENT_WORKER ] { 8 }
Constant [ int SWOOLE_SERVER_COMMAND_WORKER ] { 8 }
Constant [ int SWOOLE_SERVER_COMMAND_TASK_WORKER ] { 16 }
+ Constant [ int SWOOLE_DISPATCH_ROUND ] { 1 }
+ Constant [ int SWOOLE_DISPATCH_FDMOD ] { 2 }
+ Constant [ int SWOOLE_DISPATCH_IDLE_WORKER ] { 3 }
+ Constant [ int SWOOLE_DISPATCH_IPMOD ] { 4 }
+ Constant [ int SWOOLE_DISPATCH_UIDMOD ] { 5 }
+ Constant [ int SWOOLE_DISPATCH_USERFUNC ] { 6 }
+ Constant [ int SWOOLE_DISPATCH_STREAM ] { 7 }
+ Constant [ int SWOOLE_DISPATCH_CO_CONN_LB ] { 8 }
+ Constant [ int SWOOLE_DISPATCH_CO_REQ_LB ] { 9 }
Constant [ int SWOOLE_DISPATCH_RESULT_DISCARD_PACKET ] { -1 }
Constant [ int SWOOLE_DISPATCH_RESULT_CLOSE_CONNECTION ] { -2 }
Constant [ int SWOOLE_DISPATCH_RESULT_USERFUNC_FALLBACK ] { -3 }
@@ -6615,12 +6624,14 @@ Extension [ <persistent> extension #162 swoole version 4.8.1 ] {
- Parameters [0] {
}
+ - Return [ void ]
}
Method [ <internal:swoole, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Return [ void ]
}
Method [ <internal:swoole, prototype Iterator> public method current ] {
@@ -6639,12 +6650,14 @@ Extension [ <persistent> extension #162 swoole version 4.8.1 ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
Method [ <internal:swoole, prototype Countable> public method count ] {
- Parameters [0] {
}
+ - Return [ int ]
}
Method [ <internal:swoole, prototype ArrayAccess> public method offsetExists ] {
@@ -6652,6 +6665,7 @@ Extension [ <persistent> extension #162 swoole version 4.8.1 ] {
- Parameters [1] {
Parameter #0 [ <required> $fd ]
}
+ - Return [ bool ]
}
Method [ <internal:swoole, prototype ArrayAccess> public method offsetGet ] {
@@ -6667,6 +6681,7 @@ Extension [ <persistent> extension #162 swoole version 4.8.1 ] {
Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $value ]
}
+ - Return [ void ]
}
Method [ <internal:swoole, prototype ArrayAccess> public method offsetUnset ] {
@@ -6674,6 +6689,7 @@ Extension [ <persistent> extension #162 swoole version 4.8.1 ] {
- Parameters [1] {
Parameter #0 [ <required> $fd ]
}
+ - Return [ void ]
}
}
}
@@ -7998,6 +8014,7 @@ Extension [ <persistent> extension #162 swoole version 4.8.1 ] {
- Parameters [0] {
}
+ - Return [ string ]
}
}
}
@@ -8043,6 +8060,7 @@ Extension [ <persistent> extension #162 swoole version 4.8.1 ] {
- Parameters [0] {
}
+ - Return [ string ]
}
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index e6e5b69..61979c6 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -28,7 +28,7 @@
%bcond_with brotli
%endif
-%global upstream_version 4.8.1
+%global upstream_version 4.8.2
#global upstream_prever RC2
@@ -330,6 +330,9 @@ cd ../ZTS
%changelog
+* Thu Nov 18 2021 Remi Collet <remi@remirepo.net> - 4.8.2-1
+- update to 4.8.2
+
* Sat Oct 30 2021 Remi Collet <remi@remirepo.net> - 4.8.1-1
- update to 4.8.1
- open https://github.com/swoole/swoole-src/pull/4457