summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-08-11 06:44:57 +0200
committerRemi Collet <remi@remirepo.net>2018-08-11 06:44:57 +0200
commitbe26641575fb26cce2e9dc5ba39a3afa24de50b1 (patch)
treeea55b90cae9db0a95177986dcb4dc36660142696
parent3ce49615578e554449d43c0b82bffa121fadeeaf (diff)
v4.0.4
-rw-r--r--PHPINFO3
-rw-r--r--REFLECTION239
-rw-r--r--php-pecl-swoole4.spec5
3 files changed, 92 insertions, 155 deletions
diff --git a/PHPINFO b/PHPINFO
index 38b940d..884fd1b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,11 @@
swoole
swoole support => enabled
-Version => 4.0.3
+Version => 4.0.4
Author => Swoole Group[email: team@swoole.com]
coroutine => enabled
epoll => enabled
eventfd => enabled
-timerfd => enabled
signalfd => enabled
cpu affinity => enabled
spinlock => enabled
diff --git a/REFLECTION b/REFLECTION
index d289682..4997035 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
+Extension [ <persistent> extension #147 swoole version 4.0.4 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -21,7 +21,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
- - Constants [151] {
+ - Constants [164] {
Constant [ integer SWOOLE_BASE ] { 4 }
Constant [ integer SWOOLE_THREAD ] { 2 }
Constant [ integer SWOOLE_PROCESS ] { 3 }
@@ -66,7 +66,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.0.3 }
+ Constant [ string SWOOLE_VERSION ] { 4.0.4 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -170,6 +170,19 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Constant [ integer WEBSOCKET_STATUS_HANDSHAKE ] { 2 }
Constant [ integer WEBSOCKET_STATUS_FRAME ] { 3 }
Constant [ integer WEBSOCKET_STATUS_ACTIVE ] { 3 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_NO_ERROR ] { 0 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_PROTOCOL_ERROR ] { 1 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_INTERNAL_ERROR ] { 2 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_FLOW_CONTROL_ERROR ] { 3 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_SETTINGS_TIMEOUT ] { 4 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_STREAM_CLOSED ] { 5 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_FRAME_SIZE_ERROR ] { 6 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_REFUSED_STREAM ] { 7 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_CANCEL ] { 8 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_COMPRESSION_ERROR ] { 9 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_CONNECT_ERROR ] { 10 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_ENHANCE_YOUR_CALM ] { 11 }
+ Constant [ integer SWOOLE_HTTP2_ERROR_INADEQUATE_SECURITY ] { 12 }
Constant [ integer SWOOLE_FAST_PACK ] { 1 }
Constant [ integer UNSERIALIZE_OBJECT_TO_ARRAY ] { 1 }
Constant [ integer UNSERIALIZE_OBJECT_TO_STDCLASS ] { 2 }
@@ -459,7 +472,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $worker_pid ]
}
- - Methods [42] {
+ - Methods [40] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -767,12 +780,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Parameter #1 [ <required> $uid ]
}
}
-
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
}
}
@@ -1163,7 +1170,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $connections ]
}
- - Methods [7] {
+ - Methods [5] {
Method [ <internal:swoole, ctor> private method __construct ] {
- Parameters [0] {
@@ -1191,12 +1198,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
-
Method [ <internal:swoole> public method getSocket ] {
- Parameters [0] {
@@ -1590,18 +1591,16 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Static methods [0] {
}
- - Properties [8] {
+ - Properties [6] {
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
- Property [ <default> public $reuse ]
- Property [ <default> public $reuseCount ]
Property [ <default> public $type ]
Property [ <default> public $id ]
Property [ <default> public $setting ]
Property [ <default> public $connected ]
}
- - Methods [19] {
+ - Methods [17] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -1713,12 +1712,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
-
Method [ <internal:swoole> public method getSocket ] {
- Parameters [0] {
@@ -1748,7 +1741,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $errMsg ]
}
- - Methods [154] {
+ - Methods [152] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -2443,12 +2436,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Method [ <internal:swoole> public method script ] {
}
-
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
}
}
@@ -2584,7 +2571,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $errno ]
}
- - Methods [15] {
+ - Methods [13] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [0] {
@@ -2646,8 +2633,9 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Method [ <internal:swoole> public method prepare ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $query ]
+ Parameter #1 [ <optional> $timeout ]
}
}
@@ -2669,12 +2657,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Parameters [0] {
}
}
-
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
}
}
@@ -2696,7 +2678,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $errno ]
}
- - Methods [7] {
+ - Methods [5] {
Method [ <internal:swoole> public method execute ] {
- Parameters [2] {
@@ -2728,12 +2710,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Parameters [0] {
}
}
-
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
}
}
@@ -2805,11 +2781,9 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Static methods [0] {
}
- - Properties [19] {
+ - Properties [17] {
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
- Property [ <default> public $reuse ]
- Property [ <default> public $reuseCount ]
Property [ <default> public $type ]
Property [ <default> public $setting ]
Property [ <default> public $connected ]
@@ -2827,7 +2801,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $body ]
}
- - Methods [21] {
+ - Methods [19] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -2968,12 +2942,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Parameter #2 [ <optional> $finish ]
}
}
-
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
}
}
@@ -2985,7 +2953,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Static properties [0] {
}
- - Static methods [15] {
+ - Static methods [16] {
Method [ <internal:swoole> static public method create ] {
- Parameters [1] {
@@ -3007,6 +2975,12 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
+ Method [ <internal:swoole> static public method yield ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> static public method suspend ] {
- Parameters [0] {
@@ -3538,7 +3512,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Properties [0] {
}
- - Methods [23] {
+ - Methods [21] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
@@ -3657,12 +3631,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
-
Method [ <internal:swoole, prototype Iterator> public method rewind ] {
- Parameters [0] {
@@ -3843,7 +3811,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [8] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -3899,12 +3867,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Parameter #1 [ <required> $new_value ]
}
}
-
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
}
}
@@ -3922,7 +3884,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [6] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -3964,12 +3926,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Parameter #1 [ <required> $new_value ]
}
}
-
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
}
}
@@ -4018,7 +3974,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $setting ]
}
- - Methods [42] {
+ - Methods [40] {
Method [ <internal:swoole, overwrites Swoole\Server, prototype Swoole\Server> public method on ] {
- Parameters [2] {
@@ -4033,12 +3989,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
- Method [ <internal:swoole, overwrites Swoole\Server, prototype Swoole\Server> public method __sleep ] {
- }
-
- Method [ <internal:swoole, overwrites Swoole\Server, prototype Swoole\Server> public method __wakeup ] {
- }
-
Method [ <internal:swoole, inherits Swoole\Server, ctor> public method __construct ] {
- Parameters [4] {
@@ -4359,7 +4309,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $trailer ]
}
- - Methods [15] {
+ - Methods [13] {
Method [ <internal:swoole> public method initHeader ] {
- Parameters [0] {
@@ -4461,12 +4411,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
-
Method [ <internal:swoole, dtor> public method __destruct ] {
- Parameters [0] {
@@ -4498,7 +4442,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $tmpfiles ]
}
- - Methods [5] {
+ - Methods [3] {
Method [ <internal:swoole> public method rawcontent ] {
- Parameters [0] {
@@ -4511,12 +4455,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
-
Method [ <internal:swoole, dtor> public method __destruct ] {
- Parameters [0] {
@@ -4539,7 +4477,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [10] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -4609,12 +4547,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Parameters [0] {
}
}
-
- Method [ <internal:swoole> public method __sleep ] {
- }
-
- Method [ <internal:swoole> public method __wakeup ] {
- }
}
}
@@ -4679,7 +4611,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $setting ]
}
- - Methods [45] {
+ - Methods [43] {
Method [ <internal:swoole, overwrites Swoole\Http\Server, prototype Swoole\Server> public method on ] {
- Parameters [2] {
@@ -4727,12 +4659,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
- Method [ <internal:swoole, inherits Swoole\Http\Server, prototype Swoole\Server> public method __sleep ] {
- }
-
- Method [ <internal:swoole, inherits Swoole\Http\Server, prototype Swoole\Server> public method __wakeup ] {
- }
-
Method [ <internal:swoole, inherits Swoole\Server, ctor> public method __construct ] {
- Parameters [4] {
@@ -5720,31 +5646,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
- Class [ <internal:swoole> class Swoole\Http2\Response ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [7] {
- Property [ <default> public $errCode ]
- Property [ <default> public $statusCode ]
- Property [ <default> public $headers ]
- Property [ <default> public $set_cookie_headers ]
- Property [ <default> public $cookies ]
- Property [ <default> public $body ]
- Property [ <default> public $streamId ]
- }
-
- - Methods [0] {
- }
- }
-
Class [ <internal:swoole> class Swoole\Coroutine\Http2\Client ] {
- Constants [0] {
@@ -5756,11 +5657,10 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- Static methods [0] {
}
- - Properties [9] {
+ - Properties [8] {
Property [ <default> public $errCode ]
+ Property [ <default> public $errMsg ]
Property [ <default> public $sock ]
- Property [ <default> public $reuse ]
- Property [ <default> public $reuseCount ]
Property [ <default> public $type ]
Property [ <default> public $setting ]
Property [ <default> public $connected ]
@@ -5768,7 +5668,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $port ]
}
- - Methods [8] {
+ - Methods [10] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -5797,6 +5697,13 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
+ Method [ <internal:swoole> public method stats ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
Method [ <internal:swoole> public method send ] {
- Parameters [1] {
@@ -5820,6 +5727,14 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
+ Method [ <internal:swoole> public method goaway ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $error_code ]
+ Parameter #1 [ <optional> $debug_data ]
+ }
+ }
+
Method [ <internal:swoole> public method close ] {
- Parameters [0] {
@@ -5853,6 +5768,32 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
}
}
+ Class [ <internal:swoole> class Swoole\Http2\Response ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [8] {
+ Property [ <default> public $streamId ]
+ Property [ <default> public $errCode ]
+ Property [ <default> public $statusCode ]
+ Property [ <default> public $pipeline ]
+ Property [ <default> public $headers ]
+ Property [ <default> public $set_cookie_headers ]
+ Property [ <default> public $cookies ]
+ Property [ <default> public $data ]
+ }
+
+ - Methods [0] {
+ }
+ }
+
Class [ <internal:swoole> class Swoole\Serialize ] {
- Constants [0] {
@@ -6108,7 +6049,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Property [ <default> public $worker_pid ]
}
- - Methods [43] {
+ - Methods [41] {
Method [ <internal:swoole, overwrites Swoole\Server, prototype Swoole\Server> public method start ] {
- Parameters [0] {
@@ -6426,12 +6367,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
Parameter #1 [ <required> $uid ]
}
}
-
- Method [ <internal:swoole, inherits Swoole\Server> public method __sleep ] {
- }
-
- Method [ <internal:swoole, inherits Swoole\Server> public method __wakeup ] {
- }
}
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index dc9faa5..208af20 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -30,7 +30,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.0.3
+Version: 4.0.4
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
@@ -312,6 +312,9 @@ cd ../ZTS
%changelog
+* Sat Aug 11 2018 Remi Collet <remi@remirepo.net> - 4.0.4-1
+- update to 4.0.4
+
* Fri Jul 20 2018 Remi Collet <remi@remirepo.net> - 4.0.3-1
- update to 4.0.3