summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-07-16 08:42:45 +0200
committerRemi Collet <remi@remirepo.net>2019-07-16 08:42:45 +0200
commitbdb2ed1bb42a2daa8a290d5aed02b358544f5203 (patch)
tree4269ba9b42197194c9a1e340cd4f3a50f2d04e8e
parent9ee8fb908cf38ffca7effec44b778d0946b1af4e (diff)
v4.4.1
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION107
-rw-r--r--php-pecl-swoole4.spec5
3 files changed, 60 insertions, 56 deletions
diff --git a/PHPINFO b/PHPINFO
index 4972cd6..5017ba4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.4.0
-Built => Jul 7 2019 07:55:38
+Version => 4.4.1
+Built => Jul 16 2019 08:39:17
coroutine => enabled
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 4cfdac9..daa24a6 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 swoole version 4.4.0 ] {
+Extension [ <persistent> extension #153 swoole version 4.4.1 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -22,11 +22,11 @@ Extension [ <persistent> extension #153 swoole version 4.4.0 ] {
}
- Constants [311] {
- Constant [ string SWOOLE_VERSION ] { 4.4.0 }
- Constant [ integer SWOOLE_VERSION_ID ] { 40400 }
+ Constant [ string SWOOLE_VERSION ] { 4.4.1 }
+ Constant [ integer SWOOLE_VERSION_ID ] { 40401 }
Constant [ integer SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ integer SWOOLE_MINOR_VERSION ] { 4 }
- Constant [ integer SWOOLE_RELEASE_VERSION ] { 0 }
+ Constant [ integer SWOOLE_RELEASE_VERSION ] { 1 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ boolean SWOOLE_DEBUG ] { }
Constant [ integer SWOOLE_BASE ] { 1 }
@@ -1915,7 +1915,8 @@ Extension [ <persistent> extension #153 swoole version 4.4.0 ] {
Method [ <internal:swoole> static public method getPcid ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $cid ]
}
}
@@ -2392,54 +2393,6 @@ Extension [ <persistent> extension #153 swoole version 4.4.0 ] {
}
}
- Class [ <internal:swoole> final class Swoole\Coroutine\Scheduler ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [1] {
- Property [ <default> private $_list ]
- }
-
- - Methods [4] {
- Method [ <internal:swoole> public method add ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> callable $func ]
- Parameter #1 [ <optional> ...$params ]
- }
- }
-
- Method [ <internal:swoole> public method parallel ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $n ]
- Parameter #1 [ <optional> callable $func ]
- Parameter #2 [ <optional> ...$params ]
- }
- }
-
- Method [ <internal:swoole> public method set ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $settings ]
- }
- }
-
- Method [ <internal:swoole> public method start ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
Class [ <internal:swoole> class Swoole\ExitException extends Swoole\Exception implements Throwable ] {
- Constants [0] {
@@ -2511,6 +2464,54 @@ Extension [ <persistent> extension #153 swoole version 4.4.0 ] {
}
}
+ Class [ <internal:swoole> final class Swoole\Coroutine\Scheduler ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> private $_list ]
+ }
+
+ - Methods [4] {
+ Method [ <internal:swoole> public method add ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> callable $func ]
+ Parameter #1 [ <optional> ...$params ]
+ }
+ }
+
+ Method [ <internal:swoole> public method parallel ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $n ]
+ Parameter #1 [ <optional> callable $func ]
+ Parameter #2 [ <optional> ...$params ]
+ }
+ }
+
+ Method [ <internal:swoole> public method set ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $settings ]
+ }
+ }
+
+ Method [ <internal:swoole> public method start ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:swoole> class Swoole\Coroutine\Channel ] {
- Constants [0] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index db8f067..0622d36 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -30,7 +30,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.4.0
+Version: 4.4.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
@@ -327,6 +327,9 @@ cd ../ZTS
%changelog
+* Tue Jul 16 2019 Remi Collet <remi@remirepo.net> - 4.4.1-1
+- update to 4.4.1
+
* Sun Jul 7 2019 Remi Collet <remi@remirepo.net> - 4.4.0-1
- update to 4.4.0
- raise dependency on PHP 7.1