summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-09-05 07:48:08 +0200
committerRemi Collet <remi@remirepo.net>2018-09-05 07:48:08 +0200
commitb6549f7aacc999c9d2241a1fa559124498dfce11 (patch)
tree8bb0a9a2e3df210eec39d7af8fa55de9b5c9ed36
parentbb8a1252879e4ccdf0c2b803e6d7b0a58b76038f (diff)
v4.1.2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION13
-rw-r--r--php-pecl-swoole4.spec9
3 files changed, 17 insertions, 7 deletions
diff --git a/PHPINFO b/PHPINFO
index 7a65e9d..056c5f4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
swoole
swoole support => enabled
-Version => 4.1.1
+Version => 4.1.2
Author => Swoole Group[email: team@swoole.com]
coroutine => enabled
trace-log => enabled
diff --git a/REFLECTION b/REFLECTION
index 903ecd2..cc45892 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #148 swoole version 4.1.1 ] {
+Extension [ <persistent> extension #148 swoole version 4.1.2 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -69,7 +69,7 @@ Extension [ <persistent> extension #148 swoole version 4.1.1 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.1.1 }
+ Constant [ string SWOOLE_VERSION ] { 4.1.2 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -2653,19 +2653,22 @@ Extension [ <persistent> extension #148 swoole version 4.1.1 ] {
Method [ <internal:swoole> public method begin ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
}
}
Method [ <internal:swoole> public method commit ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
}
}
Method [ <internal:swoole> public method rollback ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index bb14709..fc317c1 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -36,7 +36,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.1.1
+Version: 4.1.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
@@ -161,6 +161,8 @@ mv %{pecl_name}-%{version} NTS
# Don't install/register tests, install examples as doc
sed -e '/examples/s/role="src"/role="doc"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/name="tests/s/role="..."/role="test"/' \
+ -e '/CMake/s/role="doc"/role="src"/' \
-i package.xml
@@ -328,6 +330,8 @@ cd ../ZTS
%files devel
%doc %{pecl_testdir}/%{pecl_name}
%doc %{pecl_docdir}/%{pecl_name}/examples
+%doc %{pecl_docdir}/%{pecl_name}/.github/ISSUE_TEMPLATE
+%doc %{pecl_docdir}/%{pecl_name}/include/readme
%{php_incldir}/ext/%{pecl_name}
%if %{with_zts}
@@ -336,6 +340,9 @@ cd ../ZTS
%changelog
+* Wed Sep 5 2018 Remi Collet <remi@remirepo.net> - 4.1.2-1
+- update to 4.1.2
+
* Fri Aug 31 2018 Remi Collet <remi@remirepo.net> - 4.1.1-1
- update to 4.1.1 (no change)