summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-21 13:48:53 +0200
committerRemi Collet <remi@remirepo.net>2018-06-21 13:48:53 +0200
commitafeb6a6baca612d074a88e46e78ab15e485db23b (patch)
treede762d2431c797cce562320bbd1b1c1fd601f9fe
parent893b8eba991c0225cafe2d1eb674e1eb758739a0 (diff)
v4.0.1
-rw-r--r--1717.patch22
-rw-r--r--REFLECTION16
-rw-r--r--php-pecl-swoole4.spec12
3 files changed, 16 insertions, 34 deletions
diff --git a/1717.patch b/1717.patch
deleted file mode 100644
index 506c7ca..0000000
--- a/1717.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 2835548fb1ddddcce082cabaa24efa17c2fada95 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 14 Jun 2018 11:21:39 +0200
-Subject: [PATCH] ensure C++ is used for link command
-
----
- config.m4 | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/config.m4 b/config.m4
-index 9664ed075..0b8ced436 100644
---- a/config.m4
-+++ b/config.m4
-@@ -630,7 +630,7 @@ if test "$PHP_SWOOLE" != "no"; then
- LDFLAGS="$LDFLAGS -lboost_context"
- fi
-
-- PHP_NEW_EXTENSION(swoole, $swoole_source_file, $ext_shared)
-+ PHP_NEW_EXTENSION(swoole, $swoole_source_file, $ext_shared,,, cxx)
-
- PHP_ADD_INCLUDE([$ext_srcdir])
- PHP_ADD_INCLUDE([$ext_srcdir/include])
diff --git a/REFLECTION b/REFLECTION
index e411967..786ba32 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #147 swoole version 4.0.0 ] {
+Extension [ <persistent> extension #147 swoole version 4.0.1 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -66,7 +66,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.0 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.0.0 }
+ Constant [ string SWOOLE_VERSION ] { 4.0.1 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -2983,7 +2983,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.0 ] {
- Static properties [0] {
}
- - Static methods [14] {
+ - Static methods [15] {
Method [ <internal:swoole> static public method create ] {
- Parameters [1] {
@@ -3018,6 +3018,12 @@ Extension [ <persistent> extension #147 swoole version 4.0.0 ] {
}
}
+ Method [ <internal:swoole> static public method stats ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> static public method getuid ] {
- Parameters [0] {
@@ -5286,7 +5292,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.0 ] {
- Parameters [3] {
Parameter #0 [ <required> array or NULL &$read_list ]
Parameter #1 [ <required> array or NULL &$write_list ]
- Parameter #2 [ <required> $timeout ]
+ Parameter #2 [ <optional> $timeout ]
}
}
}
@@ -5299,7 +5305,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.0 ] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <required> $size ]
+ Parameter #0 [ <optional> $size ]
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index aae12ca..d0d8756 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -41,17 +41,15 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.0.0
+Version: 4.0.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/swoole/swoole-src/pull/1717.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel > 7.1
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
BuildRequires: %{?scl_prefix}php-mysqlnd
@@ -152,8 +150,6 @@ sed -e '/examples/s/role="src"/role="doc"/' \
cd NTS
-%patch0 -p1 -b .pr1717
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -202,7 +198,6 @@ peclbuild() {
%endif
--enable-thread \
--enable-mysqlnd \
- --enable-coroutine \
--with-libdir=%{_lib} \
--with-php-config=$1
@@ -315,6 +310,9 @@ cd ../ZTS
%changelog
+* Thu Jun 21 2018 Remi Collet <remi@remirepo.net> - 4.0.1-1
+- update to 4.0.1
+
* Thu Jun 14 2018 Remi Collet <remi@remirepo.net> - 4.0.0-1
- update to 4.0.0
- rename to php-pecl-swoole4