summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-13 14:05:14 +0200
committerRemi Collet <remi@remirepo.net>2018-07-13 14:05:14 +0200
commit8ca5ccbfe6a1a16a67bab23b34b3069e811015d3 (patch)
tree714780abe1219befaee4c37561463ac80a8d6c9d
parent01bfcadc856506a9753a636b4f31cfb13490f913 (diff)
v4.0.2
-rw-r--r--PHPINFO34
-rw-r--r--REFLECTION16
-rw-r--r--php-pecl-swoole4.spec12
3 files changed, 50 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..852758f
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,34 @@
+
+swoole
+
+swoole support => enabled
+Version => 4.0.2
+Author => Swoole Group[email: team@swoole.com]
+coroutine => enabled
+epoll => enabled
+eventfd => enabled
+timerfd => enabled
+signalfd => enabled
+cpu affinity => enabled
+spinlock => enabled
+rwlock => enabled
+async postgresql => enabled
+async redis client => enabled
+async http/websocket client => enabled
+sockets => enabled
+openssl => enabled
+http2 => enabled
+pcre => enabled
+zlib => enabled
+mutex_timedlock => enabled
+pthread_barrier => enabled
+futex => enabled
+mysqlnd => enabled
+
+Directive => Local Value => Master Value
+swoole.aio_thread_num => 2 => 2
+swoole.display_errors => On => On
+swoole.use_namespace => On => On
+swoole.use_shortname => On => On
+swoole.fast_serialize => Off => Off
+swoole.unixsock_buffer_size => 8388608 => 8388608
diff --git a/REFLECTION b/REFLECTION
index 786ba32..69d56f1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #147 swoole version 4.0.1 ] {
+Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -66,7 +66,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.1 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.0.1 }
+ Constant [ string SWOOLE_VERSION ] { 4.0.2 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -117,7 +117,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.1 ] {
Constant [ integer SWOOLE_ERROR_SERVER_PIPE_BUFFER_FULL ] { 9006 }
Constant [ integer SWOOLE_ERROR_SERVER_NO_IDLE_WORKER ] { 9007 }
Constant [ integer SWOOLE_ERROR_SERVER_ONLY_START_ONE ] { 9008 }
- Constant [ integer SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9009 }
+ Constant [ integer SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9010 }
Constant [ integer SWOOLE_TRACE_SERVER ] { 2 }
Constant [ integer SWOOLE_TRACE_CLIENT ] { 4 }
Constant [ integer SWOOLE_TRACE_BUFFER ] { 8 }
@@ -2805,7 +2805,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.1 ] {
- Static methods [0] {
}
- - Properties [17] {
+ - Properties [19] {
Property [ <default> public $errCode ]
Property [ <default> public $sock ]
Property [ <default> public $reuse ]
@@ -2820,7 +2820,9 @@ Extension [ <persistent> extension #147 swoole version 4.0.1 ] {
Property [ <default> public $requestHeaders ]
Property [ <default> public $requestBody ]
Property [ <default> public $uploadFiles ]
+ Property [ <default> public $downloadFile ]
Property [ <default> public $headers ]
+ Property [ <default> public $set_cookie_headers ]
Property [ <default> public $cookies ]
Property [ <default> public $body ]
}
@@ -5022,7 +5024,11 @@ Extension [ <persistent> extension #147 swoole version 4.0.1 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [4] {
+ Property [ <default> public $fd ]
+ Property [ <default> public $data ]
+ Property [ <default> public $opcode ]
+ Property [ <default> public $finish ]
}
- Methods [0] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 488e173..11e15a3 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -17,13 +17,8 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name swoole
-%if "%{php_version}" < "5.6"
-# After sockets
-%global ini_name %{pecl_name}.ini
-%else
# After 20-sockets
%global ini_name 40-%{pecl_name}.ini
-%endif
%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
%global with_pgsql 1
@@ -41,8 +36,8 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.0.1
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 4.0.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -319,6 +314,9 @@ cd ../ZTS
%changelog
+* Fri Jul 13 2018 Remi Collet <remi@remirepo.net> - 4.0.2-1
+- update to 4.0.2
+
* Fri Jun 29 2018 Remi Collet <remi@remirepo.net> - 4.0.1-2
- osboletes old versions on F29+, EL-8+ and PHP 7.3+