summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-01 16:17:37 +0100
committerRemi Collet <remi@php.net>2021-12-01 16:17:37 +0100
commit8ac7b3bdc0606c0bb7e1d40e70aca061489e866e (patch)
tree53edab98fe51d63e23d719481b27efeaf1ebc15d
parent79f30f3e9776b9e30df7ad1c1b987404ae6a7efb (diff)
update to 4.8.3
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION234
-rw-r--r--php-pecl-swoole4.spec25
3 files changed, 240 insertions, 23 deletions
diff --git a/PHPINFO b/PHPINFO
index cb500b2..45d91af 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.8.2
-Built => Nov 18 2021 00:00:00
+Version => 4.8.3
+Built => Dec 1 2021 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index b4c5abc..18afc10 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #86 swoole version 4.8.2 ] {
+Extension [ <persistent> extension #86 swoole version 4.8.3 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -29,11 +29,11 @@ Extension [ <persistent> extension #86 swoole version 4.8.2 ] {
}
- Constants [390] {
- Constant [ string SWOOLE_VERSION ] { 4.8.2 }
- Constant [ int SWOOLE_VERSION_ID ] { 40802 }
+ Constant [ string SWOOLE_VERSION ] { 4.8.3 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40803 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 8 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 2 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 3 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -781,6 +781,224 @@ Extension [ <persistent> extension #86 swoole version 4.8.2 ] {
- Parameters [0] {
}
}
+ Function [ <internal:swoole> function swoole_native_socket_create_listen ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $port ]
+ Parameter #1 [ <optional> int $backlog = 128 ]
+ }
+ - Return [ Swoole\Coroutine\Socket|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_accept ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ }
+ - Return [ Swoole\Coroutine\Socket|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_set_nonblock ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_set_block ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_listen ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <optional> int $backlog = 0 ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_close ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ }
+ - Return [ void ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_write ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> string $data ]
+ Parameter #2 [ <optional> ?int $length = null ]
+ }
+ - Return [ int|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_read ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> int $length ]
+ Parameter #2 [ <optional> int $mode = PHP_BINARY_READ ]
+ }
+ - Return [ string|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_getsockname ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> &$address ]
+ Parameter #2 [ <optional> &$port = null ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_getpeername ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> &$address ]
+ Parameter #2 [ <optional> &$port = null ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_create ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> int $domain ]
+ Parameter #1 [ <required> int $type ]
+ Parameter #2 [ <required> int $protocol ]
+ }
+ - Return [ Swoole\Coroutine\Socket|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_connect ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> string $address ]
+ Parameter #2 [ <optional> ?int $port = null ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_strerror ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $error_code ]
+ }
+ - Return [ string ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_bind ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> string $address ]
+ Parameter #2 [ <optional> int $port = 0 ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_recv ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> &$data ]
+ Parameter #2 [ <required> int $length ]
+ Parameter #3 [ <required> int $flags ]
+ }
+ - Return [ int|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_send ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> string $data ]
+ Parameter #2 [ <required> int $length ]
+ Parameter #3 [ <required> int $flags ]
+ }
+ - Return [ int|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_recvfrom ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> &$data ]
+ Parameter #2 [ <required> int $length ]
+ Parameter #3 [ <required> int $flags ]
+ Parameter #4 [ <required> &$address ]
+ Parameter #5 [ <optional> &$port = null ]
+ }
+ - Return [ int|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_sendto ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> string $data ]
+ Parameter #2 [ <required> int $length ]
+ Parameter #3 [ <required> int $flags ]
+ Parameter #4 [ <required> string $address ]
+ Parameter #5 [ <optional> ?int $port = null ]
+ }
+ - Return [ int|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_get_option ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> int $level ]
+ Parameter #2 [ <required> int $option ]
+ }
+ - Return [ array|int|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_set_option ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> int $level ]
+ Parameter #2 [ <required> int $option ]
+ Parameter #3 [ <required> $value ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_getopt ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> int $level ]
+ Parameter #2 [ <required> int $option ]
+ }
+ - Return [ array|int|false ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_setopt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <required> int $level ]
+ Parameter #2 [ <required> int $option ]
+ Parameter #3 [ <required> $value ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_shutdown ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Swoole\Coroutine\Socket $socket ]
+ Parameter #1 [ <optional> int $mode = 2 ]
+ }
+ - Return [ bool ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_last_error ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> ?Swoole\Coroutine\Socket $socket = null ]
+ }
+ - Return [ int ]
+ }
+ Function [ <internal:swoole> function swoole_native_socket_clear_error ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> ?Swoole\Coroutine\Socket $socket = null ]
+ }
+ - Return [ void ]
+ }
Function [ <internal:swoole> function swoole_native_curl_close ] {
- Parameters [1] {
@@ -3415,7 +3633,7 @@ Extension [ <persistent> extension #86 swoole version 4.8.2 ] {
Property [ public $errMsg = '' ]
}
- - Methods [30] {
+ - Methods [31] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -3643,6 +3861,12 @@ Extension [ <persistent> extension #86 swoole version 4.8.2 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:swoole> public method isClosed ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 61979c6..04383ca 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -1,4 +1,3 @@
-# remirepo spec file for php-pecl-swoole4
#
# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
@@ -11,7 +10,6 @@
%undefine _strict_symbol_defs_build
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-swoole4
%endif
@@ -28,12 +26,12 @@
%bcond_with brotli
%endif
-%global upstream_version 4.8.2
+%global upstream_version 4.8.3
#global upstream_prever RC2
Summary: PHP's asynchronous concurrent distributed networking framework
-Name: %{?sub_prefix}php-pecl-%{pecl_name}4
+Name: %{?scl_prefix}php-pecl-%{pecl_name}4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
@@ -75,12 +73,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}4 = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}4%{?_isa} = %{version}-%{release}
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 2
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}2 < 4
-%endif
%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8 || "%{php_version}" > "7.3"
Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 4
@@ -91,9 +83,11 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}2 = %{version}-%{relea
Provides: %{?scl_prefix}php-pecl-%{pecl_name}2%{?_isa} = %{version}-%{release}
%else
# Single version can be installed
-Conflicts: %{?sub_prefix}php-pecl-%{pecl_name} < 4
-Conflicts: %{?sub_prefix}php-pecl-%{pecl_name}2 < 4
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 4
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}2 < 4
%endif
+# Only one extension can be installed (same symbols)
+Conflicts: %{?scl_prefix}php-pecl-openswoole
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
%if "%{php_version}" > "7.4"
@@ -136,10 +130,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
Summary: %{name} developer files (header)
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{?scl_prefix}php-devel%{?_isa}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel%{?_isa} = %{version}-%{release}
-%endif
%description devel
These are the files needed to compile programs using %{name}.
@@ -330,6 +320,9 @@ cd ../ZTS
%changelog
+* Wed Dec 1 2021 Remi Collet <remi@remirepo.net> - 4.8.3-1
+- update to 4.8.3
+
* Thu Nov 18 2021 Remi Collet <remi@remirepo.net> - 4.8.2-1
- update to 4.8.2