summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-20 13:56:07 +0200
committerRemi Collet <remi@remirepo.net>2018-07-20 13:56:07 +0200
commit824788fe7157542ca2a4a141a53c254051ffd803 (patch)
tree61a6a01c0d13bddf34d9dc2462f1f1e163428cbd
parentad6545d33480d53472d5c4efb2af59c64b03a44f (diff)
v4.0.3
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION55
-rw-r--r--php-pecl-swoole4.spec9
3 files changed, 39 insertions, 27 deletions
diff --git a/PHPINFO b/PHPINFO
index 852758f..38b940d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
swoole
swoole support => enabled
-Version => 4.0.2
+Version => 4.0.3
Author => Swoole Group[email: team@swoole.com]
coroutine => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 69d56f1..d289682 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
+Extension [ <persistent> extension #147 swoole version 4.0.3 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -66,7 +66,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 4.0.2 }
+ Constant [ string SWOOLE_VERSION ] { 4.0.3 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -4679,7 +4679,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
Property [ <default> public $setting ]
}
- - Methods [44] {
+ - Methods [45] {
Method [ <internal:swoole, overwrites Swoole\Http\Server, prototype Swoole\Server> public method on ] {
- Parameters [2] {
@@ -4698,6 +4698,15 @@ Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
}
}
+ Method [ <internal:swoole> public method disconnect ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $reason ]
+ }
+ }
+
Method [ <internal:swoole, overwrites Swoole\Server, prototype Swoole\Server> public method exist ] {
- Parameters [1] {
@@ -5292,19 +5301,12 @@ Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
- Static properties [0] {
}
- - Static methods [1] {
- Method [ <internal:swoole> static public method select ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> array or NULL &$read_list ]
- Parameter #1 [ <required> array or NULL &$write_list ]
- Parameter #2 [ <optional> $timeout ]
- }
- }
+ - Static methods [0] {
}
- - Properties [1] {
+ - Properties [2] {
Property [ <default> public $capacity ]
+ Property [ <default> public $errCode ]
}
- Methods [9] {
@@ -5330,7 +5332,8 @@ Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
Method [ <internal:swoole> public method pop ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeout ]
}
}
@@ -5728,9 +5731,12 @@ Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [7] {
Property [ <default> public $errCode ]
Property [ <default> public $statusCode ]
+ Property [ <default> public $headers ]
+ Property [ <default> public $set_cookie_headers ]
+ Property [ <default> public $cookies ]
Property [ <default> public $body ]
Property [ <default> public $streamId ]
}
@@ -5798,12 +5804,6 @@ Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
}
}
- Method [ <internal:swoole> public method recv ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:swoole> public method write ] {
- Parameters [3] {
@@ -5813,6 +5813,13 @@ Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
}
}
+ Method [ <internal:swoole> public method recv ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
+ }
+ }
+
Method [ <internal:swoole> public method close ] {
- Parameters [0] {
@@ -5821,7 +5828,7 @@ Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
}
}
- Class [ <internal:swoole> class Swoole\Coroutine\Http2\Request ] {
+ Class [ <internal:swoole> class Swoole\Http2\Request ] {
- Constants [0] {
}
@@ -5832,9 +5839,11 @@ Extension [ <persistent> extension #147 swoole version 4.0.2 ] {
- Static methods [0] {
}
- - Properties [5] {
+ - Properties [7] {
+ Property [ <default> public $path ]
Property [ <default> public $method ]
Property [ <default> public $headers ]
+ Property [ <default> public $cookies ]
Property [ <default> public $data ]
Property [ <default> public $pipeline ]
Property [ <default> public $files ]
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 60c3071..cbd2a60 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -36,8 +36,8 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.0.2
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 4.0.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -97,7 +97,7 @@ Obsoletes: php71w-pecl-%{pecl_name}4 <= %{version}
Obsoletes: php72u-pecl-%{pecl_name}4 <= %{version}
Obsoletes: php72w-pecl-%{pecl_name}4 <= %{version}
%endif
-%if "%{php_version}" > "7.2"
+%if "%{php_version}" > "7.3"
Obsoletes: php73u-pecl-%{pecl_name}4 <= %{version}
Obsoletes: php73w-pecl-%{pecl_name}4 <= %{version}
%endif
@@ -318,6 +318,9 @@ cd ../ZTS
%changelog
+* Fri Jul 20 2018 Remi Collet <remi@remirepo.net> - 4.0.3-1
+- update to 4.0.3
+
* Wed Jul 18 2018 Remi Collet <remi@remirepo.net> - 4.0.2-2
- rebuild for 7.3.0alpha4 new ABI