summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-15 11:48:32 +0100
committerRemi Collet <remi@remirepo.net>2020-01-15 11:48:32 +0100
commit75fb8c6ae5111d588cc944d49fc55c50ba48f797 (patch)
tree4ae23bb439530aa60a5f1790802be89bd3432f52
parent48491797d4486939729d915d67a0eec408e9ab58 (diff)
v4.4.15
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION33
-rw-r--r--php-pecl-swoole4.spec7
3 files changed, 23 insertions, 21 deletions
diff --git a/PHPINFO b/PHPINFO
index cda10a5..17b716c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.4.14
-Built => Dec 26 2019 00:00:00
+Version => 4.4.15
+Built => Jan 15 2020 00:00:00
coroutine => enabled
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index b4a9f4f..403c87e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 swoole version 4.4.14 ] {
+Extension [ <persistent> extension #108 swoole version 4.4.15 ] {
- INI {
Entry [ swoole.enable_coroutine <ALL> ]
@@ -22,11 +22,11 @@ Extension [ <persistent> extension #108 swoole version 4.4.14 ] {
}
- Constants [329] {
- Constant [ string SWOOLE_VERSION ] { 4.4.14 }
- Constant [ int SWOOLE_VERSION_ID ] { 40414 }
+ Constant [ string SWOOLE_VERSION ] { 4.4.15 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40415 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 4 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 14 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 15 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -395,19 +395,6 @@ Extension [ <persistent> extension #108 swoole version 4.4.14 ] {
Parameter #0 [ <required> callable $callback ]
}
}
- Function [ <internal:swoole> function go ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> callable $func ]
- Parameter #1 [ <optional> ...$params ]
- }
- }
- Function [ <internal:swoole> function defer ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> callable $callback ]
- }
- }
Function [ <internal:swoole> function swoole_client_select ] {
- Parameters [4] {
@@ -477,6 +464,18 @@ Extension [ <persistent> extension #108 swoole version 4.4.14 ] {
- Parameters [0] {
}
}
+ Function [ <internal:swoole> function go ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $func ]
+ }
+ }
+ Function [ <internal:swoole> function defer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ }
Method [ <internal:swoole> public method swoole_event_add ] {
- Parameters [4] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 40b8035..547eac0 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-swoole4
#
-# Copyright (c) 2013-2019 Remi Collet
+# Copyright (c) 2013-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -27,7 +27,7 @@
%global with_brotli 0
%endif
-%global upstream_version 4.4.14
+%global upstream_version 4.4.15
#global upstream_prever RC2
@@ -332,6 +332,9 @@ cd ../ZTS
%changelog
+* Wed Jan 15 2020 Remi Collet <remi@remirepo.net> - 4.4.15-1
+- update to 4.4.15
+
* Thu Dec 26 2019 Remi Collet <remi@remirepo.net> - 4.4.14-1
- update to 4.4.14