summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-27 07:09:55 +0100
committerRemi Collet <remi@remirepo.net>2020-11-27 07:09:55 +0100
commit345ea47467e6fcf56ec9aa3d259f514cc7ee2726 (patch)
tree4d36fd96651e004377d22b5107553b2b8513df19
parent883fc719901ca3cbdc6b3822ffaeda145c4a75d5 (diff)
update to 4.5.9
-rw-r--r--9ab8f1dfd8889f9e8581452c1ecde11cbb702280.patch30
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION11
-rw-r--r--php-pecl-swoole4.spec11
4 files changed, 13 insertions, 43 deletions
diff --git a/9ab8f1dfd8889f9e8581452c1ecde11cbb702280.patch b/9ab8f1dfd8889f9e8581452c1ecde11cbb702280.patch
deleted file mode 100644
index e830498..0000000
--- a/9ab8f1dfd8889f9e8581452c1ecde11cbb702280.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 9ab8f1dfd8889f9e8581452c1ecde11cbb702280 Mon Sep 17 00:00:00 2001
-From: twosee <twose@qq.com>
-Date: Sun, 22 Nov 2020 17:42:41 +0800
-Subject: [PATCH] Fix sw_zend_is_callable_at_frame() (#3868)
-
-* Fix sw_zend_is_callable_at_frame()
-
-* Require PHP 8.0.1
----
- ext-src/php_swoole.h | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/ext-src/php_swoole.h b/ext-src/php_swoole.h
-index ff32a2cccb..96fc4c9b6b 100644
---- a/ext-src/php_swoole.h
-+++ b/ext-src/php_swoole.h
-@@ -912,10 +912,11 @@ static sw_inline zend_bool sw_zend_is_callable_at_frame(zval *zcallable, zval *z
- {
- zend_string *name;
- zend_bool ret;
--#if PHP_VERSION_ID < 80000
-+#if PHP_VERSION_ID < 80001
- ret = zend_is_callable_ex(zcallable, zobject ? Z_OBJ_P(zobject) : NULL, check_flags, &name, fci_cache, error);
- #else
-- ret = zend_is_callable_at_frame(zcallable, zobject ? Z_OBJ_P(zobject) : NULL, frame, check_flags, &name, fci_cache, error);
-+ ret = zend_is_callable_at_frame(zcallable, zobject ? Z_OBJ_P(zobject) : NULL, frame, check_flags, fci_cache, error);
-+ name = zend_get_callable_name_ex(zcallable, zobject);
- #endif
- if (callable_name)
- {
diff --git a/PHPINFO b/PHPINFO
index 3c00379..d1f9ef7 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.5.8
-Built => Nov 21 2020 00:00:00
+Version => 4.5.9
+Built => Nov 27 2020 00:00:00
coroutine => enabled
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 2e22983..a24589f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 swoole version 4.5.8 ] {
+Extension [ <persistent> extension #117 swoole version 4.5.9 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -27,12 +27,12 @@ Extension [ <persistent> extension #117 swoole version 4.5.8 ] {
}
}
- - Constants [358] {
- Constant [ string SWOOLE_VERSION ] { 4.5.8 }
- Constant [ int SWOOLE_VERSION_ID ] { 40508 }
+ - Constants [359] {
+ Constant [ string SWOOLE_VERSION ] { 4.5.9 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40509 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 5 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 8 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 9 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -269,6 +269,7 @@ Extension [ <persistent> extension #117 swoole version 4.5.8 ] {
Constant [ int SWOOLE_HTTP_CLIENT_ESTATUS_CONNECT_FAILED ] { -1 }
Constant [ int SWOOLE_HTTP_CLIENT_ESTATUS_REQUEST_TIMEOUT ] { -2 }
Constant [ int SWOOLE_HTTP_CLIENT_ESTATUS_SERVER_RESET ] { -3 }
+ Constant [ int SWOOLE_HTTP_CLIENT_ESTATUS_SEND_FAILED ] { -4 }
Constant [ int SWOOLE_MYSQLND_CR_UNKNOWN_ERROR ] { 2000 }
Constant [ int SWOOLE_MYSQLND_CR_CONNECTION_ERROR ] { 2002 }
Constant [ int SWOOLE_MYSQLND_CR_SERVER_GONE_ERROR ] { 2006 }
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 8c75805..80cab16 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,22 +27,20 @@
%global with_brotli 0
%endif
-%global upstream_version 4.5.8
+%global upstream_version 4.5.9
#global upstream_prever RC2
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is ASL 2.0
# Hiredis is BSD
License: ASL 2.0 and BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: https://github.com/swoole/swoole-src/commit/9ab8f1dfd8889f9e8581452c1ecde11cbb702280.patch
-
%if 0%{?rhel} == 6
BuildRequires: devtoolset-6-toolchain
%else
@@ -167,8 +165,6 @@ sed \
cd NTS
-%patch0 -p1 -b .up
-
# Sanity check, really often broken
extver=$(sed -n '/#define SWOOLE_VERSION /{s/.* "//;s/".*$//;p}' include/swoole_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -339,6 +335,9 @@ cd ../ZTS
%changelog
+* Fri Nov 27 2020 Remi Collet <remi@remirepo.net> - 4.5.9-1
+- update to 4.5.9
+
* Mon Nov 23 2020 Remi Collet <remi@remirepo.net> - 4.5.8-2
- add upstream patch for PHP 8