summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-18 08:12:38 +0100
committerRemi Collet <remi@php.net>2021-12-18 08:12:38 +0100
commit1f09ce9976e9bdf473049d098d7811234420a8fe (patch)
treec3536302a22a10dda32560ddd3274207d9fe2b56
parentfcdf90969ed038bfd1a75dd6ce497d3cf85bfb19 (diff)
update to 4.8.4
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION64
-rw-r--r--php-pecl-swoole4.spec5
3 files changed, 48 insertions, 25 deletions
diff --git a/PHPINFO b/PHPINFO
index 45d91af..782a18e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.8.3
-Built => Dec 1 2021 00:00:00
+Version => 4.8.4
+Built => Dec 18 2021 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 1a39495..c090c66 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #86 swoole version 4.8.3 ] {
+Extension [ <persistent> extension #86 swoole version 4.8.4 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -29,11 +29,11 @@ Extension [ <persistent> extension #86 swoole version 4.8.3 ] {
}
- Constants [390] {
- Constant [ string SWOOLE_VERSION ] { 4.8.3 }
- Constant [ int SWOOLE_VERSION_ID ] { 40803 }
+ Constant [ string SWOOLE_VERSION ] { 4.8.4 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40804 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 8 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 3 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 4 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -2004,146 +2004,166 @@ Extension [ <persistent> extension #86 swoole version 4.8.3 ] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
- Parameter #0 [ <required> $table_size ]
- Parameter #1 [ <optional> $conflict_proportion = <default> ]
+ Parameter #0 [ <required> int $table_size ]
+ Parameter #1 [ <optional> float $conflict_proportion = 0.2 ]
}
}
Method [ <internal:swoole> public method column ] {
- Parameters [3] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $type ]
- Parameter #2 [ <optional> $size = <default> ]
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <required> int $type ]
+ Parameter #2 [ <optional> int $size = 0 ]
}
+ - Return [ bool ]
}
Method [ <internal:swoole> public method create ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
Method [ <internal:swoole> public method destroy ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
Method [ <internal:swoole> public method set ] {
- Parameters [2] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> string $key ]
Parameter #1 [ <required> array $value ]
}
+ - Return [ bool ]
}
Method [ <internal:swoole> public method get ] {
- Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $field = <default> ]
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <optional> ?string $field = null ]
}
+ - Return [ array|string|int|float|false ]
}
Method [ <internal:swoole, prototype Countable> public method count ] {
- Parameters [0] {
}
+ - Return [ int ]
}
Method [ <internal:swoole> public method del ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> string $key ]
}
+ - Return [ bool ]
}
Method [ <internal:swoole> public method delete ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> string $key ]
}
+ - Return [ bool ]
}
Method [ <internal:swoole> public method exists ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> string $key ]
}
+ - Return [ bool ]
}
Method [ <internal:swoole> public method exist ] {
- Parameters [1] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <required> string $key ]
}
+ - Return [ bool ]
}
Method [ <internal:swoole> public method incr ] {
- Parameters [3] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $column ]
- Parameter #2 [ <optional> $incrby = <default> ]
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <required> string $column ]
+ Parameter #2 [ <optional> int|float $incrby = 1 ]
}
+ - Return [ int|float ]
}
Method [ <internal:swoole> public method decr ] {
- Parameters [3] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $column ]
- Parameter #2 [ <optional> $decrby = <default> ]
+ Parameter #0 [ <required> string $key ]
+ Parameter #1 [ <required> string $column ]
+ Parameter #2 [ <optional> int|float $incrby = 1 ]
}
+ - Return [ int|float ]
}
Method [ <internal:swoole> public method getSize ] {
- Parameters [0] {
}
+ - Return [ int ]
}
Method [ <internal:swoole> public method getMemorySize ] {
- Parameters [0] {
}
+ - Return [ int ]
}
Method [ <internal:swoole> public method stats ] {
- Parameters [0] {
}
+ - Return [ array|false ]
}
Method [ <internal:swoole, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
+ - Return [ void ]
}
Method [ <internal:swoole, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
Method [ <internal:swoole, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Return [ void ]
}
Method [ <internal:swoole, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Return [ ?array ]
}
Method [ <internal:swoole, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Return [ ?string ]
}
}
}
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 04383ca..8b95d1c 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -26,7 +26,7 @@
%bcond_with brotli
%endif
-%global upstream_version 4.8.3
+%global upstream_version 4.8.4
#global upstream_prever RC2
@@ -320,6 +320,9 @@ cd ../ZTS
%changelog
+* Sat Dec 18 2021 Remi Collet <remi@remirepo.net> - 4.8.4-1
+- update to 4.8.4
+
* Wed Dec 1 2021 Remi Collet <remi@remirepo.net> - 4.8.3-1
- update to 4.8.3