summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-09 11:37:52 +0100
committerRemi Collet <remi@remirepo.net>2021-02-09 11:37:52 +0100
commit15601232d0b1265af88649191ea0432cc9c7b245 (patch)
tree90737b70c773327c5008491cf3122ddf318734f5
parentb8d61cab1722ea180cdacc4e14404253dd083ae4 (diff)
v4.6.2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION53
-rw-r--r--php-pecl-swoole4.spec5
3 files changed, 44 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index 72bc687..77323e0 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ swoole
Swoole => enabled
Author => Swoole Team <team@swoole.com>
-Version => 4.6.1
-Built => Jan 11 2021 00:00:00
+Version => 4.6.2
+Built => Jan 25 2021 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index beaae5d..faf0dc9 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 swoole version 4.6.1 ] {
+Extension [ <persistent> extension #119 swoole version 4.6.2 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -28,12 +28,12 @@ Extension [ <persistent> extension #119 swoole version 4.6.1 ] {
}
}
- - Constants [361] {
- Constant [ string SWOOLE_VERSION ] { 4.6.1 }
- Constant [ int SWOOLE_VERSION_ID ] { 40601 }
+ - Constants [362] {
+ Constant [ string SWOOLE_VERSION ] { 4.6.2 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40602 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 6 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 1 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 2 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -261,6 +261,7 @@ Extension [ <persistent> extension #119 swoole version 4.6.1 ] {
Constant [ int SWOOLE_HOOK_STREAM_FUNCTION ] { 128 }
Constant [ int SWOOLE_HOOK_STREAM_SELECT ] { 128 }
Constant [ int SWOOLE_HOOK_FILE ] { 256 }
+ Constant [ int SWOOLE_HOOK_STDIO ] { 32768 }
Constant [ int SWOOLE_HOOK_SLEEP ] { 512 }
Constant [ int SWOOLE_HOOK_PROC ] { 1024 }
Constant [ int SWOOLE_HOOK_CURL ] { 2048 }
@@ -3071,7 +3072,7 @@ Extension [ <persistent> extension #119 swoole version 4.6.1 ] {
Property [ <default> public $errMsg ]
}
- - Methods [28] {
+ - Methods [30] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -3133,6 +3134,30 @@ Extension [ <persistent> extension #119 swoole version 4.6.1 ] {
}
}
+ Method [ <internal:swoole> public method recvAll ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $length ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method recvLine ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $length ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method recvWithBuffer ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $length ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
Method [ <internal:swoole> public method recvPacket ] {
- Parameters [1] {
@@ -3189,14 +3214,6 @@ Extension [ <persistent> extension #119 swoole version 4.6.1 ] {
}
}
- Method [ <internal:swoole> public method recvAll ] {
-
- - Parameters [2] {
- Parameter #0 [ <optional> $length ]
- Parameter #1 [ <optional> $timeout ]
- }
- }
-
Method [ <internal:swoole> public method sendAll ] {
- Parameters [2] {
@@ -6545,7 +6562,7 @@ Extension [ <persistent> extension #119 swoole version 4.6.1 ] {
Property [ <default> public $tmpfiles ]
}
- - Methods [6] {
+ - Methods [7] {
Method [ <internal:swoole> public method rawContent ] {
- Parameters [0] {
@@ -6577,6 +6594,12 @@ Extension [ <persistent> extension #119 swoole version 4.6.1 ] {
}
}
+ Method [ <internal:swoole> public method getMethod ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole, dtor> public method __destruct ] {
- Parameters [0] {
diff --git a/php-pecl-swoole4.spec b/php-pecl-swoole4.spec
index 9d9c964..465a43f 100644
--- a/php-pecl-swoole4.spec
+++ b/php-pecl-swoole4.spec
@@ -27,7 +27,7 @@
%global with_brotli 0
%endif
-%global upstream_version 4.6.1
+%global upstream_version 4.6.2
#global upstream_prever RC2
@@ -320,6 +320,9 @@ cd ../ZTS
%changelog
+* Mon Jan 25 2021 Remi Collet <remi@remirepo.net> - 4.6.2-1
+- update to 4.6.2
+
* Mon Jan 11 2021 Remi Collet <remi@remirepo.net> - 4.6.1-1
- update to 4.6.1