summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--5945408fc74922a25a5d3c1500363ce474eb87dc.patch24
-rw-r--r--REFLECTION12
-rw-r--r--php-pecl-swoole2.spec16
3 files changed, 12 insertions, 40 deletions
diff --git a/5945408fc74922a25a5d3c1500363ce474eb87dc.patch b/5945408fc74922a25a5d3c1500363ce474eb87dc.patch
deleted file mode 100644
index 5721de6..0000000
--- a/5945408fc74922a25a5d3c1500363ce474eb87dc.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 5945408fc74922a25a5d3c1500363ce474eb87dc Mon Sep 17 00:00:00 2001
-From: matyhtf <mikan.tenny@gmail.com>
-Date: Thu, 28 Dec 2017 18:25:05 +0800
-Subject: [PATCH] fix #1433
-
----
- swoole.c | 4 ----
- 1 file changed, 4 deletions(-)
-
-diff --git a/swoole.c b/swoole.c
-index 2db93e145..c97ac829d 100644
---- a/swoole.c
-+++ b/swoole.c
-@@ -857,10 +857,6 @@ PHP_MINIT_FUNCTION(swoole)
- zend_declare_property_bool(swoole_server_class_entry_ptr, ZEND_STRL("taskworker"), 0, ZEND_ACC_PUBLIC TSRMLS_CC);
- zend_declare_property_long(swoole_server_class_entry_ptr, ZEND_STRL("worker_pid"), 0, ZEND_ACC_PUBLIC TSRMLS_CC);
-
--#ifdef HAVE_PCRE
-- zend_declare_property_null(swoole_server_class_entry_ptr, ZEND_STRL("connections"), ZEND_ACC_PUBLIC TSRMLS_CC);
--#endif
--
- SWOOLE_INIT_CLASS_ENTRY(swoole_timer_ce, "swoole_timer", "Swoole\\Timer", swoole_timer_methods);
- swoole_timer_class_entry_ptr = zend_register_internal_class(&swoole_timer_ce TSRMLS_CC);
- SWOOLE_CLASS_ALIAS(swoole_timer, "Swoole\\Timer");
diff --git a/REFLECTION b/REFLECTION
index 892ef30..0eca469 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
+Extension [ <persistent> extension #143 swoole version 2.0.12 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 2.0.11 }
+ Constant [ string SWOOLE_VERSION ] { 2.0.12 }
Constant [ integer SWOOLE_REDIS_MODE_MULTI ] { 0 }
Constant [ integer SWOOLE_REDIS_MODE_PIPELINE ] { 1 }
Constant [ integer SWOOLE_REDIS_TYPE_NOT_FOUND ] { 0 }
@@ -318,6 +318,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
Property [ <default> public $onManagerStop ]
Property [ <default> public $onPipeMessage ]
Property [ <default> public $setting ]
+ Property [ <default> public $connections ]
Property [ <default> public $host ]
Property [ <default> public $port ]
Property [ <default> public $type ]
@@ -328,7 +329,6 @@ Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
- Property [ <default> public $connections ]
}
- Methods [42] {
@@ -3058,6 +3058,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
Property [ <default> public $onManagerStart ]
Property [ <default> public $onManagerStop ]
Property [ <default> public $onPipeMessage ]
+ Property [ <default> public $connections ]
Property [ <default> public $host ]
Property [ <default> public $port ]
Property [ <default> public $type ]
@@ -3068,7 +3069,6 @@ Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
- Property [ <default> public $connections ]
Property [ <default> public $onRequest ]
Property [ <default> public $onHandshake ]
Property [ <default> public $setting ]
@@ -3693,6 +3693,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
Property [ <default> public $onManagerStart ]
Property [ <default> public $onManagerStop ]
Property [ <default> public $onPipeMessage ]
+ Property [ <default> public $connections ]
Property [ <default> public $host ]
Property [ <default> public $port ]
Property [ <default> public $type ]
@@ -3703,7 +3704,6 @@ Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
- Property [ <default> public $connections ]
Property [ <default> public $onRequest ]
Property [ <default> public $onHandshake ]
Property [ <default> public $setting ]
@@ -4692,6 +4692,7 @@ Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
Property [ <default> public $onManagerStop ]
Property [ <default> public $onPipeMessage ]
Property [ <default> public $setting ]
+ Property [ <default> public $connections ]
Property [ <default> public $host ]
Property [ <default> public $port ]
Property [ <default> public $type ]
@@ -4702,7 +4703,6 @@ Extension [ <persistent> extension #143 swoole version 2.0.11 ] {
Property [ <default> public $worker_id ]
Property [ <default> public $taskworker ]
Property [ <default> public $worker_pid ]
- Property [ <default> public $connections ]
}
- Methods [43] {
diff --git a/php-pecl-swoole2.spec b/php-pecl-swoole2.spec
index 3e747a0..730add3 100644
--- a/php-pecl-swoole2.spec
+++ b/php-pecl-swoole2.spec
@@ -30,16 +30,14 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}2
-Version: 2.0.11
+Version: 2.0.12
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://github.com/swoole/swoole-src/commit/5945408fc74922a25a5d3c1500363ce474eb87dc.patch
-
-BuildRequires: %{?scl_prefix}php-devel >= 5.5
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
BuildRequires: %{?scl_prefix}php-mysqlnd
@@ -79,14 +77,10 @@ Obsoletes: php54-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php54w-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php55u-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php55w-pecl-%{pecl_name}2 <= %{version}
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php56w-pecl-%{pecl_name}2 <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
Obsoletes: php70u-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php70w-pecl-%{pecl_name}2 <= %{version}
-%endif
%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php71w-pecl-%{pecl_name}2 <= %{version}
@@ -153,8 +147,6 @@ sed -e '/examples/s/role="src"/role="doc"/' \
cd NTS
-%patch0 -p1 -b .upstream
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -311,6 +303,10 @@ cd ../ZTS
%changelog
+* Fri Dec 29 2017 Remi Collet <remi@remirepo.net> - 2.0.12-1
+- Update to 2.0.12 (stable)
+- drop PHP 5 support
+
* Thu Dec 28 2017 Remi Collet <remi@remirepo.net> - 2.0.11-1
- Update to 2.0.11 (stable)
- add upstream patch to fix broken build with PHP 5.x