summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-23 13:41:49 +0200
committerRemi Collet <remi@remirepo.net>2018-05-23 13:41:49 +0200
commitcc4a1178b37d663d4bfeb059c3342133fbd3f5eb (patch)
treee1ead91e39095f0be8744beb6e17760c46bb5e6f
parentdb121cf3cdeae9e115058d1ae98bf3294f88072f (diff)
-rw-r--r--REFLECTION233
-rw-r--r--php-pecl-swoole2.spec5
2 files changed, 224 insertions, 14 deletions
diff --git a/REFLECTION b/REFLECTION
index aa35948..8fa194d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
+Extension [ <persistent> extension #147 swoole version 2.2.0 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -66,7 +66,7 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 2.1.3 }
+ Constant [ string SWOOLE_VERSION ] { 2.2.0 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -410,7 +410,7 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
}
}
- - Classes [44] {
+ - Classes [46] {
Class [ <internal:swoole> class Swoole\Server ] {
- Constants [0] {
@@ -782,18 +782,18 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
- Static methods [4] {
Method [ <internal:swoole> static public method tick ] {
- - Parameters [3] {
+ - Parameters [2] {
Parameter #0 [ <required> $ms ]
Parameter #1 [ <required> $callback ]
- Parameter #2 [ <optional> $param ]
}
}
Method [ <internal:swoole> static public method after ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $ms ]
Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $param ]
}
}
@@ -1399,6 +1399,177 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
}
}
+ Class [ <internal:swoole> final class Swoole\Coroutine\Socket ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> public $errCode ]
+ }
+
+ - Methods [13] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $domain ]
+ Parameter #1 [ <required> $type ]
+ Parameter #2 [ <required> $protocol ]
+ }
+ }
+
+ Method [ <internal:swoole> public method bind ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $address ]
+ Parameter #1 [ <optional> $port ]
+ }
+ }
+
+ Method [ <internal:swoole> public method listen ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $backlog ]
+ }
+ }
+
+ Method [ <internal:swoole> public method accept ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method connect ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <optional> $port ]
+ Parameter #2 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method recv ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method send ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method recvfrom ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> &$peername ]
+ Parameter #1 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:swoole> public method sendto ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $addr ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:swoole> public method getpeername ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method getsockname ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method getSocket ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method close ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:swoole> class Swoole\Coroutine\Socket\Exception extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:swoole> class Swoole\Coroutine\Client ] {
- Constants [4] {
@@ -2524,7 +2695,7 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
Method [ <internal:swoole> public method execute ] {
- Parameters [2] {
- Parameter #0 [ <required> $params ]
+ Parameter #0 [ <optional> $params ]
Parameter #1 [ <optional> $timeout ]
}
}
@@ -2631,7 +2802,7 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
Property [ <default> public $body ]
}
- - Methods [20] {
+ - Methods [21] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -2704,6 +2875,15 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
}
}
+ Method [ <internal:swoole> public method download ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $path ]
+ Parameter #1 [ <required> $file ]
+ Parameter #2 [ <optional> $offset ]
+ }
+ }
+
Method [ <internal:swoole> public method upgrade ] {
- Parameters [1] {
@@ -2738,7 +2918,7 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
Method [ <internal:swoole> public method setDefer ] {
- Parameters [1] {
- Parameter #0 [ <required> $defer ]
+ Parameter #0 [ <optional> $defer ]
}
}
@@ -3576,10 +3756,11 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [1] {
+ Property [ <default> public $errCode ]
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
@@ -3630,6 +3811,12 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:swoole> public method destroy ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -4147,7 +4334,13 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:swoole> static public method create ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
}
- Properties [4] {
@@ -4157,7 +4350,7 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
Property [ <default> public $trailer ]
}
- - Methods [13] {
+ - Methods [15] {
Method [ <internal:swoole> public method initHeader ] {
- Parameters [0] {
@@ -4245,6 +4438,20 @@ Extension [ <persistent> extension #147 swoole version 2.1.3 ] {
}
}
+ Method [ <internal:swoole> public method redirect ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $location ]
+ Parameter #1 [ <optional> $http_code ]
+ }
+ }
+
+ Method [ <internal:swoole> public method detach ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method __sleep ] {
}
diff --git a/php-pecl-swoole2.spec b/php-pecl-swoole2.spec
index 6d3c802..e132e14 100644
--- a/php-pecl-swoole2.spec
+++ b/php-pecl-swoole2.spec
@@ -41,7 +41,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}2
-Version: 2.1.3
+Version: 2.2.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
@@ -315,6 +315,9 @@ cd ../ZTS
%changelog
+* Wed May 23 2018 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+
* Mon Apr 16 2018 Remi Collet <remi@remirepo.net> - 2.1.3-1
- update to 2.1.3