summaryrefslogtreecommitdiffstats
path: root/php-pecl-swoole.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-swoole.spec')
-rw-r--r--php-pecl-swoole.spec33
1 files changed, 22 insertions, 11 deletions
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index c5215cf..9ee0aaf 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -13,11 +13,18 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name swoole
+%if "%{php_version}" < "5.6"
+# After sockets
+%global ini_name %{pecl_name}.ini
+%else
+# After 20-ockets
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.6.11
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.6.12
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -48,11 +55,9 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
-%if "%{php_version}" > "5.4"
Obsoletes: php53-pecl-%{pecl_name}
Obsoletes: php53u-pecl-%{pecl_name}
Obsoletes: php54-pecl-%{pecl_name}
-%endif
%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name}
%endif
@@ -71,8 +76,9 @@ Obsoletes: php56u-pecl-%{pecl_name}
%description
PHP's asynchronous concurrent distributed networking framework.
- Event-driven
-- Full asynchronous non-blocking
-- Multi-Thread or Multi-Process
+- Asynchronous non-blocking
+- Multi-Thread reactor
+- Multi-Process worker
- Millisecond timer
- Asynchronous MySQL
- AsyncTask workers
@@ -82,6 +88,8 @@ PHP's asynchronous concurrent distributed networking framework.
%setup -q -c
mv %{pecl_name}-%{version} NTS
+sed -e '/examples/s/role="src"/role="doc"/' -i package.xml
+
cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
@@ -97,7 +105,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat << 'EOF' | tee %{pecl_name}.ini
+cat << 'EOF' | tee %{ini_name}
; Enable %{summary} extension module
extension=%{pecl_name}.so
EOF
@@ -137,7 +145,7 @@ make -C NTS \
install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -146,7 +154,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
make -C ZTS \
install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -193,16 +201,19 @@ rm -rf %{buildroot}
%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Sun Apr 13 2014 Remi Collet <remi@fedoraproject.org> - 1.6.12-1
+- Update to 1.6.12
+
* Fri Feb 28 2014 Remi Collet <remi@fedoraproject.org> - 1.6.11-2
- no --enable-async-mysql with php 5.3