summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION78
-rw-r--r--php-pecl-swoole.spec5
2 files changed, 74 insertions, 9 deletions
diff --git a/REFLECTION b/REFLECTION
index 173c978..9bc9277 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
+Extension [ <persistent> extension #158 swoole version 1.7.19 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -42,7 +42,7 @@ Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
Constant [ integer SWOOLE_KEEP ] { 512 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.18 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.19 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -283,7 +283,7 @@ Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
}
}
- - Classes [12] {
+ - Classes [13] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -298,7 +298,7 @@ Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
- Properties [0] {
}
- - Methods [31] {
+ - Methods [32] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -403,6 +403,15 @@ Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
}
}
+ Method [ <internal:swoole> public method listen ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
Method [ <internal:swoole> public method reload ] {
- Parameters [0] {
@@ -869,6 +878,41 @@ Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
}
}
+ Class [ <internal:swoole> class swoole_atomic ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:swoole> public method add ] {
+ }
+
+ Method [ <internal:swoole> public method sub ] {
+ }
+
+ Method [ <internal:swoole> public method get ] {
+ }
+
+ Method [ <internal:swoole> public method set ] {
+ }
+
+ Method [ <internal:swoole> public method cmpset ] {
+ }
+ }
+ }
+
Class [ <internal:swoole> class swoole_http_server extends swoole_server ] {
- Constants [0] {
@@ -884,7 +928,7 @@ Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
Property [ <default> private $global ]
}
- - Methods [32] {
+ - Methods [33] {
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -997,6 +1041,15 @@ Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method listen ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method reload ] {
- Parameters [0] {
@@ -1174,10 +1227,10 @@ Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
Method [ <internal:swoole> public method substr ] {
}
- Method [ <internal:swoole> public method read ] {
+ Method [ <internal:swoole> public method write ] {
}
- Method [ <internal:swoole> public method write ] {
+ Method [ <internal:swoole> public method read ] {
}
Method [ <internal:swoole> public method append ] {
@@ -1205,7 +1258,7 @@ Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
- Properties [0] {
}
- - Methods [33] {
+ - Methods [34] {
Method [ <internal:swoole, overwrites swoole_http_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -1328,6 +1381,15 @@ Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method listen ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method reload ] {
- Parameters [0] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 996d693..cb80367 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -23,7 +23,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.18
+Version: 1.7.19
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -245,6 +245,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Aug 31 2015 Remi Collet <remi@fedoraproject.org> - 1.7.19-1
+- Update to 1.7.19
+
* Thu Jul 23 2015 Remi Collet <remi@fedoraproject.org> - 1.7.18-1
- Update to 1.7.18