summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION43
-rw-r--r--php-pecl-swoole.spec5
2 files changed, 27 insertions, 21 deletions
diff --git a/REFLECTION b/REFLECTION
index 6f4b313..69b3696 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #147 swoole version 1.7.10 ] {
+Extension [ <persistent> extension #147 swoole version 1.7.11 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -48,7 +48,7 @@ Extension [ <persistent> extension #147 swoole version 1.7.10 ] {
Constant [ integer SWOOLE_SSL ] { 512 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.10 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.11 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -732,57 +732,57 @@ Extension [ <persistent> extension #147 swoole version 1.7.10 ] {
}
}
- Method [ <internal:swoole, prototype Iterator> public method rewind ] {
+ Method [ <internal:swoole, prototype Countable> public method count ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $mode ]
}
}
- Method [ <internal:swoole, prototype Iterator> public method next ] {
+ Method [ <internal:swoole> public method del ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
}
- Method [ <internal:swoole, prototype Iterator> public method current ] {
+ Method [ <internal:swoole> public method lock ] {
- Parameters [0] {
}
}
- Method [ <internal:swoole, prototype Iterator> public method key ] {
+ Method [ <internal:swoole> public method unlock ] {
- Parameters [0] {
}
}
- Method [ <internal:swoole, prototype Iterator> public method valid ] {
+ Method [ <internal:swoole, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
}
- Method [ <internal:swoole, prototype Countable> public method count ] {
+ Method [ <internal:swoole, prototype Iterator> public method next ] {
- - Parameters [1] {
- Parameter #0 [ <optional> $mode ]
+ - Parameters [0] {
}
}
- Method [ <internal:swoole> public method del ] {
+ Method [ <internal:swoole, prototype Iterator> public method current ] {
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
+ - Parameters [0] {
}
}
- Method [ <internal:swoole> public method lock ] {
+ Method [ <internal:swoole, prototype Iterator> public method key ] {
- Parameters [0] {
}
}
- Method [ <internal:swoole> public method unlock ] {
+ Method [ <internal:swoole, prototype Iterator> public method valid ] {
- Parameters [0] {
}
@@ -814,7 +814,7 @@ Extension [ <persistent> extension #147 swoole version 1.7.10 ] {
}
}
- Method [ <internal:swoole> public method setGlobal ] {
+ Method [ <internal:swoole> public method setglobal ] {
}
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method start ] {
@@ -1009,7 +1009,7 @@ Extension [ <persistent> extension #147 swoole version 1.7.10 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [6] {
Method [ <internal:swoole> public method cookie ] {
}
@@ -1022,6 +1022,9 @@ Extension [ <persistent> extension #147 swoole version 1.7.10 ] {
Method [ <internal:swoole> public method header ] {
}
+ Method [ <internal:swoole> public method write ] {
+ }
+
Method [ <internal:swoole> public method end ] {
}
}
@@ -1073,7 +1076,7 @@ Extension [ <persistent> extension #147 swoole version 1.7.10 ] {
Method [ <internal:swoole> public method push ] {
}
- Method [ <internal:swoole, inherits swoole_http_server> public method setGlobal ] {
+ Method [ <internal:swoole, inherits swoole_http_server> public method setglobal ] {
}
Method [ <internal:swoole, inherits swoole_http_server, prototype swoole_server> public method start ] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 6aa5f28..d984200 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -23,7 +23,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.10
+Version: 1.7.11
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
@@ -240,6 +240,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Mar 10 2015 Remi Collet <remi@fedoraproject.org> - 1.7.11-1
+- Update to 1.7.11
+
* Sun Feb 15 2015 Remi Collet <remi@fedoraproject.org> - 1.7.10-1
- Update to 1.7.10
- drop runtime dependency on pear, new scriptlets