summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--134.patch22
-rw-r--r--REFLECTION48
-rw-r--r--php-pecl-swoole.spec10
3 files changed, 46 insertions, 34 deletions
diff --git a/134.patch b/134.patch
deleted file mode 100644
index b902a73..0000000
--- a/134.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 1e86632064d5e149356d39077ee8da97164424f0 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Tue, 28 Oct 2014 13:27:08 +0100
-Subject: [PATCH] fix class registration
-
----
- swoole_http.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/swoole_http.c b/swoole_http.c
-index 11a0d69..0ad632c 100644
---- a/swoole_http.c
-+++ b/swoole_http.c
-@@ -382,7 +382,7 @@ void swoole_http_init(int module_number TSRMLS_DC)
- INIT_CLASS_ENTRY(swoole_http_response_ce, "swoole_http_response", swoole_http_response_methods);
- swoole_http_response_class_entry_ptr = zend_register_internal_class(&swoole_http_response_ce TSRMLS_CC);
-
-- INIT_CLASS_ENTRY(swoole_http_response_ce, "swoole_http_request", NULL);
-+ INIT_CLASS_ENTRY(swoole_http_request_ce, "swoole_http_request", NULL);
- swoole_http_request_class_entry_ptr = zend_register_internal_class(&swoole_http_request_ce TSRMLS_CC);
- }
-
diff --git a/REFLECTION b/REFLECTION
index 55afe68..a84af72 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,9 +1,12 @@
-Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
+Extension [ <persistent> extension #147 swoole version 1.7.8 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
Current = '2'
}
+ Entry [ swoole.display_errors <ALL> ]
+ Current = '2'
+ }
Entry [ swoole.message_queue_key <ALL> ]
Current = '0'
}
@@ -12,7 +15,7 @@ Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
}
}
- - Constants [33] {
+ - Constants [35] {
Constant [ integer SWOOLE_BASE ] { 4 }
Constant [ integer SWOOLE_THREAD ] { 2 }
Constant [ integer SWOOLE_PROCESS ] { 3 }
@@ -23,6 +26,8 @@ Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
Constant [ integer SWOOLE_SOCK_TCP6 ] { 3 }
Constant [ integer SWOOLE_SOCK_UDP ] { 2 }
Constant [ integer SWOOLE_SOCK_UDP6 ] { 4 }
+ Constant [ integer SWOOLE_SOCK_UNIX_DGRAM ] { 5 }
+ Constant [ integer SWOOLE_SOCK_UNIX_STREAM ] { 6 }
Constant [ integer SWOOLE_TCP ] { 1 }
Constant [ integer SWOOLE_TCP6 ] { 3 }
Constant [ integer SWOOLE_UDP ] { 2 }
@@ -42,7 +47,7 @@ Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
Constant [ integer SWOOLE_SSL ] { 512 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.7 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.8 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -183,6 +188,14 @@ Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
Parameter #1 [ <required> $from_id ]
}
}
+ Function [ <internal:swoole> function swoole_bind_uid ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> swoole_server $zobject ]
+ Parameter #1 [ <required> $fd ]
+ Parameter #2 [ <optional> $uid ]
+ }
+ }
Function [ <internal:swoole> function swoole_connection_info ] {
- Parameters [3] {
@@ -280,7 +293,7 @@ Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
- Properties [0] {
}
- - Methods [23] {
+ - Methods [24] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -420,6 +433,14 @@ Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
}
}
+ Method [ <internal:swoole> public method bind_uid ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $uid ]
+ }
+ }
+
Method [ <internal:swoole> public method connection_info ] {
- Parameters [2] {
@@ -746,7 +767,7 @@ Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
- Properties [0] {
}
- - Methods [23] {
+ - Methods [24] {
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -883,6 +904,14 @@ Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method bind_uid ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $uid ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method connection_info ] {
- Parameters [2] {
@@ -921,10 +950,13 @@ Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [6] {
Method [ <internal:swoole> public method cookie ] {
}
+ Method [ <internal:swoole> public method rawcookie ] {
+ }
+
Method [ <internal:swoole> public method status ] {
}
@@ -953,7 +985,9 @@ Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
- Properties [0] {
}
- - Methods [0] {
+ - Methods [1] {
+ Method [ <internal:swoole> public method rawcontent ] {
+ }
}
}
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 2c5ce1a..d72f579 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -23,16 +23,13 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.7
+Version: 1.7.8
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://github.com/swoole/swoole-src/pull/134
-Patch0: 134.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -105,7 +102,6 @@ mv %{pecl_name}-%{version} NTS
sed -e '/examples/s/role="src"/role="doc"/' -i package.xml
cd NTS
-%patch0 -p1 -b .pr134
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
@@ -127,6 +123,7 @@ extension=%{pecl_name}.so
; Configuration
;swoole.aio_thread_num = 2
+;swoole.display_errors = 2
;swoole.message_queue_key = 0
;swoole.unixsock_buffer_size = 8388608
EOF
@@ -234,6 +231,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Nov 26 2014 Remi Collet <remi@fedoraproject.org> - 1.7.8-1
+- Update to 1.7.8 (stable)
+
* Tue Oct 28 2014 Remi Collet <remi@fedoraproject.org> - 1.7.7-1
- Update to 1.7.7 (stable)