summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION13
-rw-r--r--php-pecl-swoole.spec9
2 files changed, 16 insertions, 6 deletions
diff --git a/REFLECTION b/REFLECTION
index 27085ba..0687547 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 swoole version 1.7.16 ] {
+Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -42,7 +42,7 @@ Extension [ <persistent> extension #153 swoole version 1.7.16 ] {
Constant [ integer SWOOLE_KEEP ] { 512 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.16 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.17 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -698,7 +698,7 @@ Extension [ <persistent> extension #153 swoole version 1.7.16 ] {
- Properties [0] {
}
- - Methods [17] {
+ - Methods [18] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -752,6 +752,13 @@ Extension [ <persistent> extension #153 swoole version 1.7.16 ] {
}
}
+ Method [ <internal:swoole> public method exist ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
Method [ <internal:swoole> public method incr ] {
- Parameters [3] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index bb6aeda..ce1f6b3 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -1,4 +1,4 @@
-# spec file for php-pecl-swoole
+# remirepo spec file for php-pecl-swoole
#
# Copyright (c) 2013-2015 Remi Collet
# License: CC-BY-SA
@@ -23,7 +23,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.16
+Version: 1.7.17
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
@@ -31,7 +31,7 @@ URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel >= 5.3.10
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
BuildRequires: %{?scl_prefix}php-mysqli
@@ -245,6 +245,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Jun 01 2015 Remi Collet <remi@fedoraproject.org> - 1.7.17-1
+- Update to 1.7.17
+
* Fri May 08 2015 Remi Collet <remi@fedoraproject.org> - 1.7.16-1
- Update to 1.7.16