summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION41
-rw-r--r--php-pecl-swoole.spec11
2 files changed, 31 insertions, 21 deletions
diff --git a/REFLECTION b/REFLECTION
index 131e159..cdae2c0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #70 swoole version 1.10.4 ] {
+Extension [ <persistent> extension #70 swoole version 1.10.5 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #70 swoole version 1.10.4 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.10.4 }
+ Constant [ string SWOOLE_VERSION ] { 1.10.5 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -646,8 +646,8 @@ Extension [ <persistent> extension #70 swoole version 1.10.4 ] {
Method [ <internal:swoole> public method sendMessage ] {
- Parameters [2] {
- Parameter #0 [ <required> $dst_worker_id ]
- Parameter #1 [ <required> $data ]
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <required> $dst_worker_id ]
}
}
@@ -698,18 +698,18 @@ Extension [ <persistent> extension #70 swoole version 1.10.4 ] {
- Static methods [4] {
Method [ <internal:swoole> static public method tick ] {
- - Parameters [3] {
+ - Parameters [2] {
Parameter #0 [ <required> $ms ]
Parameter #1 [ <required> $callback ]
- Parameter #2 [ <optional> $param ]
}
}
Method [ <internal:swoole> static public method after ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $ms ]
Parameter #1 [ <required> $callback ]
+ Parameter #2 [ <optional> $param ]
}
}
@@ -1905,10 +1905,11 @@ Extension [ <persistent> extension #70 swoole version 1.10.4 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [1] {
+ Property [ <default> public $errCode ]
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
@@ -1959,6 +1960,12 @@ Extension [ <persistent> extension #70 swoole version 1.10.4 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:swoole> public method destroy ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -2425,8 +2432,8 @@ Extension [ <persistent> extension #70 swoole version 1.10.4 ] {
Method [ <internal:swoole, inherits swoole_server> public method sendMessage ] {
- Parameters [2] {
- Parameter #0 [ <required> $dst_worker_id ]
- Parameter #1 [ <required> $data ]
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <required> $dst_worker_id ]
}
}
@@ -3075,8 +3082,8 @@ Extension [ <persistent> extension #70 swoole version 1.10.4 ] {
Method [ <internal:swoole, inherits swoole_server> public method sendMessage ] {
- Parameters [2] {
- Parameter #0 [ <required> $dst_worker_id ]
- Parameter #1 [ <required> $data ]
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <required> $dst_worker_id ]
}
}
@@ -3135,8 +3142,8 @@ Extension [ <persistent> extension #70 swoole version 1.10.4 ] {
Constant [ public integer STATE_READ_START ] { 1 }
Constant [ public integer STATE_READ_FIELD ] { 2 }
Constant [ public integer STATE_READ_ROW ] { 3 }
- Constant [ public integer STATE_READ_END ] { 4 }
- Constant [ public integer STATE_CLOSED ] { 5 }
+ Constant [ public integer STATE_READ_END ] { 5 }
+ Constant [ public integer STATE_CLOSED ] { 6 }
}
- Static properties [0] {
@@ -4067,8 +4074,8 @@ Extension [ <persistent> extension #70 swoole version 1.10.4 ] {
Method [ <internal:swoole, inherits swoole_server> public method sendMessage ] {
- Parameters [2] {
- Parameter #0 [ <required> $dst_worker_id ]
- Parameter #1 [ <required> $data ]
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <required> $dst_worker_id ]
}
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index f9c56c9..421fe48 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-swoole
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -36,11 +36,11 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.10.4
+Version: 1.10.5
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -308,6 +308,9 @@ cd ../ZTS
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 1.10.5-1
+- update to 1.10.5
+
* Thu Apr 12 2018 Remi Collet <remi@remirepo.net> - 1.10.4-1
- update to 1.10.4