summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-01 07:24:30 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-01 07:24:30 +0100
commitfff1074e385196c42e6b3e2e80189453ec7efa7a (patch)
treee70260c3a68cb49900a33a13a8bc34ec1daef63b
parenta7c3cdafd49b3241fd26eed95750fa681f6adb38 (diff)
php-pecl-swoole: 1.7.21
-rw-r--r--REFLECTION35
-rw-r--r--php-pecl-swoole.spec7
2 files changed, 33 insertions, 9 deletions
diff --git a/REFLECTION b/REFLECTION
index f80167d..38f10f4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
+Extension [ <persistent> extension #160 swoole version 1.7.21 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -42,7 +42,7 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
Constant [ integer SWOOLE_KEEP ] { 4096 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.20 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.21 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -298,7 +298,7 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
- Properties [0] {
}
- - Methods [34] {
+ - Methods [35] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -521,6 +521,9 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
Method [ <internal:swoole> public method stats ] {
}
+ Method [ <internal:swoole> public method getSocket ] {
+ }
+
Method [ <internal:swoole> public method bind ] {
- Parameters [2] {
@@ -600,7 +603,7 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
Property [ <default> public $sock ]
}
- - Methods [13] {
+ - Methods [16] {
Method [ <internal:swoole, ctor> public method __construct ] {
}
@@ -625,6 +628,12 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
Method [ <internal:swoole> public method sendto ] {
}
+ Method [ <internal:swoole> public method sleep ] {
+ }
+
+ Method [ <internal:swoole> public method wakeup ] {
+ }
+
Method [ <internal:swoole> public method isConnected ] {
}
@@ -639,6 +648,9 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
Method [ <internal:swoole> public method on ] {
}
+
+ Method [ <internal:swoole> public method getSocket ] {
+ }
}
}
@@ -934,7 +946,7 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
Property [ <default> private $global ]
}
- - Methods [35] {
+ - Methods [36] {
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -1157,6 +1169,9 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
Method [ <internal:swoole, inherits swoole_server> public method stats ] {
}
+ Method [ <internal:swoole, inherits swoole_server> public method getSocket ] {
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method bind ] {
- Parameters [2] {
@@ -1181,7 +1196,7 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [8] {
Method [ <internal:swoole> public method cookie ] {
}
@@ -1202,6 +1217,9 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
Method [ <internal:swoole> public method end ] {
}
+
+ Method [ <internal:swoole> public method sendfile ] {
+ }
}
}
@@ -1280,7 +1298,7 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
- Properties [0] {
}
- - Methods [36] {
+ - Methods [37] {
Method [ <internal:swoole, overwrites swoole_http_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -1513,6 +1531,9 @@ Extension [ <persistent> extension #160 swoole version 1.7.20 ] {
Method [ <internal:swoole, inherits swoole_server> public method stats ] {
}
+ Method [ <internal:swoole, inherits swoole_server> public method getSocket ] {
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method bind ] {
- Parameters [2] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index a0ab87c..c6bf5c2 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -19,7 +19,7 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name swoole
%if "%{php_version}" < "5.6"
# After sockets
@@ -31,7 +31,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.7.20
+Version: 1.7.21
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -253,6 +253,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Dec 01 2015 Remi Collet <remi@fedoraproject.org> - 1.7.21-1
+- Update to 1.7.21
+
* Wed Oct 21 2015 Remi Collet <remi@fedoraproject.org> - 1.7.20-1
- Update to 1.7.20