summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-16 09:15:43 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-16 09:15:43 +0100
commitd7cc019ab74b78db1d23a75cf0977a1a6f969478 (patch)
tree627e3331b139db80dbd90b0a6cf117dda894b7e9
parent44cb0857fdadb198d1af67229518b73931611280 (diff)
php-pecl-swoole: 1.9.8
-rw-r--r--REFLECTION218
-rw-r--r--php-pecl-swoole.spec12
2 files changed, 220 insertions, 10 deletions
diff --git a/REFLECTION b/REFLECTION
index 4ed19fb..828b3db 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #80 swoole version 1.9.6 ] {
+Extension [ <persistent> extension #80 swoole version 1.9.8 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.6 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.9.6 }
+ Constant [ string SWOOLE_VERSION ] { 1.9.8 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -262,7 +262,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.6 ] {
}
}
- - Classes [27] {
+ - Classes [29] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -2789,6 +2789,218 @@ Extension [ <persistent> extension #80 swoole version 1.9.6 ] {
}
}
+ Class [ <internal:swoole> class swoole_http2_client extends swoole_client ] {
+
+ - Constants [4] {
+ Constant [ integer MSG_OOB ] { 1 }
+ Constant [ integer MSG_PEEK ] { 2 }
+ Constant [ integer MSG_DONTWAIT ] { 64 }
+ Constant [ integer MSG_WAITALL ] { 256 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> public $errCode ]
+ Property [ <default> public $sock ]
+ Property [ <default> public $reuse ]
+ Property [ <default> public $reuseCount ]
+ }
+
+ - Methods [30] {
+ Method [ <internal:swoole, overwrites swoole_client, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:swoole, overwrites swoole_client, prototype swoole_client, dtor> public method __destruct ] {
+ }
+
+ Method [ <internal:swoole> public method setHeaders ] {
+ }
+
+ Method [ <internal:swoole> public method setCookies ] {
+ }
+
+ Method [ <internal:swoole> public method get ] {
+ }
+
+ Method [ <internal:swoole> public method post ] {
+ }
+
+ Method [ <internal:swoole> public method onConnect ] {
+ }
+
+ Method [ <internal:swoole> public method onError ] {
+ }
+
+ Method [ <internal:swoole> public method onReceive ] {
+ }
+
+ Method [ <internal:swoole> public method onClose ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method set ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $settings ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method connect ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <optional> $port ]
+ Parameter #2 [ <optional> $timeout ]
+ Parameter #3 [ <optional> $sock_flag ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method recv ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $size ]
+ Parameter #1 [ <optional> $flag ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method send ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $flag ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method pipe ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $dst_socket ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method sendfile ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <optional> $offset ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method sendto ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $ip ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method sleep ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method wakeup ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method pause ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method resume ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method enableSSL ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method getPeerCert ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method verifyPeerCert ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method isConnected ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method getsockname ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method getpeername ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method close ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $force ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method on ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $event_name ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_client> public method getSocket ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:swoole> class swoole_http2_response ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
Class [ <internal:swoole> class swoole_serialize ] {
- Constants [0] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 6116ec0..7dc9566 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -37,16 +37,13 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.9.7
+Version: 1.9.8
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-pr1148.patch
-Patch1: 9aade9eafcd0d5be04366ed7b0f42e0dd0694082.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 5.3.10
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
@@ -144,9 +141,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
-%patch0 -p1 -b .pr1148
-%patch1 -p1 -b .upstream
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -291,6 +285,10 @@ cd ../ZTS
%changelog
+* Thu Mar 16 2017 Remi Collet <remi@remirepo.net> - 1.9.8-1
+- Update to 1.9.8
+- drop patch merged upstream
+
* Thu Mar 16 2017 Remi Collet <remi@remirepo.net> - 1.9.7-1
- Update to 1.9.7
- open https://github.com/swoole/swoole-src/issues/1147