summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-10-28 13:53:40 +0100
committerRemi Collet <fedora@famillecollet.com>2014-10-28 13:53:40 +0100
commitc4c385efb1ff72ba131108f18555fa7d89a72e69 (patch)
treea732f04ef9d5e4d0c563897073b36f0828949098
parent29c9a2b660a91942dfa97239fbafd198e31314d4 (diff)
php-pecl-swoole: 1.7.7
-rw-r--r--134.patch22
-rw-r--r--REFLECTION238
-rw-r--r--php-pecl-swoole.spec13
3 files changed, 266 insertions, 7 deletions
diff --git a/134.patch b/134.patch
new file mode 100644
index 0000000..b902a73
--- /dev/null
+++ b/134.patch
@@ -0,0 +1,22 @@
+From 1e86632064d5e149356d39077ee8da97164424f0 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Tue, 28 Oct 2014 13:27:08 +0100
+Subject: [PATCH] fix class registration
+
+---
+ swoole_http.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/swoole_http.c b/swoole_http.c
+index 11a0d69..0ad632c 100644
+--- a/swoole_http.c
++++ b/swoole_http.c
+@@ -382,7 +382,7 @@ void swoole_http_init(int module_number TSRMLS_DC)
+ INIT_CLASS_ENTRY(swoole_http_response_ce, "swoole_http_response", swoole_http_response_methods);
+ swoole_http_response_class_entry_ptr = zend_register_internal_class(&swoole_http_response_ce TSRMLS_CC);
+
+- INIT_CLASS_ENTRY(swoole_http_response_ce, "swoole_http_request", NULL);
++ INIT_CLASS_ENTRY(swoole_http_request_ce, "swoole_http_request", NULL);
+ swoole_http_request_class_entry_ptr = zend_register_internal_class(&swoole_http_request_ce TSRMLS_CC);
+ }
+
diff --git a/REFLECTION b/REFLECTION
index 14f7b7d..55afe68 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #144 swoole version 1.7.6 ] {
+Extension [ <persistent> extension #145 swoole version 1.7.7 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -42,7 +42,7 @@ Extension [ <persistent> extension #144 swoole version 1.7.6 ] {
Constant [ integer SWOOLE_SSL ] { 512 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.6 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.7 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -237,6 +237,8 @@ Extension [ <persistent> extension #144 swoole version 1.7.6 ] {
Parameter #0 [ <required> $interval ]
}
}
+ Function [ <internal:swoole> function swoole_timer_after ] {
+ }
Function [ <internal:swoole> function swoole_async_set ] {
}
Function [ <internal:swoole> function swoole_async_read ] {
@@ -263,7 +265,7 @@ Extension [ <persistent> extension #144 swoole version 1.7.6 ] {
}
}
- - Classes [6] {
+ - Classes [9] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -278,7 +280,7 @@ Extension [ <persistent> extension #144 swoole version 1.7.6 ] {
- Properties [0] {
}
- - Methods [22] {
+ - Methods [23] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -434,6 +436,9 @@ Extension [ <persistent> extension #144 swoole version 1.7.6 ] {
}
}
+ Method [ <internal:swoole> public method after ] {
+ }
+
Method [ <internal:swoole> public method stats ] {
}
}
@@ -726,6 +731,231 @@ Extension [ <persistent> extension #144 swoole version 1.7.6 ] {
}
}
}
+
+ Class [ <internal:swoole> class swoole_http_server extends swoole_server ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [23] {
+ Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method on ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $ha_name ]
+ Parameter #1 [ <required> $cb ]
+ }
+ }
+
+ Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method start ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_server, ctor> public method __construct ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $serv_host ]
+ Parameter #1 [ <required> $serv_port ]
+ Parameter #2 [ <optional> $serv_mode ]
+ Parameter #3 [ <optional> $sock_type ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method set ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $zset ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method send ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $conn_fd ]
+ Parameter #1 [ <required> $send_data ]
+ Parameter #2 [ <optional> $from_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method sendfile ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $conn_fd ]
+ Parameter #1 [ <required> $filename ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method close ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method task ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <required> $worker_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method taskwait ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> $timeout ]
+ Parameter #2 [ <optional> $worker_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method finish ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method addlistener ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $sock_type ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method addtimer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method deltimer ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method gettimer ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method reload ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method shutdown ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method hbcheck ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $from_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method heartbeat ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $from_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method handler ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $ha_name ]
+ Parameter #1 [ <required> $cb ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method connection_info ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <required> $from_id ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method connection_list ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $start_fd ]
+ Parameter #1 [ <required> $find_count ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method after ] {
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method stats ] {
+ }
+ }
+ }
+
+ Class [ <internal:swoole> class swoole_http_response ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:swoole> public method cookie ] {
+ }
+
+ Method [ <internal:swoole> public method status ] {
+ }
+
+ Method [ <internal:swoole> public method header ] {
+ }
+
+ Method [ <internal:swoole> public method end ] {
+ }
+
+ Method [ <internal:swoole> public method message ] {
+ }
+ }
+ }
+
+ Class [ <internal:swoole> class swoole_http_request ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
}
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index b197cef..2c5ce1a 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -23,13 +23,16 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.6
+Version: 1.7.7
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# https://github.com/swoole/swoole-src/pull/134
+Patch0: 134.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -102,6 +105,7 @@ mv %{pecl_name}-%{version} NTS
sed -e '/examples/s/role="src"/role="doc"/' -i package.xml
cd NTS
+%patch0 -p1 -b .pr134
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
@@ -230,11 +234,14 @@ rm -rf %{buildroot}
%changelog
+* Tue Oct 28 2014 Remi Collet <remi@fedoraproject.org> - 1.7.7-1
+- Update to 1.7.7 (stable)
+
* Fri Oct 10 2014 Remi Collet <remi@fedoraproject.org> - 1.7.6-1
-- Update to 1.7.6
+- Update to 1.7.6 (stable)
* Wed Sep 10 2014 Remi Collet <remi@fedoraproject.org> - 1.7.5-1
-- Update to 1.7.5
+- Update to 1.7.5 (stable)
* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 1.7.4-2
- improve SCL build