summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-11 14:39:55 +0200
committerRemi Collet <remi@remirepo.net>2017-08-11 14:39:55 +0200
commitbfadcceb8fa7305836d7ea41c5c31f34f2003255 (patch)
tree270bc6c0803a4bce2a22a097570e88d9e925ce4d
parentc203aebc935380c10accd9121cc78e946d23c841 (diff)
v1.9.18
-rw-r--r--REFLECTION22
-rw-r--r--php-pecl-swoole.spec7
2 files changed, 23 insertions, 6 deletions
diff --git a/REFLECTION b/REFLECTION
index e486d59..f3c9901 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #80 swoole version 1.9.17 ] {
+Extension [ <persistent> extension #80 swoole version 1.9.18 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.17 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.9.17 }
+ Constant [ string SWOOLE_VERSION ] { 1.9.18 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -247,6 +247,11 @@ Extension [ <persistent> extension #80 swoole version 1.9.17 ] {
- Parameters [0] {
}
}
+ Function [ <internal:swoole> function swoole_get_local_mac ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:swoole> function swoole_strerror ] {
- Parameters [1] {
@@ -1366,7 +1371,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.17 ] {
Method [ <internal:swoole> public method useQueue ] {
- Parameters [2] {
- Parameter #0 [ <required> $key ]
+ Parameter #0 [ <optional> $key ]
Parameter #1 [ <optional> $mode ]
}
}
@@ -2058,7 +2063,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.17 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:swoole> public method initHeader ] {
- Parameters [0] {
@@ -2114,6 +2119,15 @@ Extension [ <persistent> extension #80 swoole version 1.9.17 ] {
}
}
+ Method [ <internal:swoole> public method trailer ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ Parameter #2 [ <optional> $ucwords ]
+ }
+ }
+
Method [ <internal:swoole> public method write ] {
- Parameters [1] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index e7624e4..52201a9 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -32,8 +32,8 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.9.17
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.9.18
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -312,6 +312,9 @@ cd ../ZTS
%changelog
+* Fri Aug 11 2017 Remi Collet <remi@remirepo.net> - 1.9.18-1
+- Update to 1.9.18
+
* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 1.9.17-2
- add test and examples to devel sub-package