summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-28 08:27:16 +0200
committerRemi Collet <remi@remirepo.net>2018-03-28 08:27:16 +0200
commita38e61170140fbba81fc8d72d2a79fdd3210b526 (patch)
tree6b2f67a32fbb46c462213e6947f65d580fa5f34f
parent93986825fe6ecb8b3c19b0a056dba68983eeb870 (diff)
v1.10.3
-rw-r--r--REFLECTION39
-rw-r--r--php-pecl-swoole.spec14
2 files changed, 37 insertions, 16 deletions
diff --git a/REFLECTION b/REFLECTION
index 3541d61..9dbd5bf 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #69 swoole version 1.10.2 ] {
+Extension [ <persistent> extension #70 swoole version 1.10.3 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #69 swoole version 1.10.2 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.10.2 }
+ Constant [ string SWOOLE_VERSION ] { 1.10.3 }
Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
@@ -195,8 +195,21 @@ Extension [ <persistent> extension #69 swoole version 1.10.2 ] {
}
Function [ <internal:swoole> function swoole_event_cycle ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $callback ]
+ Parameter #1 [ <optional> $before ]
+ }
+ }
+ Function [ <internal:swoole> function swoole_event_dispatch ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:swoole> function swoole_event_isset ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $fd ]
+ Parameter #1 [ <optional> $events ]
}
}
Function [ <internal:swoole> function swoole_timer_after ] {
@@ -787,8 +800,9 @@ Extension [ <persistent> extension #69 swoole version 1.10.2 ] {
Method [ <internal:swoole> static public method cycle ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $callback ]
+ Parameter #1 [ <optional> $before ]
}
}
}
@@ -1533,7 +1547,7 @@ Extension [ <persistent> extension #69 swoole version 1.10.2 ] {
Property [ <default> public $id ]
}
- - Methods [15] {
+ - Methods [16] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [3] {
@@ -1556,6 +1570,13 @@ Extension [ <persistent> extension #69 swoole version 1.10.2 ] {
}
}
+ Method [ <internal:swoole> public method setBlocking ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $blocking ]
+ }
+ }
+
Method [ <internal:swoole> public method useQueue ] {
- Parameters [2] {
@@ -2582,13 +2603,19 @@ Extension [ <persistent> extension #69 swoole version 1.10.2 ] {
Property [ <default> public $tmpfiles ]
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:swoole> public method rawcontent ] {
- Parameters [0] {
}
}
+ Method [ <internal:swoole> public method getData ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole> public method __sleep ] {
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 3573055..4a2931b 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -36,10 +36,9 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.10.2
+Version: 1.10.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
-Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -76,14 +75,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
@@ -317,6 +308,9 @@ cd ../ZTS
%changelog
+* Wed Mar 28 2018 Remi Collet <remi@remirepo.net> - 1.10.3-1
+- update to 1.10.3 (stable)
+
* Wed Mar 14 2018 Remi Collet <remi@remirepo.net> - 1.10.2-1
- update to 1.10.2 (stable)