summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-08 07:56:26 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-08 07:56:26 +0200
commita244488b61de78f6d7853cb18b8798af846a567d (patch)
treec713b047e5600f57fbc87252030d39873839c0e6
parentebf8a9901c7556e7fdae2c8d7bae798a2f1f8478 (diff)
php-pecl-swoole: 1.7.16
-rw-r--r--REFLECTION266
-rw-r--r--php-pecl-swoole.spec5
2 files changed, 172 insertions, 99 deletions
diff --git a/REFLECTION b/REFLECTION
index 876fc53..27085ba 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
+Extension [ <persistent> extension #153 swoole version 1.7.16 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -35,11 +35,6 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
Constant [ integer SWOOLE_UDP6 ] { 4 }
Constant [ integer SWOOLE_UNIX_DGRAM ] { 5 }
Constant [ integer SWOOLE_UNIX_STREAM ] { 6 }
- Constant [ integer SWOOLE_FILELOCK ] { 2 }
- Constant [ integer SWOOLE_MUTEX ] { 3 }
- Constant [ integer SWOOLE_SEM ] { 4 }
- Constant [ integer SWOOLE_RWLOCK ] { 1 }
- Constant [ integer SWOOLE_SPINLOCK ] { 5 }
Constant [ integer SWOOLE_SOCK_SYNC ] { 0 }
Constant [ integer SWOOLE_SOCK_ASYNC ] { 1 }
Constant [ integer SWOOLE_SYNC ] { 2048 }
@@ -47,10 +42,15 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
Constant [ integer SWOOLE_KEEP ] { 512 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.15 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.16 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
+ Constant [ integer SWOOLE_FILELOCK ] { 2 }
+ Constant [ integer SWOOLE_MUTEX ] { 3 }
+ Constant [ integer SWOOLE_SEM ] { 4 }
+ Constant [ integer SWOOLE_RWLOCK ] { 1 }
+ Constant [ integer SWOOLE_SPINLOCK ] { 5 }
Constant [ integer HTTP_GLOBAL_GET ] { 2 }
Constant [ integer HTTP_GLOBAL_POST ] { 4 }
Constant [ integer HTTP_GLOBAL_COOKIE ] { 8 }
@@ -283,7 +283,7 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
}
}
- - Classes [11] {
+ - Classes [12] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -499,7 +499,7 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
}
}
- Class [ <internal:swoole> class swoole_lock ] {
+ Class [ <internal:swoole> <iterateable> class swoole_connection_iterator implements Iterator, Traversable, Countable ] {
- Constants [0] {
}
@@ -514,27 +514,45 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
}
- Methods [6] {
- Method [ <internal:swoole, ctor> public method __construct ] {
+ Method [ <internal:swoole, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:swoole> public method lock ] {
+ Method [ <internal:swoole, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:swoole> public method trylock ] {
+ Method [ <internal:swoole, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:swoole> public method lock_read ] {
+ Method [ <internal:swoole, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:swoole> public method trylock_read ] {
+ Method [ <internal:swoole, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:swoole> public method unlock ] {
+ Method [ <internal:swoole, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
}
}
}
- Class [ <internal:swoole> class swoole_process ] {
+ Class [ <internal:swoole> class swoole_client ] {
- Constants [0] {
}
@@ -542,60 +560,57 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
- Static properties [0] {
}
- - Static methods [4] {
- Method [ <internal:swoole> static public method wait ] {
- }
+ - Static methods [0] {
+ }
- Method [ <internal:swoole> static public method signal ] {
- }
+ - Properties [2] {
+ Property [ <default> public $errCode ]
+ Property [ <default> public $sock ]
+ }
- Method [ <internal:swoole> static public method kill ] {
+ - Methods [13] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
}
- Method [ <internal:swoole> static public method daemon ] {
+ Method [ <internal:swoole, dtor> public method __destruct ] {
}
- }
- - Properties [0] {
- }
-
- - Methods [11] {
- Method [ <internal:swoole, ctor> public method __construct ] {
+ Method [ <internal:swoole> public method set ] {
}
- Method [ <internal:swoole> public method useQueue ] {
+ Method [ <internal:swoole> public method connect ] {
}
- Method [ <internal:swoole> public method start ] {
+ Method [ <internal:swoole> public method recv ] {
}
- Method [ <internal:swoole> public method write ] {
+ Method [ <internal:swoole> public method send ] {
}
- Method [ <internal:swoole> public method close ] {
+ Method [ <internal:swoole> public method sendfile ] {
}
- Method [ <internal:swoole> public method read ] {
+ Method [ <internal:swoole> public method sendto ] {
}
- Method [ <internal:swoole> public method push ] {
+ Method [ <internal:swoole> public method isConnected ] {
}
- Method [ <internal:swoole> public method pop ] {
+ Method [ <internal:swoole> public method getsockname ] {
}
- Method [ <internal:swoole> public method exit ] {
+ Method [ <internal:swoole> public method getpeername ] {
}
- Method [ <internal:swoole> public method exec ] {
+ Method [ <internal:swoole> public method close ] {
}
- Method [ <internal:swoole> public method name ] {
+ Method [ <internal:swoole> public method on ] {
}
}
}
- Class [ <internal:swoole> class swoole_buffer ] {
+ Class [ <internal:swoole> class swoole_process ] {
- Constants [0] {
}
@@ -603,84 +618,58 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
- Static properties [0] {
}
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [7] {
- Method [ <internal:swoole, ctor> public method __construct ] {
- }
-
- Method [ <internal:swoole> public method substr ] {
- }
-
- Method [ <internal:swoole> public method read ] {
- }
-
- Method [ <internal:swoole> public method write ] {
+ - Static methods [4] {
+ Method [ <internal:swoole> static public method wait ] {
}
- Method [ <internal:swoole> public method append ] {
+ Method [ <internal:swoole> static public method signal ] {
}
- Method [ <internal:swoole> public method expand ] {
+ Method [ <internal:swoole> static public method kill ] {
}
- Method [ <internal:swoole> public method clear ] {
+ Method [ <internal:swoole> static public method daemon ] {
}
}
- }
-
- Class [ <internal:swoole> class swoole_client ] {
-
- - Constants [0] {
- }
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [2] {
- Property [ <default> public $errCode ]
- Property [ <default> public $sock ]
+ - Properties [0] {
}
- - Methods [11] {
+ - Methods [12] {
Method [ <internal:swoole, ctor> public method __construct ] {
}
- Method [ <internal:swoole> public method connect ] {
+ Method [ <internal:swoole, dtor> public method __destruct ] {
}
- Method [ <internal:swoole> public method recv ] {
+ Method [ <internal:swoole> public method useQueue ] {
}
- Method [ <internal:swoole> public method send ] {
+ Method [ <internal:swoole> public method start ] {
}
- Method [ <internal:swoole> public method sendfile ] {
+ Method [ <internal:swoole> public method write ] {
}
- Method [ <internal:swoole> public method sendto ] {
+ Method [ <internal:swoole> public method close ] {
}
- Method [ <internal:swoole> public method isConnected ] {
+ Method [ <internal:swoole> public method read ] {
}
- Method [ <internal:swoole> public method getsockname ] {
+ Method [ <internal:swoole> public method push ] {
}
- Method [ <internal:swoole> public method getpeername ] {
+ Method [ <internal:swoole> public method pop ] {
}
- Method [ <internal:swoole> public method close ] {
+ Method [ <internal:swoole> public method exit ] {
}
- Method [ <internal:swoole> public method on ] {
+ Method [ <internal:swoole> public method exec ] {
+ }
+
+ Method [ <internal:swoole> public method name ] {
}
}
}
@@ -709,7 +698,7 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
- Properties [0] {
}
- - Methods [16] {
+ - Methods [17] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -717,6 +706,9 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
}
}
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+ }
+
Method [ <internal:swoole> public method column ] {
- Parameters [3] {
@@ -749,8 +741,7 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
Method [ <internal:swoole, prototype Countable> public method count ] {
- - Parameters [1] {
- Parameter #0 [ <optional> $mode ]
+ - Parameters [0] {
}
}
@@ -823,6 +814,44 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
}
}
+ Class [ <internal:swoole> class swoole_lock ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+ }
+
+ Method [ <internal:swoole> public method lock ] {
+ }
+
+ Method [ <internal:swoole> public method trylock ] {
+ }
+
+ Method [ <internal:swoole> public method lock_read ] {
+ }
+
+ Method [ <internal:swoole> public method trylock_read ] {
+ }
+
+ Method [ <internal:swoole> public method unlock ] {
+ }
+ }
+ }
+
Class [ <internal:swoole> class swoole_http_server extends swoole_server ] {
- Constants [0] {
@@ -1097,6 +1126,47 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
}
}
+ Class [ <internal:swoole> class swoole_buffer ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [8] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+ }
+
+ Method [ <internal:swoole> public method substr ] {
+ }
+
+ Method [ <internal:swoole> public method read ] {
+ }
+
+ Method [ <internal:swoole> public method write ] {
+ }
+
+ Method [ <internal:swoole> public method append ] {
+ }
+
+ Method [ <internal:swoole> public method expand ] {
+ }
+
+ Method [ <internal:swoole> public method clear ] {
+ }
+ }
+ }
+
Class [ <internal:swoole> class swoole_websocket_server extends swoole_http_server ] {
- Constants [0] {
@@ -1130,15 +1200,6 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
}
}
- Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method send ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $fd ]
- Parameter #1 [ <required> $data ]
- Parameter #2 [ <optional> $from_id ]
- }
- }
-
Method [ <internal:swoole, inherits swoole_http_server> public method setglobal ] {
}
@@ -1162,6 +1223,15 @@ Extension [ <persistent> extension #153 swoole version 1.7.15 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method send ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $conn_fd ]
+ Parameter #1 [ <required> $send_data ]
+ Parameter #2 [ <optional> $from_id ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method sendto ] {
- Parameters [3] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 6196f80..bb6aeda 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -23,7 +23,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.15
+Version: 1.7.16
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
@@ -245,6 +245,9 @@ rm -rf %{buildroot}
%changelog
+* Fri May 08 2015 Remi Collet <remi@fedoraproject.org> - 1.7.16-1
+- Update to 1.7.16
+
* Tue Apr 14 2015 Remi Collet <remi@fedoraproject.org> - 1.7.15-1
- Update to 1.7.15